summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2023-11-04 11:53:32 +0000
committerKhem Raj <raj.khem@gmail.com>2023-11-06 08:47:16 -0800
commita7946f57d83f1c109335134b1f391e5c96f9763b (patch)
tree5043e2d1f81fcf8ef69e984f33dcc39802a19c2e /meta-oe/recipes-support
parent4252e49ff2e3beb5fc40cd3319da7e0f88016445 (diff)
downloadmeta-openembedded-a7946f57d83f1c109335134b1f391e5c96f9763b.tar.gz
reptyr: Add 0.10.0
reptyr is a utility for taking an existing running program and attaching it to a new terminal. Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/reptyr/reptyr_0.10.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/reptyr/reptyr_0.10.0.bb b/meta-oe/recipes-support/reptyr/reptyr_0.10.0.bb
new file mode 100644
index 000000000..57b31a78d
--- /dev/null
+++ b/meta-oe/recipes-support/reptyr/reptyr_0.10.0.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Reparent a running program to a new terminal"
2DESCRIPTION = "reptyr is a utility for taking an existing running program and \
3attaching it to a new terminal. Started a long-running process over ssh, but \
4have to leave and don't want to interrupt it? Just start a screen, use reptyr \
5to grab it, and then kill the ssh session and head on home."
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://COPYING;md5=25a0555028c71837623fa6dfa4cc45c0"
8
9SRC_URI = "git://github.com/nelhage/reptyr.git;protocol=https;branch=master"
10SRCREV = "1238097fc2cd15db058d2185cc4985daa87bcd41"
11
12S = "${WORKDIR}/git"
13
14inherit bash-completion github-releases manpages pkgconfig
15
16GITHUB_BASE_URI = "https://github.com/nelhage/${BPN}/releases/"
17
18PACKAGECONFIG ?= ""
19PACKAGECONFIG[manpages] = ""
20
21EXTRA_OEMAKE = "'BINDIR=${bindir}' 'MANDIR=${mandir}' 'PKG_CONFIG=${STAGING_BINDIR_NATIVE}/pkg-config'"
22
23do_compile () {
24 oe_runmake
25}
26
27do_install () {
28 oe_runmake install 'DESTDIR=${D}'
29}