summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-03-11 08:54:11 -0800
committerKhem Raj <raj.khem@gmail.com>2022-03-11 11:20:55 -0800
commita3f218e9db0caeb544d834a0f3f374aac7d0e4f3 (patch)
treee3e8698bb412fe24d9008cd8e56136359a9b817d /meta-oe/recipes-support
parent168a39d2bf69d547df363443014904a2293eb815 (diff)
downloadmeta-openembedded-a3f218e9db0caeb544d834a0f3f374aac7d0e4f3.tar.gz
libcereal: Link libatomics on mips for ptests
clang/mips emits calls to atomic builtins which it expects from C runtime perhaps but compiler-rt does not provide them so link in libatomics Fixes atomic.cpp:(.text._ZN6cereal12Inpu tArchiveINS_16JSONInputArchiveELj0EE7processIRNSt3__16atomicIdEEEEvOT_[_ZN6cereal12InputArchiveINS_16JSONInputArchiveELj0EE7processIRNSt3__16atomicIdEEEEvOT_]+0x10c): undefined reference to `__atomic_store_8' Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb b/meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb
index 250ea97f4..fb37de3c3 100644
--- a/meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb
+++ b/meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb
@@ -26,9 +26,10 @@ S = "${WORKDIR}/git"
26 26
27inherit cmake pkgconfig ptest 27inherit cmake pkgconfig ptest
28 28
29PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'with-tests', '', d)}" 29LIBATOMIC:mips:toolchain-clang = "${@bb.utils.contains('PTEST_ENABLED', '1', '-DCEREAL_THREAD_LIBS="-latomic"', '', d)}"
30PACKAGECONFIG[with-tests] = "-DWITH_WERROR=OFF -DBUILD_TESTS=ON,,"
31 30
31PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'with-tests', '', d)}"
32PACKAGECONFIG[with-tests] = "-DWITH_WERROR=OFF -DBUILD_TESTS=ON ${LIBATOMIC},,"
32EXTRA_OECMAKE = "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', '', '-DJUST_INSTALL_CEREAL=ON', d)} \ 33EXTRA_OECMAKE = "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', '', '-DJUST_INSTALL_CEREAL=ON', d)} \
33 ${@['','-DSKIP_PORTABILITY_TEST=ON'][d.getVar('SITEINFO_BITS') != '32']}" 34 ${@['','-DSKIP_PORTABILITY_TEST=ON'][d.getVar('SITEINFO_BITS') != '32']}"
34 35