summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-10-18 22:38:31 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-26 10:28:39 +0200
commit9db48dc417af22cb0ef62a6fa876fab550cb9974 (patch)
treead5482a0bbc3b52862cfc700fc0220915639804c /meta-oe/recipes-support
parentcc5414c232ef5679f180adbc16f0f67a997179a2 (diff)
downloadmeta-openembedded-9db48dc417af22cb0ef62a6fa876fab550cb9974.tar.gz
joe: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/joe/joe/0001-adjust-signature-of-main.patch30
-rw-r--r--meta-oe/recipes-support/joe/joe_3.1.bb4
2 files changed, 33 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/joe/joe/0001-adjust-signature-of-main.patch b/meta-oe/recipes-support/joe/joe/0001-adjust-signature-of-main.patch
new file mode 100644
index 000000000..00f48e8a2
--- /dev/null
+++ b/meta-oe/recipes-support/joe/joe/0001-adjust-signature-of-main.patch
@@ -0,0 +1,30 @@
1From 27e4639254f2b2eb7d04790bd8cf16ecfcbac1c2 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 19 Oct 2016 01:07:16 +0000
4Subject: [PATCH] adjust signature of main()
5
6clang complains about the types of main() function
7
8Upstream-Status: Pending
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 main.c | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/main.c b/main.c
16index 81ba543..ee7506c 100644
17--- a/main.c
18+++ b/main.c
19@@ -159,7 +159,7 @@ extern int breakflg;
20
21 unsigned char **mainenv;
22
23-int main(int argc, unsigned char **argv, unsigned char **envv)
24+int main(int argc, char **argv, char **envv)
25 {
26 CAP *cap;
27 unsigned char *s;
28--
291.9.1
30
diff --git a/meta-oe/recipes-support/joe/joe_3.1.bb b/meta-oe/recipes-support/joe/joe_3.1.bb
index fb9a9fbab..1ad355b5a 100644
--- a/meta-oe/recipes-support/joe/joe_3.1.bb
+++ b/meta-oe/recipes-support/joe/joe_3.1.bb
@@ -4,7 +4,9 @@ HOMEPAGE = "http://joe-editor.sourceforge.net/"
4LICENSE = "GPLv1" 4LICENSE = "GPLv1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=da10ed7cf8038981c580e11c1d3e8fb6" 5LIC_FILES_CHKSUM = "file://COPYING;md5=da10ed7cf8038981c580e11c1d3e8fb6"
6 6
7SRC_URI = "${SOURCEFORGE_MIRROR}/joe-editor/joe-${PV}.tar.gz" 7SRC_URI = "${SOURCEFORGE_MIRROR}/joe-editor/joe-${PV}.tar.gz \
8 file://0001-adjust-signature-of-main.patch \
9 "
8 10
9PACKAGECONFIG ??= "curses" 11PACKAGECONFIG ??= "curses"
10PACKAGECONFIG[curses] = "--enable-curses,--disable-curses,ncurses,ncurses-terminfo" 12PACKAGECONFIG[curses] = "--enable-curses,--disable-curses,ncurses,ncurses-terminfo"