diff options
author | André Draszik <adraszik@tycoint.com> | 2016-11-09 15:55:12 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-11-23 15:24:44 +0100 |
commit | 902a38b9891f5b3358ce5c48ee6b99bddb39d29c (patch) | |
tree | c7468259107563ddc7f36ffb9f863df681837e8f /meta-oe/recipes-support | |
parent | 334608d5ddb758b2776cd7b98cf7cdbbf6643657 (diff) | |
download | meta-openembedded-902a38b9891f5b3358ce5c48ee6b99bddb39d29c.tar.gz |
asio: fix a musl compilation warning
This is the same patch as applied to boost's copy
of asio in openembedded-core, with slightly
massaged paths
Signed-off-by: André Draszik <adraszik@tycoint.com>
Reviewed-by: Sylvain Lemieux <slemieux@tycoint.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/asio/asio/0001-use-POSIX-poll.h-instead-of-sys-poll.h.patch | 64 | ||||
-rw-r--r-- | meta-oe/recipes-support/asio/asio_1.10.6.bb | 5 |
2 files changed, 68 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/asio/asio/0001-use-POSIX-poll.h-instead-of-sys-poll.h.patch b/meta-oe/recipes-support/asio/asio/0001-use-POSIX-poll.h-instead-of-sys-poll.h.patch new file mode 100644 index 000000000..7f95f5a25 --- /dev/null +++ b/meta-oe/recipes-support/asio/asio/0001-use-POSIX-poll.h-instead-of-sys-poll.h.patch | |||
@@ -0,0 +1,64 @@ | |||
1 | From dac36a170188917e2f61b0394ba8a2f6509ddf3a Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andr=C3=A9=20Draszik?= <adraszik@tycoint.com> | ||
3 | Date: Tue, 8 Nov 2016 20:39:55 +0000 | ||
4 | Subject: [PATCH] use POSIX poll.h instead of sys/poll.h | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | POSIX specifies that <poll.h> is the correct header to | ||
10 | include for poll() | ||
11 | http://pubs.opengroup.org/onlinepubs/009695399/functions/poll.html | ||
12 | whereas <sys/poll.h> is only needed for ancient glibc (<2.3), | ||
13 | so let's follow POSIX instead. | ||
14 | |||
15 | As a side-effect, this silences numerous compilation warnings | ||
16 | when compiling against the musl C-library: | ||
17 | |||
18 | In file included from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/detail/socket_types.hpp:57:0, | ||
19 | from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/impl/error_code.ipp:29, | ||
20 | from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/error_code.hpp:185, | ||
21 | from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/detail/throw_error.hpp:19, | ||
22 | from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/detail/impl/posix_tss_ptr.ipp:23, | ||
23 | from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/detail/posix_tss_ptr.hpp:74, | ||
24 | from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/detail/tss_ptr.hpp:27, | ||
25 | from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/detail/call_stack.hpp:20, | ||
26 | from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/impl/handler_alloc_hook.ipp:19, | ||
27 | from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/handler_alloc_hook.hpp:78, | ||
28 | from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/detail/handler_alloc_helpers.hpp:21, | ||
29 | from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/detail/bind_handler.hpp:19, | ||
30 | from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/detail/wrapped_handler.hpp:18, | ||
31 | from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/io_service.hpp:24, | ||
32 | from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/basic_io_object.hpp:19, | ||
33 | from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/basic_socket.hpp:20, | ||
34 | from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/basic_datagram_socket.hpp:20, | ||
35 | from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio.hpp:19, | ||
36 | from ../../../../asio-1.10.6/src/examples/cpp03/buffers/reference_counted.cpp:11: | ||
37 | <sysroot>/usr/include/sys/poll.h:1:2: warning: #warning redirecting incorrect #include <sys/poll.h> to <poll.h> [-Wcpp] | ||
38 | #warning redirecting incorrect #include <sys/poll.h> to <poll.h> | ||
39 | ^~~~~~~ | ||
40 | |||
41 | etc. | ||
42 | |||
43 | Signed-off-by: André Draszik <adraszik@tycoint.com> | ||
44 | --- | ||
45 | Upstream-Status: Submitted https://svn.boost.org/trac/boost/ticket/12419 | ||
46 | include/asio/detail/socket_types.hpp | 2 +- | ||
47 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
48 | |||
49 | diff --git a/include/asio/detail/socket_types.hpp b/include/asio/detail/socket_types.hpp | ||
50 | index f2600c2..cb61b8e 100644 | ||
51 | --- a/include/asio/detail/socket_types.hpp | ||
52 | +++ b/include/asio/detail/socket_types.hpp | ||
53 | @@ -54,7 +54,7 @@ | ||
54 | #else | ||
55 | # include <sys/ioctl.h> | ||
56 | # if !defined(__SYMBIAN32__) | ||
57 | -# include <sys/poll.h> | ||
58 | +# include <poll.h> | ||
59 | # endif | ||
60 | # include <sys/types.h> | ||
61 | # include <sys/stat.h> | ||
62 | -- | ||
63 | 2.10.2 | ||
64 | |||
diff --git a/meta-oe/recipes-support/asio/asio_1.10.6.bb b/meta-oe/recipes-support/asio/asio_1.10.6.bb index d6f4dddc0..565603984 100644 --- a/meta-oe/recipes-support/asio/asio_1.10.6.bb +++ b/meta-oe/recipes-support/asio/asio_1.10.6.bb | |||
@@ -5,4 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fede5286a78559dd646e355ab0cc8f04" | |||
5 | SRC_URI[md5sum] = "85d014a356a6e004cd30ccd4c9b6a5c2" | 5 | SRC_URI[md5sum] = "85d014a356a6e004cd30ccd4c9b6a5c2" |
6 | SRC_URI[sha256sum] = "e0d71c40a7b1f6c1334008fb279e7361b32a063e020efd21e40d9d8ff037195e" | 6 | SRC_URI[sha256sum] = "e0d71c40a7b1f6c1334008fb279e7361b32a063e020efd21e40d9d8ff037195e" |
7 | 7 | ||
8 | SRC_URI += "file://0001-Automatically-handle-glibc-variant-of-strerror_r-wit.patch" | 8 | SRC_URI += "\ |
9 | file://0001-Automatically-handle-glibc-variant-of-strerror_r-wit.patch \ | ||
10 | file://0001-use-POSIX-poll.h-instead-of-sys-poll.h.patch \ | ||
11 | " | ||