diff options
author | Wang Mingyu <wangmy@cn.fujitsu.com> | 2020-04-24 11:11:09 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-04-25 08:32:42 -0700 |
commit | 72fd749e6423190ff5a1dbdd45d5cd4e7ebba835 (patch) | |
tree | ba546cfaa30acdb1a39912cfbd0aad515e37f90d /meta-oe/recipes-support | |
parent | 38ed9d2c5071e4fb22e7f0cfbe5351791f002e9a (diff) | |
download | meta-openembedded-72fd749e6423190ff5a1dbdd45d5cd4e7ebba835.tar.gz |
websocketpp: upgrade 0.8.1 -> 0.8.2
0001-Replace-make_shared-with-new-in-some-cases.patch
0002-Fix-missed-entries-fix-testing.patch
771.patch
842.patch
removed since they are included in 0.8.2
Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
9 files changed, 2 insertions, 202 deletions
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Replace-make_shared-with-new-in-some-cases.patch b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Replace-make_shared-with-new-in-some-cases.patch deleted file mode 100644 index 0c8285df9..000000000 --- a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Replace-make_shared-with-new-in-some-cases.patch +++ /dev/null | |||
@@ -1,78 +0,0 @@ | |||
1 | From 080fc37949114184d4832f7acffe2613745833f3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Stefan Floeren <42731906+stefan-floeren@users.noreply.github.com> | ||
3 | Date: Tue, 16 Apr 2019 08:38:01 +0200 | ||
4 | Subject: [PATCH 1/2] Replace make_shared with new in some cases | ||
5 | |||
6 | Replace make_shared for asio types that take a lib::ref as a parameter. | ||
7 | This should fix the ASIO change (boostorg/asio@59066d8) for 1.70, | ||
8 | while keeping it backwards compatible to older boost versions. | ||
9 | --- | ||
10 | websocketpp/transport/asio/connection.hpp | 7 ++++--- | ||
11 | websocketpp/transport/asio/endpoint.hpp | 3 +-- | ||
12 | websocketpp/transport/asio/security/none.hpp | 3 +-- | ||
13 | websocketpp/transport/asio/security/tls.hpp | 3 +-- | ||
14 | 4 files changed, 7 insertions(+), 9 deletions(-) | ||
15 | |||
16 | diff --git a/websocketpp/transport/asio/connection.hpp b/websocketpp/transport/asio/connection.hpp | ||
17 | index 60f88a7..1ccda8f 100644 | ||
18 | --- a/websocketpp/transport/asio/connection.hpp | ||
19 | +++ b/websocketpp/transport/asio/connection.hpp | ||
20 | @@ -311,9 +311,10 @@ public: | ||
21 | * needed. | ||
22 | */ | ||
23 | timer_ptr set_timer(long duration, timer_handler callback) { | ||
24 | - timer_ptr new_timer = lib::make_shared<lib::asio::steady_timer>( | ||
25 | - lib::ref(*m_io_service), | ||
26 | - lib::asio::milliseconds(duration) | ||
27 | + timer_ptr new_timer( | ||
28 | + new lib::asio::steady_timer( | ||
29 | + *m_io_service, | ||
30 | + lib::asio::milliseconds(duration)) | ||
31 | ); | ||
32 | |||
33 | if (config::enable_multithreading) { | ||
34 | diff --git a/websocketpp/transport/asio/endpoint.hpp b/websocketpp/transport/asio/endpoint.hpp | ||
35 | index ddab2c7..4b719a9 100644 | ||
36 | --- a/websocketpp/transport/asio/endpoint.hpp | ||
37 | +++ b/websocketpp/transport/asio/endpoint.hpp | ||
38 | @@ -195,8 +195,7 @@ public: | ||
39 | |||
40 | m_io_service = ptr; | ||
41 | m_external_io_service = true; | ||
42 | - m_acceptor = lib::make_shared<lib::asio::ip::tcp::acceptor>( | ||
43 | - lib::ref(*m_io_service)); | ||
44 | + m_acceptor.reset(new lib::asio::ip::tcp::acceptor(*m_io_service)); | ||
45 | |||
46 | m_state = READY; | ||
47 | ec = lib::error_code(); | ||
48 | diff --git a/websocketpp/transport/asio/security/none.hpp b/websocketpp/transport/asio/security/none.hpp | ||
49 | index 5c8293d..6c7d352 100644 | ||
50 | --- a/websocketpp/transport/asio/security/none.hpp | ||
51 | +++ b/websocketpp/transport/asio/security/none.hpp | ||
52 | @@ -168,8 +168,7 @@ protected: | ||
53 | return socket::make_error_code(socket::error::invalid_state); | ||
54 | } | ||
55 | |||
56 | - m_socket = lib::make_shared<lib::asio::ip::tcp::socket>( | ||
57 | - lib::ref(*service)); | ||
58 | + m_socket.reset(new lib::asio::ip::tcp::socket(*service)); | ||
59 | |||
60 | if (m_socket_init_handler) { | ||
61 | m_socket_init_handler(m_hdl, *m_socket); | ||
62 | diff --git a/websocketpp/transport/asio/security/tls.hpp b/websocketpp/transport/asio/security/tls.hpp | ||
63 | index c76fd9a..04ac379 100644 | ||
64 | --- a/websocketpp/transport/asio/security/tls.hpp | ||
65 | +++ b/websocketpp/transport/asio/security/tls.hpp | ||
66 | @@ -193,8 +193,7 @@ protected: | ||
67 | if (!m_context) { | ||
68 | return socket::make_error_code(socket::error::invalid_tls_context); | ||
69 | } | ||
70 | - m_socket = lib::make_shared<socket_type>( | ||
71 | - _WEBSOCKETPP_REF(*service),lib::ref(*m_context)); | ||
72 | + m_socket.reset(new socket_type(*service, *m_context)); | ||
73 | |||
74 | if (m_socket_init_handler) { | ||
75 | m_socket_init_handler(m_hdl, get_socket()); | ||
76 | -- | ||
77 | 2.23.0 | ||
78 | |||
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0002-Fix-missed-entries-fix-testing.patch b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0002-Fix-missed-entries-fix-testing.patch deleted file mode 100644 index 962d08967..000000000 --- a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0002-Fix-missed-entries-fix-testing.patch +++ /dev/null | |||
@@ -1,66 +0,0 @@ | |||
1 | From 12ab603ca962e83591985a585451d33544d75d56 Mon Sep 17 00:00:00 2001 | ||
2 | From: Stefan Floeren <42731906+stefan-floeren@users.noreply.github.com> | ||
3 | Date: Wed, 17 Apr 2019 10:06:18 +0000 | ||
4 | Subject: [PATCH 2/2] Fix missed entries; fix testing | ||
5 | |||
6 | --- | ||
7 | CMakeLists.txt | 2 +- | ||
8 | websocketpp/transport/asio/connection.hpp | 3 +-- | ||
9 | websocketpp/transport/asio/endpoint.hpp | 7 ++----- | ||
10 | 3 files changed, 4 insertions(+), 8 deletions(-) | ||
11 | |||
12 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
13 | index 2786aba..951de97 100644 | ||
14 | --- a/CMakeLists.txt | ||
15 | +++ b/CMakeLists.txt | ||
16 | @@ -202,7 +202,7 @@ if (BUILD_TESTS OR BUILD_EXAMPLES) | ||
17 | endif () | ||
18 | |||
19 | if (NOT Boost_USE_STATIC_LIBS) | ||
20 | - add_definitions (/DBOOST_TEST_DYN_LINK) | ||
21 | + add_definitions (-DBOOST_TEST_DYN_LINK) | ||
22 | endif () | ||
23 | |||
24 | set (Boost_FIND_REQUIRED TRUE) | ||
25 | diff --git a/websocketpp/transport/asio/connection.hpp b/websocketpp/transport/asio/connection.hpp | ||
26 | index 1ccda8f..57dda74 100644 | ||
27 | --- a/websocketpp/transport/asio/connection.hpp | ||
28 | +++ b/websocketpp/transport/asio/connection.hpp | ||
29 | @@ -462,8 +462,7 @@ protected: | ||
30 | m_io_service = io_service; | ||
31 | |||
32 | if (config::enable_multithreading) { | ||
33 | - m_strand = lib::make_shared<lib::asio::io_service::strand>( | ||
34 | - lib::ref(*io_service)); | ||
35 | + m_strand.reset(new lib::asio::io_service::strand(*io_service)); | ||
36 | } | ||
37 | |||
38 | lib::error_code ec = socket_con_type::init_asio(io_service, m_strand, | ||
39 | diff --git a/websocketpp/transport/asio/endpoint.hpp b/websocketpp/transport/asio/endpoint.hpp | ||
40 | index 4b719a9..94509ad 100644 | ||
41 | --- a/websocketpp/transport/asio/endpoint.hpp | ||
42 | +++ b/websocketpp/transport/asio/endpoint.hpp | ||
43 | @@ -687,9 +687,7 @@ public: | ||
44 | * @since 0.3.0 | ||
45 | */ | ||
46 | void start_perpetual() { | ||
47 | - m_work = lib::make_shared<lib::asio::io_service::work>( | ||
48 | - lib::ref(*m_io_service) | ||
49 | - ); | ||
50 | + m_work.reset(new lib::asio::io_service::work(*m_io_service)); | ||
51 | } | ||
52 | |||
53 | /// Clears the endpoint's perpetual flag, allowing it to exit when empty | ||
54 | @@ -853,8 +851,7 @@ protected: | ||
55 | |||
56 | // Create a resolver | ||
57 | if (!m_resolver) { | ||
58 | - m_resolver = lib::make_shared<lib::asio::ip::tcp::resolver>( | ||
59 | - lib::ref(*m_io_service)); | ||
60 | + m_resolver.reset(new lib::asio::ip::tcp::resolver(*m_io_service)); | ||
61 | } | ||
62 | |||
63 | tcon->set_uri(u); | ||
64 | -- | ||
65 | 2.23.0 | ||
66 | |||
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/771.patch b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/771.patch deleted file mode 100644 index bc65efb7d..000000000 --- a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/771.patch +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | From 4bccfb04a264704ec9b80ba332ee1cf113ce7f1b Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Wolfgang=20St=C3=B6ggl?= <c72578@yahoo.de> | ||
3 | Date: Thu, 1 Nov 2018 20:58:10 +0100 | ||
4 | Subject: [PATCH] Update version number in CMakeLists.txt to 0.8.1 | ||
5 | |||
6 | --- | ||
7 | CMakeLists.txt | 2 +- | ||
8 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
11 | index 2786aba9..2d13117b 100644 | ||
12 | --- a/CMakeLists.txt | ||
13 | +++ b/CMakeLists.txt | ||
14 | @@ -24,7 +24,7 @@ endif () | ||
15 | ############ Project name and version | ||
16 | set (WEBSOCKETPP_MAJOR_VERSION 0) | ||
17 | set (WEBSOCKETPP_MINOR_VERSION 8) | ||
18 | -set (WEBSOCKETPP_PATCH_VERSION 0) | ||
19 | +set (WEBSOCKETPP_PATCH_VERSION 1) | ||
20 | set (WEBSOCKETPP_VERSION ${WEBSOCKETPP_MAJOR_VERSION}.${WEBSOCKETPP_MINOR_VERSION}.${WEBSOCKETPP_PATCH_VERSION}) | ||
21 | |||
22 | if(POLICY CMP0048) | ||
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/842.patch b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/842.patch deleted file mode 100644 index c3651e94a..000000000 --- a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/842.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | From 7f7e2be01b4fa6580ce27f668e61adf37853ad67 Mon Sep 17 00:00:00 2001 | ||
2 | From: Schrijvers Luc <begasus@gmail.com> | ||
3 | Date: Wed, 18 Sep 2019 11:35:43 +0200 | ||
4 | Subject: [PATCH] Fix "include" directory installation. the variable | ||
5 | INSTALL_INCLUDE_DIR already exists, and defaults to include if not | ||
6 | specificied otherwise. Using it allows people to customize the installation | ||
7 | from outside, fixing issues with other OS like Haiku | ||
8 | |||
9 | Signed-off-by: Gianfranco Costamagna <costamagnagianfranco@yahoo.it> | ||
10 | Signed-off-by: Gianfranco Costamagna <locutusofborg@debian.org> | ||
11 | --- | ||
12 | cmake/CMakeHelpers.cmake | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/cmake/CMakeHelpers.cmake b/cmake/CMakeHelpers.cmake | ||
16 | index 1478f4b..f603632 100644 | ||
17 | --- a/cmake/CMakeHelpers.cmake | ||
18 | +++ b/cmake/CMakeHelpers.cmake | ||
19 | @@ -80,7 +80,7 @@ macro (final_target) | ||
20 | endif () | ||
21 | |||
22 | install (DIRECTORY ${CMAKE_SOURCE_DIR}/${TARGET_NAME} | ||
23 | - DESTINATION include/ | ||
24 | + DESTINATION ${INSTALL_INCLUDE_DIR}/ | ||
25 | FILES_MATCHING PATTERN "*.hpp*") | ||
26 | endmacro () | ||
27 | |||
28 | -- | ||
29 | 2.17.1 | ||
30 | |||
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Correct-clang-compiler-flags.patch b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.2/0001-Correct-clang-compiler-flags.patch index f1d037fae..f1d037fae 100644 --- a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Correct-clang-compiler-flags.patch +++ b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.2/0001-Correct-clang-compiler-flags.patch | |||
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-cmake-Use-GNUInstallDirs.patch b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.2/0001-cmake-Use-GNUInstallDirs.patch index 0ef2e1237..0ef2e1237 100644 --- a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-cmake-Use-GNUInstallDirs.patch +++ b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.2/0001-cmake-Use-GNUInstallDirs.patch | |||
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/855.patch b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.2/855.patch index a1ee627b3..a1ee627b3 100644 --- a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/855.patch +++ b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.2/855.patch | |||
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/857.patch b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.2/857.patch index f221cd699..f221cd699 100644 --- a/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/857.patch +++ b/meta-oe/recipes-support/websocketpp/websocketpp-0.8.2/857.patch | |||
diff --git a/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb b/meta-oe/recipes-support/websocketpp/websocketpp_0.8.2.bb index af6d30a28..79a5ac5c4 100644 --- a/meta-oe/recipes-support/websocketpp/websocketpp_0.8.1.bb +++ b/meta-oe/recipes-support/websocketpp/websocketpp_0.8.2.bb | |||
@@ -7,11 +7,7 @@ LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=4d168d763c111f4ffc62249870e4e0ea" | |||
7 | DEPENDS = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'openssl boost zlib', '', d)} " | 7 | DEPENDS = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'openssl boost zlib', '', d)} " |
8 | 8 | ||
9 | SRC_URI = "git://github.com/zaphoyd/websocketpp.git;protocol=https \ | 9 | SRC_URI = "git://github.com/zaphoyd/websocketpp.git;protocol=https \ |
10 | file://0001-Replace-make_shared-with-new-in-some-cases.patch \ | ||
11 | file://0002-Fix-missed-entries-fix-testing.patch \ | ||
12 | file://0001-cmake-Use-GNUInstallDirs.patch \ | 10 | file://0001-cmake-Use-GNUInstallDirs.patch \ |
13 | file://842.patch \ | ||
14 | file://771.patch \ | ||
15 | file://855.patch \ | 11 | file://855.patch \ |
16 | file://857.patch \ | 12 | file://857.patch \ |
17 | file://0001-Correct-clang-compiler-flags.patch \ | 13 | file://0001-Correct-clang-compiler-flags.patch \ |
@@ -25,8 +21,8 @@ RDEPENDS_${PN}-dev = "" | |||
25 | # to add this package to an SDK, since it isn't a reverse-dependency of anything, just use something like this: | 21 | # to add this package to an SDK, since it isn't a reverse-dependency of anything, just use something like this: |
26 | # TOOLCHAIN_TARGET_TASK_append = " websocketpp-dev" | 22 | # TOOLCHAIN_TARGET_TASK_append = " websocketpp-dev" |
27 | 23 | ||
28 | # tag 0.8.1 | 24 | # tag 0.8.2 |
29 | SRCREV= "c6d7e295bf5a0ab9b5f896720cc1a0e0fdc397a7" | 25 | SRCREV= "56123c87598f8b1dd471be83ca841ceae07f95ba" |
30 | 26 | ||
31 | S = "${WORKDIR}/git" | 27 | S = "${WORKDIR}/git" |
32 | 28 | ||