diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2019-09-25 14:14:58 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-09-25 09:48:19 -0700 |
commit | 54f0796cb0f2ca98d4513e6434e4517fbc6b8067 (patch) | |
tree | 8240a2f0c418d7a6551ca6cfda57de70722c1411 /meta-oe/recipes-support | |
parent | c636bc25dba745eb459cc6d55b0d86ef09253016 (diff) | |
download | meta-openembedded-54f0796cb0f2ca98d4513e6434e4517fbc6b8067.tar.gz |
libmicrohttpd: backport the fix for building with older gnutls
* with gnutls from meta-gplv2 libmicrohttpd fails to build now:
libmicrohttpd-0.9.66/src/microhttpd/daemon.c:2539:7: error: unknown type name 'gnutls_init_flags_t'; did you mean 'gnutls_pin_flag_t'?
2539 | gnutls_init_flags_t flags;
backport the fix from master branch
* see https://bugs.gnunet.org/view.php?id=5806
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/libmicrohttpd/libmicrohttpd/fix-build-with-older-gnutls.patch | 32 | ||||
-rw-r--r-- | meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.66.bb | 4 |
2 files changed, 35 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd/fix-build-with-older-gnutls.patch b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd/fix-build-with-older-gnutls.patch new file mode 100644 index 000000000..61a7ac0a6 --- /dev/null +++ b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd/fix-build-with-older-gnutls.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From b84ee1fa41c53c43aa7ed1583c36af5cb7c77a0f Mon Sep 17 00:00:00 2001 | ||
2 | From: Christian Grothoff <christian@grothoff.org> | ||
3 | Date: Fri, 2 Aug 2019 15:43:44 +0200 | ||
4 | Subject: trying to fix #5806 | ||
5 | |||
6 | Upstream-Status: Backport from 0.9.67 [https://git.gnunet.org/libmicrohttpd.git/commit/?id=b84ee1fa41c53c43aa7ed1583c36af5cb7c77a0f] | ||
7 | |||
8 | --- | ||
9 | src/microhttpd/daemon.c | 7 ++++++- | ||
10 | 1 file changed, 6 insertions(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/src/microhttpd/daemon.c b/src/microhttpd/daemon.c | ||
13 | index bf01ba9b..a8fc98c6 100644 | ||
14 | --- a/src/microhttpd/daemon.c | ||
15 | +++ b/src/microhttpd/daemon.c | ||
16 | @@ -2536,7 +2536,12 @@ internal_add_connection (struct MHD_Daemon *daemon, | ||
17 | else | ||
18 | { | ||
19 | #ifdef HTTPS_SUPPORT | ||
20 | - gnutls_init_flags_t flags; | ||
21 | +#if (GNUTLS_VERSION_NUMBER+0 >= 0x030500) | ||
22 | + gnutls_init_flags_t | ||
23 | +#else | ||
24 | + unsigned int | ||
25 | +#endif | ||
26 | + flags; | ||
27 | |||
28 | flags = GNUTLS_SERVER; | ||
29 | #if (GNUTLS_VERSION_NUMBER+0 >= 0x030402) | ||
30 | -- | ||
31 | cgit v1.2.1 | ||
32 | |||
diff --git a/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.66.bb b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.66.bb index 7d349b94e..6b5417004 100644 --- a/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.66.bb +++ b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.66.bb | |||
@@ -6,7 +6,9 @@ SECTION = "net" | |||
6 | 6 | ||
7 | DEPENDS = "file" | 7 | DEPENDS = "file" |
8 | 8 | ||
9 | SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz" | 9 | SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz \ |
10 | file://fix-build-with-older-gnutls.patch \ | ||
11 | " | ||
10 | SRC_URI[md5sum] = "ce4050e75cc40d68506e2b403e1a76f9" | 12 | SRC_URI[md5sum] = "ce4050e75cc40d68506e2b403e1a76f9" |
11 | SRC_URI[sha256sum] = "4e66d4db1574f4912fbd2690d10d227cc9cc56df6a10aa8f4fc2da75cea7ab1b" | 13 | SRC_URI[sha256sum] = "4e66d4db1574f4912fbd2690d10d227cc9cc56df6a10aa8f4fc2da75cea7ab1b" |
12 | 14 | ||