diff options
author | Bartosz Golaszewski <bgolaszewski@baylibre.com> | 2019-07-27 22:30:20 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-11-17 12:34:21 -0800 |
commit | 4339c28ff4aa0264c34f4f183349aea20a5ff127 (patch) | |
tree | 58e1fbf2bf2c35d6c07eaa47cd8aa6df5633d017 /meta-oe/recipes-support | |
parent | 599304fb377187eb900261d4eda66de39abaf664 (diff) | |
download | meta-openembedded-4339c28ff4aa0264c34f4f183349aea20a5ff127.tar.gz |
libgpiod: put gpio utils into an actual separate package
Currently tools are built conditionally depending on whether the
corresponding PACKAGECONFIG option has been set and, although they
live in a separate libgpiod-tools package, the user cannot simply
select it - he has to additionally extend PACKAGECONFIG. While this
makes sense for python and C++ bindings, the tools don't have any
dependencies other the libgpiod. Make libgpiod-tools an actual
stand-alone package: always build them but install them only if
user selected libgpiod-tools.
Disable setting tools in default PACKAGECONFIGS
Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
s
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/libgpiod/libgpiod.inc | 6 | ||||
-rw-r--r-- | meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb | 3 | ||||
-rw-r--r-- | meta-oe/recipes-support/libgpiod/libgpiod_1.4.1.bb | 4 |
3 files changed, 5 insertions, 8 deletions
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod.inc b/meta-oe/recipes-support/libgpiod/libgpiod.inc index 89679cb91..07ce35a7f 100644 --- a/meta-oe/recipes-support/libgpiod/libgpiod.inc +++ b/meta-oe/recipes-support/libgpiod/libgpiod.inc | |||
@@ -8,11 +8,9 @@ SRC_URI = "https://www.kernel.org/pub/software/libs/libgpiod/${BP}.tar.xz" | |||
8 | inherit autotools pkgconfig | 8 | inherit autotools pkgconfig |
9 | 9 | ||
10 | PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev" | 10 | PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev" |
11 | PACKAGECONFIG[tools] = "--enable-tools,--disable-tools," | 11 | |
12 | EXTRA_OECONF = "--enable-tools" | ||
12 | 13 | ||
13 | PACKAGES =+ " ${PN}-tools" | 14 | PACKAGES =+ " ${PN}-tools" |
14 | 15 | ||
15 | FILES_${PN}-tools = "${bindir}/*" | 16 | FILES_${PN}-tools = "${bindir}/*" |
16 | |||
17 | RRECOMMENDS_TOOLS = "${@bb.utils.contains('PACKAGECONFIG', 'tools', '${PN}-tools', '',d)}" | ||
18 | RRECOMMENDS_${PN} += "${RRECOMMENDS_TOOLS}" | ||
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb b/meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb index 3ecfffdd6..c4d2bddf4 100644 --- a/meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb +++ b/meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb | |||
@@ -1,7 +1,6 @@ | |||
1 | require libgpiod.inc | 1 | require libgpiod.inc |
2 | 2 | ||
3 | # enable tools | 3 | PACKAGECONFIG ?= "" |
4 | PACKAGECONFIG ?= "tools" | ||
5 | 4 | ||
6 | PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev" | 5 | PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev" |
7 | 6 | ||
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_1.4.1.bb b/meta-oe/recipes-support/libgpiod/libgpiod_1.4.1.bb index d55902898..0391deb86 100644 --- a/meta-oe/recipes-support/libgpiod/libgpiod_1.4.1.bb +++ b/meta-oe/recipes-support/libgpiod/libgpiod_1.4.1.bb | |||
@@ -5,8 +5,8 @@ DEPENDS += "autoconf-archive-native" | |||
5 | SRC_URI[md5sum] = "585b4bb431f99c4ba9b3ee58b9d494c1" | 5 | SRC_URI[md5sum] = "585b4bb431f99c4ba9b3ee58b9d494c1" |
6 | SRC_URI[sha256sum] = "21ae8fd1f8dafc2eb2ba50e652390cf533d21351419a7426255895cb52e21b1c" | 6 | SRC_URI[sha256sum] = "21ae8fd1f8dafc2eb2ba50e652390cf533d21351419a7426255895cb52e21b1c" |
7 | 7 | ||
8 | # enable tools and cxx bindings | 8 | # enable cxx bindings |
9 | PACKAGECONFIG ?= "cxx tools" | 9 | PACKAGECONFIG ?= "cxx" |
10 | 10 | ||
11 | PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx" | 11 | PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx" |
12 | PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev" | 12 | PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev" |