summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorchangqing.li@windriver.com <changqing.li@windriver.com>2018-06-29 14:22:17 +0800
committerKhem Raj <raj.khem@gmail.com>2018-06-29 07:00:52 -0700
commit318c9572d26b8ff16b3b6ba43c22c11894f6dde2 (patch)
tree1a17498c9fd91b9aaddc40ce62e79b0df91c1679 /meta-oe/recipes-support
parent6e47ace16f6914d8a0006c790a2dfdff02468ade (diff)
downloadmeta-openembedded-318c9572d26b8ff16b3b6ba43c22c11894f6dde2.tar.gz
vim/vim-tiny: upgrade 8.0.0983 -> 8.1.0.116
Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/vim/files/CVE-2017-17087.patch70
-rw-r--r--meta-oe/recipes-support/vim/files/disable_acl_header_check.patch28
-rw-r--r--meta-oe/recipes-support/vim/files/vim-add-knob-whether-elf.h-are-checked.patch16
-rw-r--r--meta-oe/recipes-support/vim/vim-tiny_8.1.0.116.bb (renamed from meta-oe/recipes-support/vim/vim-tiny_8.0.0983.bb)0
-rw-r--r--meta-oe/recipes-support/vim/vim_8.1.0.116.bb (renamed from meta-oe/recipes-support/vim/vim_8.0.0983.bb)7
5 files changed, 33 insertions, 88 deletions
diff --git a/meta-oe/recipes-support/vim/files/CVE-2017-17087.patch b/meta-oe/recipes-support/vim/files/CVE-2017-17087.patch
deleted file mode 100644
index 937b9ba31..000000000
--- a/meta-oe/recipes-support/vim/files/CVE-2017-17087.patch
+++ /dev/null
@@ -1,70 +0,0 @@
1From 9c11f80339372b7aa2f43153d574f2b5abb79708 Mon Sep 17 00:00:00 2001
2From: Li Zhou <li.zhou@windriver.com>
3Date: Sun, 17 Dec 2017 23:09:35 -0800
4Subject: [PATCH] vim: patch 8.0.1263: others can read the swap file if a user
5 is careless
6
7Problem: Others can read the swap file if a user is careless with his
8 primary group.
9Solution: If the group permission allows for reading but the world
10 permissions doesn't, make sure the group is right.
11
12Upstream-Status: Backport
13CVE: CVE-2017-17087
14Signed-off-by: Li Zhou <li.zhou@windriver.com>
15---
16 src/fileio.c | 24 +++++++++++++++++++++++-
17 src/version.c | 2 ++
18 2 files changed, 25 insertions(+), 1 deletion(-)
19
20diff --git a/src/fileio.c b/src/fileio.c
21index f54fb8465..2c7740af9 100644
22--- a/src/fileio.c
23+++ b/src/fileio.c
24@@ -716,7 +716,29 @@ readfile(
25 /* Set swap file protection bits after creating it. */
26 if (swap_mode > 0 && curbuf->b_ml.ml_mfp != NULL
27 && curbuf->b_ml.ml_mfp->mf_fname != NULL)
28- (void)mch_setperm(curbuf->b_ml.ml_mfp->mf_fname, (long)swap_mode);
29+ {
30+ char_u *swap_fname = curbuf->b_ml.ml_mfp->mf_fname;
31+
32+ /*
33+ * If the group-read bit is set but not the world-read bit, then
34+ * the group must be equal to the group of the original file. If
35+ * we can't make that happen then reset the group-read bit. This
36+ * avoids making the swap file readable to more users when the
37+ * primary group of the user is too permissive.
38+ */
39+ if ((swap_mode & 044) == 040)
40+ {
41+ stat_T swap_st;
42+
43+ if (mch_stat((char *)swap_fname, &swap_st) >= 0
44+ && st.st_gid != swap_st.st_gid
45+ && fchown(curbuf->b_ml.ml_mfp->mf_fd, -1, st.st_gid)
46+ == -1)
47+ swap_mode &= 0600;
48+ }
49+
50+ (void)mch_setperm(swap_fname, (long)swap_mode);
51+ }
52 #endif
53 }
54
55diff --git a/src/version.c b/src/version.c
56index a5cb078f0..5c0df475f 100644
57--- a/src/version.c
58+++ b/src/version.c
59@@ -770,6 +770,8 @@ static char *(features[]) =
60 static int included_patches[] =
61 { /* Add new patch number below this line */
62 /**/
63+ 1263,
64+/**/
65 983,
66 /**/
67 982,
68--
692.11.0
70
diff --git a/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch b/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch
index 65e5f58c6..4720003c2 100644
--- a/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch
+++ b/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch
@@ -1,14 +1,23 @@
1Upstream-Status: pending 1From 5ed25c076a1fb1889a3c50dddf29f21850b59a13 Mon Sep 17 00:00:00 2001
2From: Wenzong Fan <wenzong.fan@windriver.com>
3Date: Tue, 26 Jun 2018 17:29:09 +0800
4Subject: [PATCH] disable acl header check
2 5
3Don't check 'sys/acl.h' if acl support disabled for vim/vim-tiny. 6Don't check 'sys/acl.h' if acl support disabled for vim/vim-tiny.
4 7
8Upstream-Status: pending
9
5Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> 10Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
6================================================ 11Signed-off-by: Changqing Li <changqing.li@windriver.com>
12---
13 src/configure.ac | 3 ++-
14 1 file changed, 2 insertions(+), 1 deletion(-)
15
7diff --git a/src/configure.ac b/src/configure.ac 16diff --git a/src/configure.ac b/src/configure.ac
8index fb965e5..d734064 100644 17index 107c170..0ee86ad 100644
9--- a/src/configure.ac 18--- a/src/configure.ac
10+++ b/src/configure.ac 19+++ b/src/configure.ac
11@@ -2511,7 +2511,7 @@ AC_CHECK_HEADERS(stdarg.h stdint.h stdlib.h string.h \ 20@@ -3220,7 +3220,7 @@ AC_CHECK_HEADERS(stdint.h stdlib.h string.h \
12 sys/systeminfo.h locale.h sys/stream.h termios.h \ 21 sys/systeminfo.h locale.h sys/stream.h termios.h \
13 libc.h sys/statfs.h poll.h sys/poll.h pwd.h \ 22 libc.h sys/statfs.h poll.h sys/poll.h pwd.h \
14 utime.h sys/param.h libintl.h libgen.h \ 23 utime.h sys/param.h libintl.h libgen.h \
@@ -17,11 +26,14 @@ index fb965e5..d734064 100644
17 sys/access.h sys/sysinfo.h wchar.h wctype.h) 26 sys/access.h sys/sysinfo.h wchar.h wctype.h)
18 27
19 dnl sys/ptem.h depends on sys/stream.h on Solaris 28 dnl sys/ptem.h depends on sys/stream.h on Solaris
20@@ -3112,6 +3112,7 @@ AC_ARG_ENABLE(acl, 29@@ -3848,6 +3848,7 @@ AC_ARG_ENABLE(acl,
21 , [enable_acl="yes"]) 30 , [enable_acl="yes"])
22 if test "$enable_acl" = "yes"; then 31 if test "$enable_acl" = "yes"; then
23 AC_MSG_RESULT(no) 32 AC_MSG_RESULT(no)
24+AC_CHECK_HEADERS(sys/acl.h) 33+ AC_CHECK_HEADERS(sys/acl.h)
25 AC_CHECK_LIB(posix1e, acl_get_file, [LIBS="$LIBS -lposix1e"], 34 AC_CHECK_LIB(posix1e, acl_get_file, [LIBS="$LIBS -lposix1e"],
26 AC_CHECK_LIB(acl, acl_get_file, [LIBS="$LIBS -lacl" 35 AC_CHECK_LIB(acl, acl_get_file, [LIBS="$LIBS -lacl"
27 AC_CHECK_LIB(attr, fgetxattr, LIBS="$LIBS -lattr",,)],,),) 36 AC_CHECK_LIB(attr, fgetxattr, LIBS="$LIBS -lattr",,)],,),)
37--
382.7.4
39
diff --git a/meta-oe/recipes-support/vim/files/vim-add-knob-whether-elf.h-are-checked.patch b/meta-oe/recipes-support/vim/files/vim-add-knob-whether-elf.h-are-checked.patch
index 6c620f9f2..37914d4cd 100644
--- a/meta-oe/recipes-support/vim/files/vim-add-knob-whether-elf.h-are-checked.patch
+++ b/meta-oe/recipes-support/vim/files/vim-add-knob-whether-elf.h-are-checked.patch
@@ -1,20 +1,24 @@
1vim: add knob whether elf.h are checked 1From 38de4bccdb8a861ffdd447f12fdab19d6d852c02 Mon Sep 17 00:00:00 2001
2From: Chong Lu <Chong.Lu@windriver.com>
3Date: Tue, 26 Jun 2018 17:34:15 +0800
4Subject: [PATCH] vim: add knob whether elf.h are checked
2 5
3Previously, it still was checked when there was no elf library in sysroots directory. 6Previously, it still was checked when there was no elf library in sysroots directory.
4Add knob to decide whether elf.h are checked or not. 7Add knob to decide whether elf.h are checked or not.
5 8
6Upstream-status: Pending 9Upstream-Status: Pending
7 10
8Signed-off-by: Chong Lu <Chong.Lu@windriver.com> 11Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
12Signed-off-by: Changqing Li <changqing.li@windriver.com>
9--- 13---
10 src/configure.ac | 7 +++++++ 14 src/configure.ac | 7 +++++++
11 1 file changed, 7 insertions(+) 15 1 file changed, 7 insertions(+)
12 16
13diff --git a/src/configure.ac b/src/configure.ac 17diff --git a/src/configure.ac b/src/configure.ac
14index d734064..f504fa6 100644 18index 0ee86ad..64736f0 100644
15--- a/src/configure.ac 19--- a/src/configure.ac
16+++ b/src/configure.ac 20+++ b/src/configure.ac
17@@ -2483,11 +2483,18 @@ AC_TRY_COMPILE([#include <stdio.h>], [int x __attribute__((unused));], 21@@ -3192,11 +3192,18 @@ AC_TRY_COMPILE([#include <stdio.h>], [int x __attribute__((unused));],
18 AC_MSG_RESULT(no)) 22 AC_MSG_RESULT(no))
19 23
20 dnl Checks for header files. 24 dnl Checks for header files.
@@ -34,5 +38,5 @@ index d734064..f504fa6 100644
34 AC_HEADER_DIRENT 38 AC_HEADER_DIRENT
35 39
36-- 40--
371.7.9.5 412.7.4
38 42
diff --git a/meta-oe/recipes-support/vim/vim-tiny_8.0.0983.bb b/meta-oe/recipes-support/vim/vim-tiny_8.1.0.116.bb
index bb8f2b7ea..bb8f2b7ea 100644
--- a/meta-oe/recipes-support/vim/vim-tiny_8.0.0983.bb
+++ b/meta-oe/recipes-support/vim/vim-tiny_8.1.0.116.bb
diff --git a/meta-oe/recipes-support/vim/vim_8.0.0983.bb b/meta-oe/recipes-support/vim/vim_8.1.0.116.bb
index 44c868c74..f669dfea4 100644
--- a/meta-oe/recipes-support/vim/vim_8.0.0983.bb
+++ b/meta-oe/recipes-support/vim/vim_8.1.0.116.bb
@@ -4,14 +4,13 @@ DEPENDS = "ncurses gettext-native"
4# vimdiff doesn't like busybox diff 4# vimdiff doesn't like busybox diff
5RSUGGESTS_${PN} = "diffutils" 5RSUGGESTS_${PN} = "diffutils"
6LICENSE = "vim" 6LICENSE = "vim"
7LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=eea32ac1424bba14096736a494ae9045" 7LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=b6eb9d541de3933cc8f48125ae0335fe"
8 8
9SRC_URI = "git://github.com/vim/vim.git \ 9SRC_URI = "git://github.com/vim/vim.git \
10 file://disable_acl_header_check.patch;patchdir=.. \ 10 file://disable_acl_header_check.patch;patchdir=.. \
11 file://vim-add-knob-whether-elf.h-are-checked.patch;patchdir=.. \ 11 file://vim-add-knob-whether-elf.h-are-checked.patch;patchdir=.. \
12 file://CVE-2017-17087.patch;patchdir=.. \
13" 12"
14SRCREV = "3f9a1ff141412e9e85f7dff47d02946cb9be9228" 13SRCREV = "a87b72cc316e065d66dcbcf7ec1cde330adef3a3"
15 14
16S = "${WORKDIR}/git/src" 15S = "${WORKDIR}/git/src"
17 16
@@ -54,7 +53,7 @@ EXTRA_OECONF = " \
54 vim_cv_memmove_handles_overlap=yes \ 53 vim_cv_memmove_handles_overlap=yes \
55 vim_cv_stat_ignores_slash=no \ 54 vim_cv_stat_ignores_slash=no \
56 vim_cv_terminfo=yes \ 55 vim_cv_terminfo=yes \
57 vim_cv_tgent=non-zero \ 56 vim_cv_tgetent=non-zero \
58 vim_cv_toupper_broken=no \ 57 vim_cv_toupper_broken=no \
59 vim_cv_tty_group=world \ 58 vim_cv_tty_group=world \
60 STRIP=/bin/true \ 59 STRIP=/bin/true \