diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-11-16 14:39:38 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-11-17 12:34:21 -0800 |
commit | 0e67e06127ca1a314e2ff69b7586e5b4651e49ee (patch) | |
tree | 1e9d6e98f66d735842da0ec4d5a14247c4fb156d /meta-oe/recipes-support | |
parent | a1c37384e45c5db30d59b07d8f1fa72877a594cf (diff) | |
download | meta-openembedded-0e67e06127ca1a314e2ff69b7586e5b4651e49ee.tar.gz |
pidgin-sipe: Fix another case of struct incompatiblility due to 64bit time_t
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/pidgin/pidgin-sipe/0001-Align-structs-casts-with-time_t-elements-to-8byte-bo.patch | 50 | ||||
-rw-r--r-- | meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb | 1 |
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/pidgin/pidgin-sipe/0001-Align-structs-casts-with-time_t-elements-to-8byte-bo.patch b/meta-oe/recipes-support/pidgin/pidgin-sipe/0001-Align-structs-casts-with-time_t-elements-to-8byte-bo.patch new file mode 100644 index 000000000..87a6435f7 --- /dev/null +++ b/meta-oe/recipes-support/pidgin/pidgin-sipe/0001-Align-structs-casts-with-time_t-elements-to-8byte-bo.patch | |||
@@ -0,0 +1,50 @@ | |||
1 | From 1110d3036e73d0571f70f6758f3179e5048c0b5d Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 16 Nov 2019 11:07:42 -0800 | ||
4 | Subject: [PATCH] Align structs casts with time_t elements to 8byte boundary | ||
5 | |||
6 | This helps with 64bit time_t conversion, especially where these | ||
7 | structures are typcasted to another struct types which have time_t | ||
8 | element, that now increases the natural alignment boundary of structures | ||
9 | to 8-bytes. | ||
10 | |||
11 | Fixes | ||
12 | ../../../pidgin-sipe-1.25.0/src/core/sipe-user.c:124:43: error: cast from 'struct sipe_core_public *' to 'struct sipe_core_private *' increases required alignment from 4 to 8 [-Werror,-Wcast-align] | ||
13 | struct sipe_core_private *sipe_private = SIPE_CORE_PRIVATE; | ||
14 | ^~~~~~~~~~~~~~~~~ | ||
15 | Upstream-Status: Pending | ||
16 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
17 | --- | ||
18 | src/api/sipe-core.h | 2 +- | ||
19 | src/core/sipe-http-transport.h | 2 +- | ||
20 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
21 | |||
22 | diff --git a/src/api/sipe-core.h b/src/api/sipe-core.h | ||
23 | index cde0a9c..bd818bb 100644 | ||
24 | --- a/src/api/sipe-core.h | ||
25 | +++ b/src/api/sipe-core.h | ||
26 | @@ -148,7 +148,7 @@ struct sipe_core_public { | ||
27 | |||
28 | /* server information */ | ||
29 | /* currently nothing */ | ||
30 | -}; | ||
31 | +} __attribute__((aligned(8))); | ||
32 | |||
33 | /** | ||
34 | * Initialize & destroy functions for the SIPE core | ||
35 | diff --git a/src/core/sipe-http-transport.h b/src/core/sipe-http-transport.h | ||
36 | index d82cd1b..08eb150 100644 | ||
37 | --- a/src/core/sipe-http-transport.h | ||
38 | +++ b/src/core/sipe-http-transport.h | ||
39 | @@ -46,7 +46,7 @@ struct sipe_http_connection_public { | ||
40 | gchar *host; | ||
41 | guint32 port; | ||
42 | gboolean connected; | ||
43 | -}; | ||
44 | +} __attribute__((aligned(8))); | ||
45 | |||
46 | /** | ||
47 | * Check if we're shutting down the HTTP stack | ||
48 | -- | ||
49 | 2.24.0 | ||
50 | |||
diff --git a/meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb b/meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb index 7dc63164e..99fcf3c6d 100644 --- a/meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb +++ b/meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb | |||
@@ -9,6 +9,7 @@ inherit autotools gettext pkgconfig | |||
9 | 9 | ||
10 | SRC_URI = "${SOURCEFORGE_MIRROR}/sipe/pidgin-sipe-${PV}.tar.xz \ | 10 | SRC_URI = "${SOURCEFORGE_MIRROR}/sipe/pidgin-sipe-${PV}.tar.xz \ |
11 | file://0001-sipe-consider-64bit-time_t-when-printing.patch \ | 11 | file://0001-sipe-consider-64bit-time_t-when-printing.patch \ |
12 | file://0001-Align-structs-casts-with-time_t-elements-to-8byte-bo.patch \ | ||
12 | " | 13 | " |
13 | 14 | ||
14 | SRC_URI[md5sum] = "0e742f021dc8c3f17435aea05c3e0314" | 15 | SRC_URI[md5sum] = "0e742f021dc8c3f17435aea05c3e0314" |