summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2012-05-04 19:29:13 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-05-05 09:00:21 +0200
commitf769b97271cf4158ec700d32a56d18a756a1ddcb (patch)
treee178a5071333bb5a3e90914279d45dd79337da1b /meta-oe/recipes-support
parentbab6476691ba2a2d944ec814008f79e04a6a114a (diff)
downloadmeta-openembedded-f769b97271cf4158ec700d32a56d18a756a1ddcb.tar.gz
xfsprogs: misc fixes for recipe
* Only libhandle's license is the LGPLv2.1, all tools are licensed under the GPLv2. * Create seperate package for libhandle. * Create seperate packages for mkfs.xfs and fsck.xfs to save space. * Use real license file for LIC_FILES_CHKSUM. * Fix libhandle.so symlink. * Remove unneeded symlinks from ${base_libdir} Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.7.bb31
1 files changed, 16 insertions, 15 deletions
diff --git a/meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.7.bb b/meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.7.bb
index 383088729..3bc489742 100644
--- a/meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.7.bb
+++ b/meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.7.bb
@@ -1,11 +1,11 @@
1DESCRIPTION = "XFS Filesystem Utilities" 1DESCRIPTION = "XFS Filesystem Utilities"
2HOMEPAGE = "http://oss.sgi.com/projects/xfs" 2HOMEPAGE = "http://oss.sgi.com/projects/xfs"
3SECTION = "base" 3SECTION = "base"
4LICENSE = "LGPL2.1" 4LICENSE = "GPLv2"
5 5LICENSE_libhandle = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://Makefile;endline=3;md5=def2844770bb44eba37bc9ca8610fad4" 6LIC_FILES_CHKSUM = "file://doc/COPYING;md5=dbdb5f4329b7e7145de650e9ecd4ac2a"
7
8DEPENDS = "util-linux" 7DEPENDS = "util-linux"
8PR = "r1"
9 9
10SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz \ 10SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz \
11 file://remove-install-as-user.patch \ 11 file://remove-install-as-user.patch \
@@ -15,8 +15,13 @@ SRC_URI[sha256sum] = "e150914210ac5fd29c098ef0fd94bdec51d2fb231cf9faa765c16ec6d7
15 15
16inherit autotools 16inherit autotools
17 17
18FILES_${PN}-dev += "${base_libdir}/libhandle.la \ 18PACKAGES =+ "${PN}-fsck ${PN}-mkfs libhandle"
19 ${base_libdir}/libhandle.so" 19
20RDEPENDS_${PN} = "${PN}-fsck ${PN}-mkfs"
21
22FILES_${PN}-fsck = "${base_sbindir}/fsck.xfs"
23FILES_${PN}-mkfs = "${base_sbindir}/mkfs.xfs"
24FILES_libhandle = "${base_libdir}/libhandle${SOLIBS}"
20 25
21EXTRA_OECONF = "--enable-gettext=no" 26EXTRA_OECONF = "--enable-gettext=no"
22do_configure () { 27do_configure () {
@@ -34,13 +39,9 @@ do_install () {
34 oe_runmake install 39 oe_runmake install
35 # needed for xfsdump 40 # needed for xfsdump
36 oe_runmake install-dev 41 oe_runmake install-dev
37 # replace extra links to /usr/lib with relative links (otherwise autotools_prepackage_lamangler fails to read nonexistent link) 42 rm ${D}${base_libdir}/libhandle.a
38 rm -f ${D}/${base_libdir}/libhandle.la 43 rm ${D}${base_libdir}/libhandle.la
39 rm -f ${D}/${base_libdir}/libhandle.a 44 rm ${D}${base_libdir}/libhandle.so
40 ln -s ../usr/lib/libhandle.la ${D}/${base_libdir}/libhandle.la 45 rm ${D}${libdir}/libhandle.so
41 ln -s ../usr/lib/libhandle.a ${D}/${base_libdir}/libhandle.a 46 ln -s ../..${base_libdir}/libhandle.so.1 ${D}${libdir}/libhandle.so
42
43 # and link from /usr/lib/libhandle.so to /lib/libhandle.so
44 rm -f ${D}/${libdir}/libhandle.so
45 ln -s ../../lib/libhandle.a ${D}/${libdir}/libhandle.so
46} 47}