summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-05-26 03:37:32 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-05 11:01:47 +0200
commit6aa1dd223a140abc9f7fb6c9e9bf7134abfde5cc (patch)
tree7f93bfda61694af9f92d193fb9f03c2622c6c593 /meta-oe/recipes-support
parentab2ca92e8322549aa3f13af0c903aa80bd6f10ad (diff)
downloadmeta-openembedded-6aa1dd223a140abc9f7fb6c9e9bf7134abfde5cc.tar.gz
lvm2/libdevmapper: fix invoking lvcreate failed
Previously, libdevmapper is separated from lvm2 in the following commit: Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/lvm2/libdevmapper_2.02.166.bb21
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2.inc26
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2/0001-explicitly-do-not-install-libdm.patch36
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2_2.02.171.bb31
4 files changed, 65 insertions, 49 deletions
diff --git a/meta-oe/recipes-support/lvm2/libdevmapper_2.02.166.bb b/meta-oe/recipes-support/lvm2/libdevmapper_2.02.166.bb
index fd1fc2c2b..3cf939da7 100644
--- a/meta-oe/recipes-support/lvm2/libdevmapper_2.02.166.bb
+++ b/meta-oe/recipes-support/lvm2/libdevmapper_2.02.166.bb
@@ -5,27 +5,10 @@ SRC_URI[sha256sum] = "e120b066b85b224552efda40204488c5123de068725676fd6e5c8bc655
5 5
6DEPENDS += "autoconf-archive-native" 6DEPENDS += "autoconf-archive-native"
7 7
8PACKAGECONFIG = ""
9
10# Unset user/group to unbreak install.
11EXTRA_OECONF = "--with-user= \
12 --with-group= \
13 --enable-pkgconfig \
14 --with-usrlibdir=${libdir} \
15"
16
17TARGET_CC_ARCH += "${LDFLAGS}" 8TARGET_CC_ARCH += "${LDFLAGS}"
18 9
19do_install_append() { 10do_install() {
20 # Remove things unrelated to libdevmapper 11 oe_runmake 'DESTDIR=${D}' -C libdm install
21 rm -rf ${D}${sysconfdir}
22 for i in `ls ${D}${sbindir}/*`; do
23 if [ $i != ${D}${sbindir}/dmsetup ]; then
24 rm $i
25 fi
26 done
27 # Remove docs
28 rm -rf ${D}${datadir}
29} 12}
30 13
31RRECOMMENDS_${PN}_append_class-target = " lvm2-udevrules" 14RRECOMMENDS_${PN}_append_class-target = " lvm2-udevrules"
diff --git a/meta-oe/recipes-support/lvm2/lvm2.inc b/meta-oe/recipes-support/lvm2/lvm2.inc
index cb5a9e042..c2dac952f 100644
--- a/meta-oe/recipes-support/lvm2/lvm2.inc
+++ b/meta-oe/recipes-support/lvm2/lvm2.inc
@@ -18,11 +18,18 @@ S = "${WORKDIR}/LVM2.${PV}"
18 18
19inherit autotools-brokensep pkgconfig systemd 19inherit autotools-brokensep pkgconfig systemd
20 20
21LVM2_PACKAGECONFIG = "dmeventd lvmetad"
22LVM2_PACKAGECONFIG_append_class-target = " \
23 ${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)} \
24 thin-provisioning-tools \
25 udev \
26"
27
21# odirect is always enabled because there currently is a bug in 28# odirect is always enabled because there currently is a bug in
22# lib/device/dev-io.c which prevents compiling without it. It is 29# lib/device/dev-io.c which prevents compiling without it. It is
23# better to stick to configurations that were actually tested by 30# better to stick to configurations that were actually tested by
24# upstream... 31# upstream...
25PACKAGECONFIG_append = " odirect" 32PACKAGECONFIG ??= "odirect ${LVM2_PACKAGECONFIG}"
26 33
27PACKAGECONFIG[dmeventd] = "--enable-dmeventd,--disable-dmeventd" 34PACKAGECONFIG[dmeventd] = "--enable-dmeventd,--disable-dmeventd"
28PACKAGECONFIG[lvmetad] = "--enable-lvmetad,--disable-lvmetad" 35PACKAGECONFIG[lvmetad] = "--enable-lvmetad,--disable-lvmetad"
@@ -31,3 +38,20 @@ PACKAGECONFIG[readline] = "--enable-readline,--disable-readline,readline"
31PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux" 38PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux"
32PACKAGECONFIG[thin-provisioning-tools] = "--with-thin=internal,--with-thin=none,,thin-provisioning-tools" 39PACKAGECONFIG[thin-provisioning-tools] = "--with-thin=internal,--with-thin=none,,thin-provisioning-tools"
33PACKAGECONFIG[udev] = "--enable-udev_sync --enable-udev_rules --with-udevdir=${nonarch_base_libdir}/udev/rules.d,--disable-udev_sync --disable-udev_rules,udev" 40PACKAGECONFIG[udev] = "--enable-udev_sync --enable-udev_rules --with-udevdir=${nonarch_base_libdir}/udev/rules.d,--disable-udev_sync --disable-udev_rules,udev"
41
42# Unset user/group to unbreak install.
43EXTRA_OECONF = "--with-user= \
44 --with-group= \
45 --enable-realtime \
46 --enable-applib \
47 --enable-cmdlib \
48 --enable-pkgconfig \
49 --with-usrlibdir=${libdir} \
50 --with-systemdsystemunitdir=${systemd_system_unitdir} \
51 --disable-thin_check_needs_check \
52 --with-thin-check=${sbindir}/thin_check \
53 --with-thin-dump=${sbindir}/thin_dump \
54 --with-thin-repair=${sbindir}/thin_repair \
55 --with-thin-restore=${sbindir}/thin_restore \
56"
57
diff --git a/meta-oe/recipes-support/lvm2/lvm2/0001-explicitly-do-not-install-libdm.patch b/meta-oe/recipes-support/lvm2/lvm2/0001-explicitly-do-not-install-libdm.patch
new file mode 100644
index 000000000..e85818dbd
--- /dev/null
+++ b/meta-oe/recipes-support/lvm2/lvm2/0001-explicitly-do-not-install-libdm.patch
@@ -0,0 +1,36 @@
1From 0a8e466fcf99622896e070c5133165e4278e8cfb Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Thu, 25 May 2017 05:27:11 -0400
4Subject: [PATCH] explicitly do not install libdm
5
6Already have package libdevmapper which split from lvm2,
7explicitly do not do the installation here.
8
9Upstream-Status: Inappropriate [meta-oe specific]
10
11Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
12---
13 libdm/Makefile.in | 6 ++++--
14 1 file changed, 4 insertions(+), 2 deletions(-)
15
16diff --git a/libdm/Makefile.in b/libdm/Makefile.in
17index 3c9a4ce..45c91c6 100644
18--- a/libdm/Makefile.in
19+++ b/libdm/Makefile.in
20@@ -77,9 +77,11 @@ ifeq ("@PKGCONFIG@", "yes")
21 INSTALL_TYPE += install_pkgconfig
22 endif
23
24-install: $(INSTALL_TYPE) install_include
25+install:
26+ echo "Do not install device mappler in lvm2"
27
28-install_device-mapper: install
29+install_device-mapper:
30+ echo "Do not install device mappler in lvm2"
31
32 install_include: $(srcdir)/libdevmapper.h
33 $(INSTALL_DATA) -D $< $(includedir)/$(<F)
34--
352.8.1
36
diff --git a/meta-oe/recipes-support/lvm2/lvm2_2.02.171.bb b/meta-oe/recipes-support/lvm2/lvm2_2.02.171.bb
index 38c441473..84881e744 100644
--- a/meta-oe/recipes-support/lvm2/lvm2_2.02.171.bb
+++ b/meta-oe/recipes-support/lvm2/lvm2_2.02.171.bb
@@ -3,32 +3,9 @@ require lvm2.inc
3SRC_URI[md5sum] = "153b7bb643eb26073274968e9026fa8f" 3SRC_URI[md5sum] = "153b7bb643eb26073274968e9026fa8f"
4SRC_URI[sha256sum] = "b815a711a2fabaa5c3dc1a4a284df0268bf0f325f0fc0f5c9530c9bbb54b9964" 4SRC_URI[sha256sum] = "b815a711a2fabaa5c3dc1a4a284df0268bf0f325f0fc0f5c9530c9bbb54b9964"
5 5
6DEPENDS += "autoconf-archive-native" 6SRC_URI += "file://0001-explicitly-do-not-install-libdm.patch"
7
8LVM2_PACKAGECONFIG = "dmeventd lvmetad"
9LVM2_PACKAGECONFIG_append_class-target = " \
10 ${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)} \
11 thin-provisioning-tools \
12 udev \
13"
14 7
15PACKAGECONFIG ??= "${LVM2_PACKAGECONFIG}" 8DEPENDS += "autoconf-archive-native"
16
17# Unset user/group to unbreak install.
18EXTRA_OECONF = "--with-user= \
19 --with-group= \
20 --enable-realtime \
21 --enable-applib \
22 --enable-cmdlib \
23 --enable-pkgconfig \
24 --with-usrlibdir=${libdir} \
25 --with-systemdsystemunitdir=${systemd_system_unitdir} \
26 --disable-thin_check_needs_check \
27 --with-thin-check=${sbindir}/thin_check \
28 --with-thin-dump=${sbindir}/thin_dump \
29 --with-thin-repair=${sbindir}/thin_repair \
30 --with-thin-restore=${sbindir}/thin_restore \
31"
32 9
33CACHED_CONFIGUREVARS += "MODPROBE_CMD=${base_sbindir}/modprobe" 10CACHED_CONFIGUREVARS += "MODPROBE_CMD=${base_sbindir}/modprobe"
34 11
@@ -45,10 +22,6 @@ do_install_append() {
45 mv ${D}${sysconfdir}/rc.d/init.d ${D}${sysconfdir}/init.d 22 mv ${D}${sysconfdir}/rc.d/init.d ${D}${sysconfdir}/init.d
46 rm -rf ${D}${sysconfdir}/rc.d 23 rm -rf ${D}${sysconfdir}/rc.d
47 fi 24 fi
48 # Remove things related to libdevmapper
49 rm -f ${D}${sbindir}/dmsetup
50 rm -f ${D}${libdir}/libdevmapper.so.*
51 rm -f ${D}${libdir}/libdevmapper.so ${D}${libdir}/pkgconfig/devmapper.pc ${D}${includedir}/libdevmapper.h
52} 25}
53 26
54PACKAGE_BEFORE_PN = "${PN}-scripts ${PN}-udevrules" 27PACKAGE_BEFORE_PN = "${PN}-scripts ${PN}-udevrules"