diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2012-07-11 12:39:16 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-07-13 10:19:57 +0200 |
commit | 82fe3fa0a89c35f61687d19a54bf3490a23108dd (patch) | |
tree | ee41cd0d6fbbb54c57efad85c2e95eac6066fc6e /meta-oe/recipes-support | |
parent | 888509e75f70f9a16eb213ebb35c0535646a05ab (diff) | |
download | meta-openembedded-82fe3fa0a89c35f61687d19a54bf3490a23108dd.tar.gz |
opencv, opencv-samples: drop 2.3.1
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support')
3 files changed, 0 insertions, 155 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv-samples_2.3.bb b/meta-oe/recipes-support/opencv/opencv-samples_2.3.bb deleted file mode 100644 index 89bbc01db..000000000 --- a/meta-oe/recipes-support/opencv/opencv-samples_2.3.bb +++ /dev/null | |||
@@ -1,42 +0,0 @@ | |||
1 | DESCRIPTION = "Opencv : The Open Computer Vision Library" | ||
2 | HOMEPAGE = "http://opencv.willowgarage.com/wiki/" | ||
3 | SECTION = "libs" | ||
4 | LICENSE = "BSD" | ||
5 | |||
6 | DEPENDS = "opencv" | ||
7 | |||
8 | LIC_FILES_CHKSUM = "file://include/opencv2/opencv.hpp;endline=41;md5=6d690d8488a6fca7a2c192932466bb14 \ | ||
9 | " | ||
10 | |||
11 | SRC_URI = "svn://code.ros.org/svn/opencv/tags/2.3.1;module=opencv;proto=https \ | ||
12 | " | ||
13 | |||
14 | SRCREV = "7198" | ||
15 | PV = "2.3.1" | ||
16 | PR = "r2" | ||
17 | |||
18 | S = "${WORKDIR}/opencv" | ||
19 | |||
20 | do_install() { | ||
21 | cd samples/c | ||
22 | install -d ${D}/${bindir} | ||
23 | install -d ${D}/${datadir}/opencv/samples | ||
24 | |||
25 | cp * ${D}/${datadir}/opencv/samples || true | ||
26 | |||
27 | for i in *.c; do | ||
28 | echo "compiling $i" | ||
29 | ${CXX} ${CFLAGS} ${LDFLAGS} -ggdb `pkg-config --cflags opencv` -o `basename $i .c` $i `pkg-config --libs opencv` || true | ||
30 | install -m 0755 `basename $i .c` ${D}/${bindir} || true | ||
31 | rm ${D}/${datadir}/opencv/samples/`basename $i .c` || true | ||
32 | done | ||
33 | for i in *.cpp; do | ||
34 | echo "compiling $i" | ||
35 | ${CXX} ${CFLAGS} ${LDFLAGS} -ggdb `pkg-config --cflags opencv` -o `basename $i .cpp` $i `pkg-config --libs opencv` || true | ||
36 | install -m 0755 `basename $i .cpp` ${D}/${bindir} || true | ||
37 | rm ${D}/${datadir}/opencv/samples/`basename $i .cpp` || true | ||
38 | done | ||
39 | } | ||
40 | |||
41 | FILES_${PN}-dev += "${datadir}/opencv/samples/*.c* ${datadir}/opencv/samples/*.vcp* ${datadir}/opencv/samples/build*" | ||
42 | FILES_${PN} += "${bindir} ${datadir}/opencv" | ||
diff --git a/meta-oe/recipes-support/opencv/opencv/0001-Fix-CMakeLists.txt-numpy-detection.patch b/meta-oe/recipes-support/opencv/opencv/0001-Fix-CMakeLists.txt-numpy-detection.patch deleted file mode 100644 index dba00f8a1..000000000 --- a/meta-oe/recipes-support/opencv/opencv/0001-Fix-CMakeLists.txt-numpy-detection.patch +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | From a7301911a3cdf9196abd93ff894a9e86e0bcdc5e Mon Sep 17 00:00:00 2001 | ||
2 | From: Connor Abbott <cwabbott0@gmail.com> | ||
3 | Date: Sun, 30 Oct 2011 20:00:03 -0400 | ||
4 | Subject: [PATCH] Fix CMakeLists.txt numpy detection | ||
5 | |||
6 | Right now, the code opencv uses to detect where the numpy include files are doesn't work with cross-compiling because it uses the native python to determine the environment. To make this a little better, allow the user to explictly specify the path using -DPYTHON_NUMPY_INCLUDE_DIRS=path/to/numpy/include/dir . | ||
7 | Signed-off-by: Connor Abbott <cwabbott0@gmail.com> | ||
8 | --- | ||
9 | CMakeLists.txt | 12 ++++++++---- | ||
10 | 1 files changed, 8 insertions(+), 4 deletions(-) | ||
11 | |||
12 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
13 | index ff8f20c..8edbd78 100644 | ||
14 | --- a/CMakeLists.txt | ||
15 | +++ b/CMakeLists.txt | ||
16 | @@ -715,10 +715,14 @@ IF ("${PYTHON_VERSION_MAJOR_MINOR}" VERSION_GREATER 2.4) | ||
17 | ENDIF() | ||
18 | |||
19 | # Attempt to discover the NumPy include directory. If this succeeds, then build python API with NumPy | ||
20 | -execute_process(COMMAND ${PYTHON_EXECUTABLE} -c "import os; os.environ['DISTUTILS_USE_SDK']='1'; import numpy.distutils; print numpy.distutils.misc_util.get_numpy_include_dirs()[0]" | ||
21 | - RESULT_VARIABLE PYTHON_NUMPY_PROCESS | ||
22 | - OUTPUT_VARIABLE PYTHON_NUMPY_INCLUDE_DIRS | ||
23 | - OUTPUT_STRIP_TRAILING_WHITESPACE) | ||
24 | +if(NOT DEFINED PYTHON_NUMPY_INCLUDE_DIRS) | ||
25 | + execute_process(COMMAND ${PYTHON_EXECUTABLE} -c "import os; os.environ['DISTUTILS_USE_SDK']='1'; import numpy.distutils; print numpy.distutils.misc_util.get_numpy_include_dirs()[0]" | ||
26 | + RESULT_VARIABLE PYTHON_NUMPY_PROCESS | ||
27 | + OUTPUT_VARIABLE PYTHON_NUMPY_INCLUDE_DIRS | ||
28 | + OUTPUT_STRIP_TRAILING_WHITESPACE) | ||
29 | +else() | ||
30 | + set(PYTHON_NUMPY_PROCESS 0) | ||
31 | +endif() | ||
32 | |||
33 | if(PYTHON_NUMPY_PROCESS EQUAL 0) | ||
34 | set(PYTHON_USE_NUMPY 1) | ||
35 | -- | ||
36 | 1.7.4.1 | ||
37 | |||
diff --git a/meta-oe/recipes-support/opencv/opencv_2.3.bb b/meta-oe/recipes-support/opencv/opencv_2.3.bb deleted file mode 100644 index 0534c2791..000000000 --- a/meta-oe/recipes-support/opencv/opencv_2.3.bb +++ /dev/null | |||
@@ -1,76 +0,0 @@ | |||
1 | DESCRIPTION = "Opencv : The Open Computer Vision Library" | ||
2 | HOMEPAGE = "http://opencv.willowgarage.com/wiki/" | ||
3 | SECTION = "libs" | ||
4 | |||
5 | LICENSE = "BSD" | ||
6 | LIC_FILES_CHKSUM = "file://include/opencv2/opencv.hpp;endline=41;md5=6d690d8488a6fca7a2c192932466bb14" | ||
7 | |||
8 | ARM_INSTRUCTION_SET = "arm" | ||
9 | |||
10 | DEPENDS = "python-numpy gstreamer gtk+ libtool swig swig-native python jpeg bzip2 zlib libpng tiff glib-2.0" | ||
11 | |||
12 | SRC_URI = "svn://code.ros.org/svn/opencv/tags/2.3.1;module=opencv;proto=https \ | ||
13 | file://opencv/0001-Fix-CMakeLists.txt-numpy-detection.patch \ | ||
14 | " | ||
15 | |||
16 | SRCREV = "7198" | ||
17 | |||
18 | PV = "2.3.1" | ||
19 | PR = "r3" | ||
20 | |||
21 | S = "${WORKDIR}/opencv" | ||
22 | |||
23 | EXTRA_OECMAKE = "-DPYTHON_NUMPY_INCLUDE_DIRS=${STAGING_LIBDIR}/${PYTHON_DIR}/site-packages/numpy/core/include \ | ||
24 | -DBUILD_PYTHON_SUPPORT=ON \ | ||
25 | -DWITH_FFMPEG=OFF \ | ||
26 | -DWITH_GSTREAMER=ON \ | ||
27 | " | ||
28 | |||
29 | inherit distutils-base pkgconfig cmake | ||
30 | |||
31 | export BUILD_SYS | ||
32 | export HOST_SYS | ||
33 | export PYTHON_CSPEC="-I${STAGING_INCDIR}/${PYTHON_DIR}" | ||
34 | export PYTHON="${STAGING_BINDIR_NATIVE}/python" | ||
35 | |||
36 | TARGET_CC_ARCH += "-I${S}/include " | ||
37 | |||
38 | PACKAGES += "${PN}-apps python-opencv" | ||
39 | |||
40 | python populate_packages_prepend () { | ||
41 | cv_libdir = bb.data.expand('${libdir}', d) | ||
42 | cv_libdir_dbg = bb.data.expand('${libdir}/.debug', d) | ||
43 | do_split_packages(d, cv_libdir, '^lib(.*)\.so$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev', allow_links=True) | ||
44 | do_split_packages(d, cv_libdir, '^lib(.*)\.la$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev') | ||
45 | do_split_packages(d, cv_libdir, '^lib(.*)\.a$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev') | ||
46 | do_split_packages(d, cv_libdir, '^lib(.*)\.so\.*', 'lib%s', 'OpenCV %s library', extra_depends='', allow_links=True) | ||
47 | |||
48 | pn = bb.data.getVar('PN', d, 1) | ||
49 | metapkg = pn + '-dev' | ||
50 | bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d) | ||
51 | blacklist = [ metapkg ] | ||
52 | metapkg_rdepends = [ ] | ||
53 | packages = bb.data.getVar('PACKAGES', d, 1).split() | ||
54 | for pkg in packages[1:]: | ||
55 | if not pkg in blacklist and not pkg in metapkg_rdepends and pkg.endswith('-dev'): | ||
56 | metapkg_rdepends.append(pkg) | ||
57 | bb.data.setVar('RRECOMMENDS_' + metapkg, ' '.join(metapkg_rdepends), d) | ||
58 | } | ||
59 | |||
60 | FILES_${PN} = "" | ||
61 | FILES_${PN}-apps = "${bindir}/* ${datadir}/OpenCV" | ||
62 | FILES_${PN}-dbg += "${libdir}/.debug" | ||
63 | FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig" | ||
64 | FILES_${PN}-doc = "${datadir}/OpenCV/doc" | ||
65 | |||
66 | ALLOW_EMPTY_${PN} = "1" | ||
67 | |||
68 | INSANE_SKIP_python-opencv = "True" | ||
69 | DESCRIPTION_python-opencv = "Python bindings to opencv" | ||
70 | FILES_python-opencv = "${PYTHON_SITEPACKAGES_DIR}/*" | ||
71 | RDEPENDS_python-opencv = "python-core python-numpy" | ||
72 | |||
73 | do_install_append() { | ||
74 | cp ${S}/include/opencv/*.h ${D}${includedir}/opencv/ | ||
75 | sed -i '/blobtrack/d' ${D}${includedir}/opencv/cvaux.h | ||
76 | } | ||