summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2017-02-28 16:54:05 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-04 12:38:53 +0100
commitf5ad70187901bf5464dbff350990c741760ddba3 (patch)
tree62aea327e7fc1d62b4d4c1f391f0aa86979b32ef /meta-oe/recipes-support
parenta4835a616b33a2bfe6943dff37327f6858e0fbe8 (diff)
downloadmeta-openembedded-f5ad70187901bf5464dbff350990c741760ddba3.tar.gz
syslog-ng: Update to 3.8.1
* The upstream has changed to github.com. * Remove patches that are no longer needed: - Fix-the-memory-leak-problem-for-mutex.patch - configure.patch - dbifix.patch - fix-a-memory-leak-in-log_driver_free.patch * Update syslog-ng.service-the-syslog-ng-service.patch * openssl is no longer optional, so remove its PACKAGECONFIG. * Add (disabled) PACKAGECONFIGs for the new http and native modules. * Disable the new python and java modules. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/Fix-the-memory-leak-problem-for-mutex.patch58
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/configure.patch23
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/dbifix.patch20
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/fix-a-memory-leak-in-log_driver_free.patch33
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/syslog-ng.service-the-syslog-ng-service.patch13
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng.inc17
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng_3.6.4.bb15
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng_3.8.1.bb11
8 files changed, 27 insertions, 163 deletions
diff --git a/meta-oe/recipes-support/syslog-ng/files/Fix-the-memory-leak-problem-for-mutex.patch b/meta-oe/recipes-support/syslog-ng/files/Fix-the-memory-leak-problem-for-mutex.patch
deleted file mode 100644
index 89022aaf0..000000000
--- a/meta-oe/recipes-support/syslog-ng/files/Fix-the-memory-leak-problem-for-mutex.patch
+++ /dev/null
@@ -1,58 +0,0 @@
1Fix the memory leak problem for mutex
2
3Upstream-Status: Pending
4
5Signed-off-by: Xufeng Zhang <xufeng.zhang@windriver.com>
6---
7 lib/logqueue.c | 1 +
8 modules/affile/affile-dest.c | 2 ++
9 modules/dbparser/dbparser.c | 1 +
10 3 files changed, 4 insertions(+), 0 deletions(-)
11
12diff --git a/lib/logqueue.c b/lib/logqueue.c
13index 337a3c1..10edcf0 100644
14--- a/lib/logqueue.c
15+++ b/lib/logqueue.c
16@@ -188,6 +188,7 @@ log_queue_init_instance(LogQueue *self, const gchar *persist_name)
17 void
18 log_queue_free_method(LogQueue *self)
19 {
20+ g_static_mutex_free(&self->lock);
21 g_free(self->persist_name);
22 g_free(self);
23 }
24diff --git a/modules/affile/affile-dest.c b/modules/affile/affile-dest.c
25index a2bcdad..ce79f6f 100644
26--- a/modules/affile/affile-dest.c
27+++ b/modules/affile/affile-dest.c
28@@ -305,6 +305,7 @@ affile_dw_free(LogPipe *s)
29 {
30 AFFileDestWriter *self = (AFFileDestWriter *) s;
31
32+ g_static_mutex_free(&self->lock);
33 log_pipe_unref((LogPipe *) self->writer);
34 self->writer = NULL;
35 g_free(self->filename);
36@@ -687,6 +688,7 @@ affile_dd_free(LogPipe *s)
37 /* NOTE: this must be NULL as deinit has freed it, otherwise we'd have circular references */
38 g_assert(self->single_writer == NULL && self->writer_hash == NULL);
39
40+ g_static_mutex_free(&self->lock);
41 log_template_unref(self->filename_template);
42 log_writer_options_destroy(&self->writer_options);
43 log_dest_driver_free(s);
44diff --git a/modules/dbparser/dbparser.c b/modules/dbparser/dbparser.c
45index f1248b5..9775701 100644
46--- a/modules/dbparser/dbparser.c
47+++ b/modules/dbparser/dbparser.c
48@@ -284,6 +284,7 @@ log_db_parser_free(LogPipe *s)
49 {
50 LogDBParser *self = (LogDBParser *) s;
51
52+ g_static_mutex_free(&self->lock);
53 if (self->db)
54 pattern_db_free(self->db);
55
56--
571.7.1
58
diff --git a/meta-oe/recipes-support/syslog-ng/files/configure.patch b/meta-oe/recipes-support/syslog-ng/files/configure.patch
deleted file mode 100644
index 109f58cf7..000000000
--- a/meta-oe/recipes-support/syslog-ng/files/configure.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1Index: syslog-ng-3.5.4.1/configure.ac
2===================================================================
3--- syslog-ng-3.5.4.1.orig/configure.ac 2014-07-18 13:49:36.794141441 +0000
4+++ syslog-ng-3.5.4.1/configure.ac 2014-07-18 14:23:57.738197606 +0000
5@@ -8,7 +8,8 @@ dnl SNAPSHOT_VERSION - snapshot version to add to version number
6 dnl BINARY_BRANCH - the value is added to all source/binary packages
7 dnl SOURCE_REVISION - Revision of the source-tree, will added to the version string
8 dnl
9-AC_INIT(syslog-ng/main.c)
10+AC_INIT(syslog-ng, 3.5.4.1)
11+AC_CONFIG_SRCDIR(syslog-ng/main.c)
12 AC_CONFIG_MACRO_DIR([m4])
13 m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
14
15@@ -53,7 +54,7 @@ else
16 CURRDATE=`date +"%a, %d %b %Y %H:%M:%S %Z"`
17 fi
18
19-AM_INIT_AUTOMAKE($PACKAGE, $VERSION, [foreign no-define subdir-objects])
20+AM_INIT_AUTOMAKE([foreign no-define subdir-objects])
21 _AM_PROG_TAR([ustar])
22 if test -n "$SNAPSHOT_VERSION"; then
23 VERSION=$VERSION+$SNAPSHOT_VERSION
diff --git a/meta-oe/recipes-support/syslog-ng/files/dbifix.patch b/meta-oe/recipes-support/syslog-ng/files/dbifix.patch
deleted file mode 100644
index 15dfb6885..000000000
--- a/meta-oe/recipes-support/syslog-ng/files/dbifix.patch
+++ /dev/null
@@ -1,20 +0,0 @@
1Index: syslog-ng-3.5.4.1/configure.ac
2===================================================================
3--- syslog-ng-3.5.4.1.orig/configure.ac 2014-07-18 14:35:03.134215740 +0000
4+++ syslog-ng-3.5.4.1/configure.ac 2014-07-18 15:31:52.510308653 +0000
5@@ -576,13 +576,14 @@
6 dnl ***************************************************************************
7
8 AC_CHECK_LIB(dl, dlsym, DL_LIBS="-ldl")
9+if test "x$enable_sql" != "xno"; then
10 PKG_CHECK_MODULES(LIBDBI, dbi >= $LIBDBI_MIN_VERSION, libdbi_pkgconfig_not_found="0", libdbi_pkgconfig_not_found="1")
11
12 if test "$libdbi_pkgconfig_not_found" -eq 1; then
13 dnl if libdbi has no .pc file, try it without one
14 AC_CHECK_LIB(dbi, dbi_initialize, LIBDBI_LIBS="-ldbi"; LIBDBI_CFLAGS="-I/usr/include")
15 fi
16-
17+fi
18 if test "x$enable_sql" = "xauto"; then
19 AC_MSG_CHECKING(whether to enable SQL support)
20 if test "x$LIBDBI_LIBS" != "x"; then
diff --git a/meta-oe/recipes-support/syslog-ng/files/fix-a-memory-leak-in-log_driver_free.patch b/meta-oe/recipes-support/syslog-ng/files/fix-a-memory-leak-in-log_driver_free.patch
deleted file mode 100644
index 260347413..000000000
--- a/meta-oe/recipes-support/syslog-ng/files/fix-a-memory-leak-in-log_driver_free.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From a269669ba3cb6d1c06a3322b4a6a035cb787d085 Mon Sep 17 00:00:00 2001
2From: Gergely Nagy <algernon@balabit.hu>
3Date: Tue, 14 Jan 2014 13:58:05 +0100
4Subject: [PATCH] driver: Fix a memory leak in log_driver_free()
5
6Upstream-Status: Backport
7
8After freeing up the members of self->plugins, free self->plugins itself
9too.
10
11Signed-off-by: Gergely Nagy <algernon@balabit.hu>
12---
13 lib/driver.c | 4 ++++
14 1 file changed, 4 insertions(+)
15
16diff --git a/lib/driver.c b/lib/driver.c
17index d77fe57..a6867b9 100644
18--- a/lib/driver.c
19+++ b/lib/driver.c
20@@ -91,6 +91,10 @@ log_driver_free(LogPipe *s)
21 {
22 log_driver_plugin_free((LogDriverPlugin *) l->data);
23 }
24+ if (self->plugins)
25+ {
26+ g_list_free(self->plugins);
27+ }
28 if (self->group)
29 g_free(self->group);
30 if (self->id)
31--
321.8.4.1
33
diff --git a/meta-oe/recipes-support/syslog-ng/files/syslog-ng.service-the-syslog-ng-service.patch b/meta-oe/recipes-support/syslog-ng/files/syslog-ng.service-the-syslog-ng-service.patch
index f53c607b4..6b30c20c1 100644
--- a/meta-oe/recipes-support/syslog-ng/files/syslog-ng.service-the-syslog-ng-service.patch
+++ b/meta-oe/recipes-support/syslog-ng/files/syslog-ng.service-the-syslog-ng-service.patch
@@ -15,18 +15,17 @@ diff --git a/contrib/systemd/syslog-ng.service b/contrib/systemd/syslog-ng.servi
15index fc16f8d..8e09deb 100644 15index fc16f8d..8e09deb 100644
16--- a/contrib/systemd/syslog-ng.service 16--- a/contrib/systemd/syslog-ng.service
17+++ b/contrib/systemd/syslog-ng.service 17+++ b/contrib/systemd/syslog-ng.service
18@@ -3,9 +3,8 @@ Description=System Logger Daemon 18@@ -4,8 +4,8 @@ Description=System Logger Daemon
19 Documentation=man:syslog-ng(8)
20 19
21 [Service] 20 [Service]
22-Type=notify 21 Type=notify
23-ExecStart=/usr/sbin/syslog-ng -F 22-ExecStart=/usr/sbin/syslog-ng -F $SYSLOGNG_OPTS
24-ExecReload=/bin/kill -HUP $MAINPID 23-ExecReload=/bin/kill -HUP $MAINPID
25+ExecStart=@SBINDIR@/syslog-ng -F -p @LOCALSTATEDIR@/run/syslogd.pid 24+ExecStart=@SBINDIR@/syslog-ng -F $SYSLOGNG_OPTS -p @LOCALSTATEDIR@/run/syslogd.pid
26+ExecReload=@BASEBINDIR@/kill -HUP $MAINPID 25+ExecReload=@BASEBINDIR@/kill -HUP $MAINPID
26 EnvironmentFile=-/etc/default/syslog-ng
27 EnvironmentFile=-/etc/sysconfig/syslog-ng
27 StandardOutput=journal 28 StandardOutput=journal
28 StandardError=journal
29 Restart=on-failure
30-- 29--
311.8.4.2 301.8.4.2
32 31
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
index a5e1bfe48..e13c57be9 100644
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
@@ -10,12 +10,12 @@ ideal for firewalled environments. \
10HOMEPAGE = "http://www.balabit.com/network-security/syslog-ng/opensource-logging-system" 10HOMEPAGE = "http://www.balabit.com/network-security/syslog-ng/opensource-logging-system"
11 11
12LICENSE = "GPLv2 & LGPLv2.1" 12LICENSE = "GPLv2 & LGPLv2.1"
13LIC_FILES_CHKSUM = "file://COPYING;md5=e0e8658d9be248f01b7933df24dc1408" 13LIC_FILES_CHKSUM = "file://COPYING;md5=24c0c5cb2c83d9f2ab725481e4df5240"
14 14
15# util-linux added to get libuuid 15# util-linux added to get libuuid
16DEPENDS = "libpcre flex eventlog glib-2.0 util-linux" 16DEPENDS = "libpcre flex eventlog glib-2.0 openssl util-linux"
17 17
18SRC_URI = "http://www.balabit.com/downloads/files/syslog-ng/sources/${PV}/source/${BPN}_${PV}.tar.gz \ 18SRC_URI = "https://github.com/balabit/syslog-ng/releases/download/${BP}/${BP}.tar.gz \
19 file://syslog-ng.conf \ 19 file://syslog-ng.conf \
20 file://initscript \ 20 file://initscript \
21 file://volatiles.03_syslog-ng \ 21 file://volatiles.03_syslog-ng \
@@ -32,28 +32,31 @@ EXTRA_OECONF = " \
32 --sysconfdir=${sysconfdir}/${BPN} \ 32 --sysconfdir=${sysconfdir}/${BPN} \
33 --with-module-dir=${libdir}/${BPN} \ 33 --with-module-dir=${libdir}/${BPN} \
34 --with-sysroot=${STAGING_DIR_HOST} \ 34 --with-sysroot=${STAGING_DIR_HOST} \
35 --with-libmongo-client=no --disable-mongodb \ 35 --without-mongoc --disable-mongodb \
36 --with-librabbitmq-client=no \ 36 --with-librabbitmq-client=no \
37 --disable-python \
38 --disable-java --disable-java-modules \
37 ${CONFIG_TLS} \ 39 ${CONFIG_TLS} \
38" 40"
39 41
40CONFIG_TLS = "--enable-thread-tls" 42CONFIG_TLS = "--enable-thread-tls"
41CONFIG_TLS_arm = "${@base_conditional( "DEBUG_BUILD", "1", " --disable-thread-tls", " --enable-thread-tls", d )}" 43CONFIG_TLS_arm = "${@base_conditional( "DEBUG_BUILD", "1", " --disable-thread-tls", " --enable-thread-tls", d )}"
42 44
43PACKAGECONFIG ??= "openssl \ 45PACKAGECONFIG ??= " \
44 ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \ 46 ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \
45 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \ 47 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
46" 48"
47PACKAGECONFIG[openssl] = "--enable-ssl,--disable-ssl,openssl,"
48PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,," 49PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,,"
49PACKAGECONFIG[systemd] = "--enable-systemd --with-systemdsystemunitdir=${systemd_unitdir}/system/,--disable-systemd --without-systemdsystemunitdir,systemd," 50PACKAGECONFIG[systemd] = "--enable-systemd --with-systemdsystemunitdir=${systemd_unitdir}/system/,--disable-systemd --without-systemdsystemunitdir,systemd,"
50PACKAGECONFIG[linux-caps] = "--enable-linux-caps,--disable-linux-caps,libcap," 51PACKAGECONFIG[linux-caps] = "--enable-linux-caps,--disable-linux-caps,libcap,"
51PACKAGECONFIG[dbi] = "--enable-sql,--disable-sql,libdbi," 52PACKAGECONFIG[dbi] = "--enable-sql,--disable-sql,libdbi,"
52PACKAGECONFIG[libnet] = "--enable-libnet --with-libnet=${STAGING_BINDIR_CROSS},--disable-libnet,libnet," 53PACKAGECONFIG[libnet] = "--enable-libnet --with-libnet=${STAGING_BINDIR_CROSS},--disable-libnet,libnet,"
54PACKAGECONFIG[http] = "--enable-http,--disable-http,curl,"
53PACKAGECONFIG[smtp] = "--enable-smtp --with-libesmtp=${STAGING_LIBDIR},--disable-smtp,libesmtp," 55PACKAGECONFIG[smtp] = "--enable-smtp --with-libesmtp=${STAGING_LIBDIR},--disable-smtp,libesmtp,"
54PACKAGECONFIG[json] = "--enable-json,--disable-json,json-c," 56PACKAGECONFIG[json] = "--enable-json,--disable-json,json-c,"
55PACKAGECONFIG[tcp-wrapper] = "--enable-tcp-wrapper,--disable-tcp-wrapper,tcp-wrappers," 57PACKAGECONFIG[tcp-wrapper] = "--enable-tcp-wrapper,--disable-tcp-wrapper,tcp-wrappers,"
56PACKAGECONFIG[geoip] = "--enable-geoip,--disable-geoip,geoip," 58PACKAGECONFIG[geoip] = "--enable-geoip,--disable-geoip,geoip,"
59PACKAGECONFIG[native] = "--enable-native,--disable-native,,"
57 60
58do_configure_prepend() { 61do_configure_prepend() {
59 olddir=$(pwd) 62 olddir=$(pwd)
@@ -90,7 +93,7 @@ PACKAGES =+ "${PN}-libs ${PN}-libs-dev ${PN}-libs-dbg"
90FILES_${PN}-libs = "${libdir}/${BPN}/*.so ${libdir}/libsyslog-ng-*.so*" 93FILES_${PN}-libs = "${libdir}/${BPN}/*.so ${libdir}/libsyslog-ng-*.so*"
91FILES_${PN}-libs-dev = "${libdir}/${BPN}/lib*.la" 94FILES_${PN}-libs-dev = "${libdir}/${BPN}/lib*.la"
92FILES_${PN}-libs-dbg = "${libdir}/${BPN}/.debug" 95FILES_${PN}-libs-dbg = "${libdir}/${BPN}/.debug"
93FILES_${PN}-staticdev = "${libdir}/${BPN}/libtest/*.a" 96FILES_${PN}-staticdev += "${libdir}/${BPN}/libtest/*.a"
94INSANE_SKIP_${PN}-libs = "dev-so" 97INSANE_SKIP_${PN}-libs = "dev-so"
95RDEPENDS_${PN} += "${PN}-libs" 98RDEPENDS_${PN} += "${PN}-libs"
96 99
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng_3.6.4.bb b/meta-oe/recipes-support/syslog-ng/syslog-ng_3.6.4.bb
deleted file mode 100644
index 73609af10..000000000
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng_3.6.4.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1require syslog-ng.inc
2
3SRC_URI += " \
4 file://fix-a-memory-leak-in-log_driver_free.patch \
5 file://fix-config-libnet.patch \
6 file://fix-invalid-ownership.patch \
7 file://Fix-the-memory-leak-problem-for-mutex.patch \
8 file://Fix-the-memory-leak-problem-when-HAVE_ENVIRON-defined.patch \
9 file://configure.patch \
10 file://dbifix.patch \
11 file://syslog-ng.service-the-syslog-ng-service.patch \
12"
13
14SRC_URI[md5sum] = "e9f401615e92e5eb27396c995c1446ba"
15SRC_URI[sha256sum] = "7be11df31ac7d716f1f952e22b5ae8e2049edd633a41b223776a853d9106f4e7"
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng_3.8.1.bb b/meta-oe/recipes-support/syslog-ng/syslog-ng_3.8.1.bb
new file mode 100644
index 000000000..91a0e4699
--- /dev/null
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng_3.8.1.bb
@@ -0,0 +1,11 @@
1require syslog-ng.inc
2
3SRC_URI += " \
4 file://fix-config-libnet.patch \
5 file://fix-invalid-ownership.patch \
6 file://Fix-the-memory-leak-problem-when-HAVE_ENVIRON-defined.patch \
7 file://syslog-ng.service-the-syslog-ng-service.patch \
8"
9
10SRC_URI[md5sum] = "acf14563cf5ce435db8db35486ce66af"
11SRC_URI[sha256sum] = "84b081f6e5f98cbc52052e342bcfdc5de5fe0ebe9f5ec32fe9eaec5759224cc5"