summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-07-31 01:32:06 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2012-07-31 03:47:15 +0200
commitaa558bc2e839edc6dd816b2ce301d8fe0de87a69 (patch)
treed5c0bd553b9f809e3a6a5d74069bf501a2b62581 /meta-oe/recipes-support
parentb980ffb8627595bf6d8a7269fa9035e16aa53f65 (diff)
downloadmeta-openembedded-aa558bc2e839edc6dd816b2ce301d8fe0de87a69.tar.gz
emacs: upgrade to 23.4
* package icons in PN * pass --with-crt-dir option to resolve crt* used from host system Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/emacs/emacs-23.4/nostdlib-unwind.patch16
-rw-r--r--meta-oe/recipes-support/emacs/emacs-23.4/use-qemu.patch104
-rw-r--r--meta-oe/recipes-support/emacs/emacs.inc4
-rw-r--r--meta-oe/recipes-support/emacs/emacs_23.4.bb10
4 files changed, 132 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/emacs/emacs-23.4/nostdlib-unwind.patch b/meta-oe/recipes-support/emacs/emacs-23.4/nostdlib-unwind.patch
new file mode 100644
index 000000000..4200301a3
--- /dev/null
+++ b/meta-oe/recipes-support/emacs/emacs-23.4/nostdlib-unwind.patch
@@ -0,0 +1,16 @@
1Fix linking problem:
2undefined reference to `__aeabi_unwind_cpp_pr0'
3undefined reference to `__aeabi_unwind_cpp_pr1'
4Index: emacs/src/Makefile.in
5===================================================================
6--- emacs.orig/src/Makefile.in 2008-08-16 14:20:18.000000000 +0000
7+++ emacs/src/Makefile.in 2008-08-16 14:51:25.000000000 +0000
8@@ -443,7 +443,7 @@
9 ask GCC explicitly where to find libgcc.a. */
10
11 #ifndef LINKER
12-#define LINKER $(CC) -nostdlib
13+#define LINKER $(CC) -nostdlib -lgcc_s
14 #endif
15
16 #ifndef LIB_GCC
diff --git a/meta-oe/recipes-support/emacs/emacs-23.4/use-qemu.patch b/meta-oe/recipes-support/emacs/emacs-23.4/use-qemu.patch
new file mode 100644
index 000000000..c15207a43
--- /dev/null
+++ b/meta-oe/recipes-support/emacs/emacs-23.4/use-qemu.patch
@@ -0,0 +1,104 @@
1Upstream-Status: Inappropriate [embedded specific]
2
3diff -uNr emacs-23.4/Makefile.in emacs-23.4.new/Makefile.in
4--- emacs-23.4/Makefile.in 2012-01-11 13:35:01.000000000 +0100
5+++ emacs-23.4.new/Makefile.in 2012-07-31 00:54:07.223590866 +0200
6@@ -336,7 +336,7 @@
7 # all preloaded elisp files, and only then dump the actual src/emacs, which
8 # is not wrong, but is overkill in 99.99% of the cases.
9 src: Makefile FRC
10- boot=bootstrap-emacs$(EXEEXT); \
11+ boot=${QEMU} bootstrap-emacs$(EXEEXT); \
12 if [ ! -x "src/$$boot" ]; then \
13 cd $@; $(MAKE) all $(MFLAGS) \
14 CC='${CC}' CFLAGS='${CFLAGS}' CPPFLAGS='${CPPFLAGS}' \
15diff -uNr emacs-23.4/leim/Makefile.in emacs-23.4.new/leim/Makefile.in
16--- emacs-23.4/leim/Makefile.in 2012-01-11 13:35:01.000000000 +0100
17+++ emacs-23.4.new/leim/Makefile.in 2012-07-31 00:54:07.179590866 +0200
18@@ -51,7 +51,7 @@
19
20 # How to run Emacs.
21 RUN-EMACS = EMACSLOADPATH=$(buildlisppath) LC_ALL=C \
22- ${BUILT-EMACS} -batch --no-init-file --no-site-file --multibyte
23+ ${QEMU} ${BUILT-EMACS} -batch --no-init-file --no-site-file --multibyte
24
25 # Subdirectories to be made if ${srcdir} is different from the current
26 # directory.
27diff -uNr emacs-23.4/lib-src/Makefile.in emacs-23.4.new/lib-src/Makefile.in
28--- emacs-23.4/lib-src/Makefile.in 2012-01-11 13:35:01.000000000 +0100
29+++ emacs-23.4.new/lib-src/Makefile.in 2012-07-31 00:54:07.180590866 +0200
30@@ -23,7 +23,7 @@
31 SHELL = /bin/sh
32
33 # Following ../lisp/Makefile.in.
34-EMACS = ../src/emacs
35+EMACS = ${QEMU} ../src/emacs
36 EMACSOPT = -batch --no-site-file --multibyte
37
38 # ==================== Things `configure' will edit ====================
39@@ -372,7 +372,7 @@
40 clobbered too. */
41 test-distrib${EXEEXT}: ${srcdir}/test-distrib.c
42 $(CC) ${ALL_CFLAGS} -o test-distrib ${srcdir}/test-distrib.c
43- ./test-distrib ${srcdir}/testfile
44+ ${QEMU} ./test-distrib ${srcdir}/testfile
45
46 /* We need the following in order to create a <getopt.h> when the system
47 does not have one that works with the given compiler. */
48diff -uNr emacs-23.4/lisp/Makefile.in emacs-23.4.new/lisp/Makefile.in
49--- emacs-23.4/lisp/Makefile.in 2012-01-11 13:35:01.000000000 +0100
50+++ emacs-23.4.new/lisp/Makefile.in 2012-07-31 00:54:07.195590866 +0200
51@@ -26,8 +26,7 @@
52 # You can specify a different executable on the make command line,
53 # e.g. "make EMACS=../src/emacs ...".
54
55-EMACS = ../src/emacs
56-
57+EMACS = "${QEMU} ../src/emacs"
58 # Command line flags for Emacs. This must include --multibyte,
59 # otherwise some files will not compile.
60
61diff -uNr emacs-23.4/src/Makefile.in emacs-23.4.new/src/Makefile.in
62--- emacs-23.4/src/Makefile.in 2012-01-12 11:27:54.000000000 +0100
63+++ emacs-23.4.new/src/Makefile.in 2012-07-31 00:55:30.344593847 +0200
64@@ -482,7 +482,7 @@
65 this with the shell''s ``for'' construct.
66 Note that some people do not have '.' in their paths, so we must
67 use ./prefix-args. */
68-#define YMF_PASS_LDFLAGS(flags) `./prefix-args -Xlinker flags`
69+#define YMF_PASS_LDFLAGS(flags) `${QEMU} ./prefix-args -Xlinker flags`
70 #else
71 #define YMF_PASS_LDFLAGS(flags) flags
72 #endif
73@@ -919,9 +919,9 @@
74 $(GNULIB_VAR) LIB_MATH LIB_STANDARD $(GNULIB_VAR)
75
76 #ifdef HAVE_SHM
77-RUN_TEMACS = `/bin/pwd`/temacs -nl
78+RUN_TEMACS = ${QEMU} temacs -nl
79 #else
80-RUN_TEMACS = `/bin/pwd`/temacs
81+RUN_TEMACS = ${QEMU} temacs
82 #endif
83
84 all: emacs${EXEEXT} $(OTHER_FILES)
85@@ -936,7 +936,7 @@
86 @: This new Emacs is as functional and more efficient then
87 @: bootstrap-emacs, so let us replace it.
88 -ln -f emacs${EXEEXT} bootstrap-emacs${EXEEXT}
89- -./emacs -q -batch -f list-load-path-shadows
90+ -${QEMU} ./emacs -q -batch -f list-load-path-shadows
91 #endif /* ! defined (CANNOT_DUMP) */
92
93 /* We run make-docfile twice because the command line may get too long
94@@ -954,8 +954,8 @@
95 only in order to reduce the command line length. --Stef */
96 ${etc}DOC: ${libsrc}make-docfile${EXEEXT} ${obj} ${lisp} ${SOME_MACHINE_LISP}
97 -rm -f ${etc}DOC
98- ${libsrc}make-docfile -d ${srcdir} ${SOME_MACHINE_OBJECTS} ${obj} > ${etc}DOC
99- ${libsrc}make-docfile -a ${etc}DOC -d ${srcdir} ${SOME_MACHINE_LISP} ${shortlisp}
100+ ${QEMU}${libsrc}make-docfile -d ${srcdir} ${SOME_MACHINE_OBJECTS} ${obj} > ${etc}DOC
101+ ${QEMU} ${libsrc}make-docfile -a ${etc}DOC -d ${srcdir} ${SOME_MACHINE_LISP} ${shortlisp}
102
103 ${libsrc}make-docfile${EXEEXT}:
104 cd ${libsrc}; ${MAKE} ${MFLAGS} make-docfile${EXEEXT}
diff --git a/meta-oe/recipes-support/emacs/emacs.inc b/meta-oe/recipes-support/emacs/emacs.inc
index 588371999..f6cd46198 100644
--- a/meta-oe/recipes-support/emacs/emacs.inc
+++ b/meta-oe/recipes-support/emacs/emacs.inc
@@ -10,7 +10,7 @@ DEPENDS +=" liblockfile"
10 10
11X11DEPENDS = "gtk+ libungif dbus" 11X11DEPENDS = "gtk+ libungif dbus"
12 12
13EXTRA_OECONF = "--without-sound " 13EXTRA_OECONF = "--without-sound --with-crt-dir=${STAGING_LIBDIR} "
14 14
15PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" 15PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
16PACKAGECONFIG[x11] = "--with-x-toolkit=gtk,--without-x,${X11DEPENDS}" 16PACKAGECONFIG[x11] = "--with-x-toolkit=gtk,--without-x,${X11DEPENDS}"
@@ -22,7 +22,7 @@ PACKAGES =+ "${PN}-el"
22FILES_${PN}-el = "${datadir}/emacs/*/*/*.el.gz \ 22FILES_${PN}-el = "${datadir}/emacs/*/*/*.el.gz \
23 ${datadir}/emacs/*/*/*/*.el.gz" 23 ${datadir}/emacs/*/*/*/*.el.gz"
24 24
25FILES_${PN} += "${datadir}/emacs" 25FILES_${PN} += "${datadir}/emacs ${datadir}/icons"
26 26
27FILES_${PN}-dbg += "${libexecdir}/emacs/*/*/.debug ${datadir}/emacs/*/*/.debug" 27FILES_${PN}-dbg += "${libexecdir}/emacs/*/*/.debug ${datadir}/emacs/*/*/.debug"
28 28
diff --git a/meta-oe/recipes-support/emacs/emacs_23.4.bb b/meta-oe/recipes-support/emacs/emacs_23.4.bb
new file mode 100644
index 000000000..3c97e9ebd
--- /dev/null
+++ b/meta-oe/recipes-support/emacs/emacs_23.4.bb
@@ -0,0 +1,10 @@
1require emacs.inc
2
3DEFAULT_PREFERENCE = "-1"
4
5SRC_URI = "${GNU_MIRROR}/emacs/emacs-${PV}.tar.gz;name=tarball \
6 file://use-qemu.patch \
7 file://nostdlib-unwind.patch \
8"
9SRC_URI[tarball.md5sum] = "34405165fcd978fbc8b304cbd99ccf4f"
10SRC_URI[tarball.sha256sum] = "b9a2b8434052771f797d2032772eba862ff9aa143029efc72295170607289c18"