summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2016-09-02 12:59:27 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-11 09:11:22 +0200
commit0a5c689b6823bbad0b535c98841f0f85b23db90f (patch)
tree8b0079115529ea2e61f3d6168058b934984a0e7b /meta-oe/recipes-support
parent11178d122cc019d7b22c251993df87238a69c43b (diff)
downloadmeta-openembedded-0a5c689b6823bbad0b535c98841f0f85b23db90f.tar.gz
upower: add systemd support
* inherit systemd * Add PACKAGECONFIG for systemd and control it based on DISTRO_FEATURES Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/upower/upower_0.99.4.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/upower/upower_0.99.4.bb b/meta-oe/recipes-support/upower/upower_0.99.4.bb
index 770f33360..2573f12d4 100644
--- a/meta-oe/recipes-support/upower/upower_0.99.4.bb
+++ b/meta-oe/recipes-support/upower/upower_0.99.4.bb
@@ -8,13 +8,17 @@ SRC_URI = "http://upower.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
8SRC_URI[md5sum] = "78800e1ac7f92b24aabdf433e38f75d2" 8SRC_URI[md5sum] = "78800e1ac7f92b24aabdf433e38f75d2"
9SRC_URI[sha256sum] = "9ca325a6ccef505529b268ebbbd9becd0ce65a65f6ac7ee31e2e5b17648037b0" 9SRC_URI[sha256sum] = "9ca325a6ccef505529b268ebbbd9becd0ce65a65f6ac7ee31e2e5b17648037b0"
10 10
11inherit autotools pkgconfig gettext gobject-introspection 11inherit autotools pkgconfig gettext gobject-introspection systemd
12 12
13PACKAGECONFIG ??= "" 13PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
14PACKAGECONFIG[idevice] = "--with-idevice,--without-idevice,libimobiledevice libplist" 14PACKAGECONFIG[idevice] = "--with-idevice,--without-idevice,libimobiledevice libplist"
15PACKAGECONFIG[systemd] = "--with-systemdutildir=${systemd_unitdir} --with-systemdsystemunitdir=${systemd_system_unitdir}, \
16 --without-systemdutildir --without-systemdsystemunitdir,systemd"
15 17
16EXTRA_OECONF = " --with-backend=linux" 18EXTRA_OECONF = " --with-backend=linux"
17 19
20SYSTEMD_SERVICE_${PN} = "upower.service"
21
18do_configure_prepend() { 22do_configure_prepend() {
19 sed -i -e s:-nonet:\:g ${S}/doc/man/Makefile.am 23 sed -i -e s:-nonet:\:g ${S}/doc/man/Makefile.am
20 sed -i -e 's: doc : :g' ${S}/Makefile.am 24 sed -i -e 's: doc : :g' ${S}/Makefile.am