summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-10-24 08:39:12 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-10-24 08:39:12 +0200
commit80ef3c0aa0f92e93d1581e47ccb77a04022d04cf (patch)
tree770fad80bcfa1546ab9e99373dac7e2dcaac62d3 /meta-oe/recipes-support
parentbe304441d8a63df14d91c2c8ee79aa126f87d74a (diff)
downloadmeta-openembedded-80ef3c0aa0f92e93d1581e47ccb77a04022d04cf.tar.gz
Revert "maliit-framework: Clean up recipe and use gtk-immodules-cache.bbclass"
The class hasn't hit oe-core yet This reverts commit eb66e508e33ccbec8299041265eef183913a3a8c.
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/maliit/maliit-framework_git.bb32
1 files changed, 25 insertions, 7 deletions
diff --git a/meta-oe/recipes-support/maliit/maliit-framework_git.bb b/meta-oe/recipes-support/maliit/maliit-framework_git.bb
index 534a3c85b..3f50d1bc5 100644
--- a/meta-oe/recipes-support/maliit/maliit-framework_git.bb
+++ b/meta-oe/recipes-support/maliit/maliit-framework_git.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "https://wiki.maliit.org/Main_Page"
4LICENSE = "LGPLv2.1" 4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=5c917f6ce94ceb8d8d5e16e2fca5b9ad" 5LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=5c917f6ce94ceb8d8d5e16e2fca5b9ad"
6 6
7inherit autotools qt4x11 gtk-immodules-cache 7inherit autotools qt4x11
8 8
9 9
10SRC_URI = "git://gitorious.org/maliit/maliit-framework.git;branch=master \ 10SRC_URI = "git://gitorious.org/maliit/maliit-framework.git;branch=master \
@@ -16,8 +16,9 @@ SRCREV = "750842dec74a9b17dca91ef779c4fc5a43c4d9dc"
16PV = "0.92.3+git${SRCPV}" 16PV = "0.92.3+git${SRCPV}"
17 17
18 18
19PACKAGES =+ "${PN}-gtk" 19PACKAGES =+ "\
20GTKIMMODULES_PACKAGES = "${PN}-gtk" 20 ${PN}-gtk \
21 "
21 22
22# Maliit needs Qt configured with -accessibility, a patch for that was already sent and will get merged in post 1.2. 23# Maliit needs Qt configured with -accessibility, a patch for that was already sent and will get merged in post 1.2.
23RDEPENDS_${PN} = "qt4-plugin-inputmethod-imsw-multi libqtsvg4" 24RDEPENDS_${PN} = "qt4-plugin-inputmethod-imsw-multi libqtsvg4"
@@ -57,12 +58,29 @@ EXTRA_QMAKEVARS_PRE = "\
57 CONFIG+=local-install \ 58 CONFIG+=local-install \
58 " 59 "
59 60
60EXTRA_OEMAKE += "INSTALL_ROOT=${D}" 61do_install() {
62 cd ${S} && (INSTALL_ROOT=${D} oe_runmake install)
61 63
62do_install_append() {
63 #Fix absolute paths 64 #Fix absolute paths
64 sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${datadir}/qt4/mkspecs/features/maliit-framework.prf 65 cd ${D}/${datadir}/qt4/mkspecs/features && sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ./maliit-framework.prf
65 sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${datadir}/qt4/mkspecs/features/maliit-plugins.prf 66 cd ${D}/${datadir}/qt4/mkspecs/features && sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ./maliit-plugins.prf
67}
68
69
70
71# Update the inputmethod modules in gtk
72pkg_postinst_${PN}-gtk() {
73if [ "x$D" != "x" ]; then
74 exit 1
75fi
76gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
77}
78
79pkg_postrm_${PN}-gtk() {
80if [ "x$D" != "x" ]; then
81 exit 1
82fi
83gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
66} 84}
67 85
68S= "${WORKDIR}/git" 86S= "${WORKDIR}/git"