summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2013-12-05 15:10:38 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2013-12-21 19:16:51 +0100
commit5916ffe0a19422706d1f84870adc603bad202f1c (patch)
treec8f99d4813ea99f96254efefc1f47d8fd0c8834b /meta-oe/recipes-support
parent552b06192a48f0dfab59fb4894742e4415757dc2 (diff)
downloadmeta-openembedded-5916ffe0a19422706d1f84870adc603bad202f1c.tar.gz
mariadb-native: fix link error on Ubuntu 13.10
Below errors only occurs on Ubuntu 13.10: $arch-linux-libtool: link: g++ ... -o .libs/mysqltest_embedded \ ../../libmysqld/.libs/libmysqld.so -ldl ../../libmysqld/.libs/libmysqld.so: undefined reference to `dlopen' ../../libmysqld/.libs/libmysqld.so: undefined reference to `dlclose' ../../libmysqld/.libs/libmysqld.so: undefined reference to `dlerror' ../../libmysqld/.libs/libmysqld.so: undefined reference to `dlsym' GCC/ld verion on the host: gcc (Ubuntu/Linaro 4.8.1-10ubuntu8) 4.8.1 GNU ld (GNU Binutils for Ubuntu) 2.23.52.20130913 This is a strange behavior on Ub13.10, it fails even '-ldl' in the link command line. This patch will append '-ldl' to dependency_libs in libmysqld.la. Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/mysql/mariadb-native_5.1.67.bb3
-rw-r--r--meta-oe/recipes-support/mysql/mariadb/fix-link-error-ub1310.patch37
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mysql/mariadb-native_5.1.67.bb b/meta-oe/recipes-support/mysql/mariadb-native_5.1.67.bb
index a55c2ab6a..e8382e285 100644
--- a/meta-oe/recipes-support/mysql/mariadb-native_5.1.67.bb
+++ b/meta-oe/recipes-support/mysql/mariadb-native_5.1.67.bb
@@ -8,6 +8,9 @@ PACKAGES = ""
8EXTRA_OEMAKE = "" 8EXTRA_OEMAKE = ""
9EXTRA_OECONF = " --with-embedded-server " 9EXTRA_OECONF = " --with-embedded-server "
10 10
11SRC_URI += "file://fix-link-error-ub1310.patch \
12"
13
11do_install() { 14do_install() {
12 oe_runmake 'DESTDIR=${D}' install 15 oe_runmake 'DESTDIR=${D}' install
13 mv -f ${D}${libdir}/mysql/* ${D}${libdir} 16 mv -f ${D}${libdir}/mysql/* ${D}${libdir}
diff --git a/meta-oe/recipes-support/mysql/mariadb/fix-link-error-ub1310.patch b/meta-oe/recipes-support/mysql/mariadb/fix-link-error-ub1310.patch
new file mode 100644
index 000000000..a528ea700
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/mariadb/fix-link-error-ub1310.patch
@@ -0,0 +1,37 @@
1mariadb-native: fix link error on Ubuntu 13.10
2
3Below errors only occurs on Ubuntu 13.10:
4
5$arch-linux-libtool: link: g++ ... -o .libs/mysqltest_embedded \
6 ../../libmysqld/.libs/libmysqld.so -ldl
7
8 ../../libmysqld/.libs/libmysqld.so: undefined reference to `dlopen'
9 ../../libmysqld/.libs/libmysqld.so: undefined reference to `dlclose'
10 ../../libmysqld/.libs/libmysqld.so: undefined reference to `dlerror'
11 ../../libmysqld/.libs/libmysqld.so: undefined reference to `dlsym'
12
13GCC/ld verion on the host:
14 gcc (Ubuntu/Linaro 4.8.1-10ubuntu8) 4.8.1
15 GNU ld (GNU Binutils for Ubuntu) 2.23.52.20130913
16
17This is a strange behavior on Ub13.10, it fails even '-ldl' in the
18link command line. Below fix will append '-ldl' to dependency_libs
19in libmysqld.la.
20
21Upstream-Status: Submitted [https://mariadb.atlassian.net/browse/MDEV-5362]
22
23Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
24================================================
25diff --git a/libmysqld/Makefile.am b/libmysqld/Makefile.am
26index 7a2c92e..eee501e 100644
27--- a/libmysqld/Makefile.am
28+++ b/libmysqld/Makefile.am
29@@ -92,7 +92,7 @@ INC_LIB= $(top_builddir)/regex/libregex.la \
30 @ndbcluster_libs@ @NDB_SCI_LIBS@ \
31 @mysql_embedded_plugin_libs@ \
32 $(libevent_inc_libs) \
33- $(yassl_inc_libs)
34+ $(yassl_inc_libs) @LIBDL@
35
36 if HAVE_YASSL
37 yassl_inc_libs= $(top_builddir)/extra/yassl/src/libyassl.la \