diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2011-05-17 04:43:25 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-05-17 14:20:50 +0200 |
commit | 2d3f207b840cc64c54117ec79b3eabe72431c0fb (patch) | |
tree | 24cb7552ec78d91d2533a27f0c06c1049457a750 /meta-oe/recipes-support | |
parent | 68c15845d087df0a6f66c58a9fd80548a9bb3a59 (diff) | |
download | meta-openembedded-2d3f207b840cc64c54117ec79b3eabe72431c0fb.tar.gz |
freerdp: update to 2011-05-16 snapshot
This version includes major improvements since last version
packages. It also had the plugins packages redone so they can be
choosen depending on the environment needs.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/freerdp/freerdp.inc | 40 | ||||
-rw-r--r-- | meta-oe/recipes-support/freerdp/freerdp_git.bb | 4 |
2 files changed, 35 insertions, 9 deletions
diff --git a/meta-oe/recipes-support/freerdp/freerdp.inc b/meta-oe/recipes-support/freerdp/freerdp.inc index f8402c71d..71dab978e 100644 --- a/meta-oe/recipes-support/freerdp/freerdp.inc +++ b/meta-oe/recipes-support/freerdp/freerdp.inc | |||
@@ -3,22 +3,48 @@ | |||
3 | 3 | ||
4 | DESCRIPTION = "FreeRDP RDP client" | 4 | DESCRIPTION = "FreeRDP RDP client" |
5 | HOMEPAGE = "http://freerdp.sourceforge.net" | 5 | HOMEPAGE = "http://freerdp.sourceforge.net" |
6 | DEPENDS = "virtual/libx11 openssl libxcursor cups alsa-lib" | 6 | DEPENDS = "virtual/libx11 openssl libxcursor libxv cups alsa-lib pulseaudio pcsc-lite" |
7 | SECTION = "x11/network" | 7 | SECTION = "x11/network" |
8 | LICENSE = "Apache-2.0" | 8 | LICENSE = "Apache-2.0" |
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
10 | 10 | ||
11 | INC_PR = "r0" | 11 | INC_PR = "r1" |
12 | 12 | ||
13 | inherit pkgconfig autotools | 13 | inherit pkgconfig autotools |
14 | 14 | ||
15 | do_configure_prepend() { | 15 | EXTRA_OECONF += "--with-smartcard --with-xvideo" |
16 | # workaround gcc linking bug | ||
17 | find ${S} -name 'Makefile.am' | xargs -n 1 sed 's,-pthread,-lpthread -D_REENTRANT,g' -i | ||
18 | } | ||
19 | 16 | ||
20 | do_install_append() { | 17 | do_install_append() { |
21 | rm ${D}${libdir}/freerdp/*.a ${D}${libdir}/freerdp/*.la | 18 | rm ${D}${libdir}/freerdp/*.a ${D}${libdir}/freerdp/*.la |
22 | } | 19 | } |
23 | 20 | ||
24 | RDEPENDS_${PN} += "xprop" | 21 | PACKAGES =+ "libfreerdp" |
22 | |||
23 | LEAD_SONAME = "libfreerdp.so" | ||
24 | FILES_libfreerdp = "${libdir}/lib*${SOLIBS}" | ||
25 | |||
26 | PACKAGES_DYNAMIC = "libfreerdp-plugin-*" | ||
27 | |||
28 | python populate_packages_prepend () { | ||
29 | freerdp_root = bb.data.expand('${libdir}/freerdp', d) | ||
30 | |||
31 | do_split_packages(d, freerdp_root, '^(audin_.*)\.so$', | ||
32 | output_pattern='libfreerdp-plugin-%s', | ||
33 | description='FreeRDP plugin %s', | ||
34 | prepend=True, extra_depends='libfreerdp-plugin-audin') | ||
35 | |||
36 | do_split_packages(d, freerdp_root, '^(rdpsnd_.*)\.so$', | ||
37 | output_pattern='libfreerdp-plugin-%s', | ||
38 | description='FreeRDP plugin %s', | ||
39 | prepend=True, extra_depends='libfreerdp-plugin-rdpsnd') | ||
40 | |||
41 | do_split_packages(d, freerdp_root, '^(tsmf_.*)\.so$', | ||
42 | output_pattern='libfreerdp-plugin-%s', | ||
43 | description='FreeRDP plugin %s', | ||
44 | prepend=True, extra_depends='libfreerdp-plugin-tsmf') | ||
45 | |||
46 | do_split_packages(d, freerdp_root, '^([^-]*)\.so$', | ||
47 | output_pattern='libfreerdp-plugin-%s', | ||
48 | description='FreeRDP plugin %s', | ||
49 | prepend=True, extra_depends='') | ||
50 | } | ||
diff --git a/meta-oe/recipes-support/freerdp/freerdp_git.bb b/meta-oe/recipes-support/freerdp/freerdp_git.bb index fa4ba9ae2..e1359026b 100644 --- a/meta-oe/recipes-support/freerdp/freerdp_git.bb +++ b/meta-oe/recipes-support/freerdp/freerdp_git.bb | |||
@@ -7,9 +7,9 @@ inherit gitpkgv | |||
7 | 7 | ||
8 | PV = "gitr${SRCPV}" | 8 | PV = "gitr${SRCPV}" |
9 | PKGV = "${GITPKGVTAG}" | 9 | PKGV = "${GITPKGVTAG}" |
10 | PR = "${INC_PR}.0" | 10 | PR = "${INC_PR}.1" |
11 | 11 | ||
12 | SRCREV = "7bbde4fb3bc3a781364d0a626c49bc165cc507fd" | 12 | SRCREV = "f5aef3be8fac9a02b0c7bbb5424831a7b285e7bb" |
13 | SRC_URI = "git://github.com/FreeRDP/FreeRDP.git;protocol=git" | 13 | SRC_URI = "git://github.com/FreeRDP/FreeRDP.git;protocol=git" |
14 | 14 | ||
15 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |