diff options
author | Li xin <lixin.fnst@cn.fujitsu.com> | 2014-12-12 13:15:32 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-12-19 20:10:56 +0100 |
commit | e2f8425e2d806e511489694ec338c6299eddcddd (patch) | |
tree | c9fd885f37dc86bfa48d97a5143db5ef4e01318f /meta-oe/recipes-support | |
parent | 6781f9b5dc60bbd39727aeaa74c13dd31eb73838 (diff) | |
download | meta-openembedded-e2f8425e2d806e511489694ec338c6299eddcddd.tar.gz |
openwbem: add new recipe
OpenWBEM is a set of software components that help facilitate
deployment of the Common Information Model (CIM) and Web-Based
Enterprise Management (WBEM) technologies of the Distributed Management
Task Force (DMTF).
Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
9 files changed, 476 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/openwbem/openwbem/checkserverkey b/meta-oe/recipes-support/openwbem/openwbem/checkserverkey new file mode 100644 index 000000000..bcfa36101 --- /dev/null +++ b/meta-oe/recipes-support/openwbem/openwbem/checkserverkey | |||
@@ -0,0 +1,20 @@ | |||
1 | #!/bin/bash | ||
2 | |||
3 | if [ ! -f "/etc/openwbem/serverkey.pem" ]; then | ||
4 | if [ -f "/etc/ssl/servercerts/servercert.pem" \ | ||
5 | -a -f "/etc/ssl/servercerts/serverkey.pem" ]; then | ||
6 | echo "Using common server certificate /etc/ssl/servercerts/servercert.pem" | ||
7 | ln -s /etc/ssl/servercerts/server{cert,key}.pem /etc/openwbem/ | ||
8 | else | ||
9 | echo "FAILED: Starting OpenWBEM server" | ||
10 | echo "There is no ssl server key available for OpenWBEM server to use." | ||
11 | echo -e "Please generate one with the following script and start the OpenWBEM service again:\n" | ||
12 | echo "##################################" | ||
13 | echo "/etc/openwbem/owgencert" | ||
14 | echo "=================================" | ||
15 | |||
16 | echo "NOTE: The script uses /dev/random device for generating some random bits while generating the server key." | ||
17 | echo " If this takes too long, you can replace the value of \"RANDFILE\" in /etc/openwsman/ssleay.cnf with /dev/urandom. Please understand the implications" | ||
18 | exit 1 | ||
19 | fi | ||
20 | fi | ||
diff --git a/meta-oe/recipes-support/openwbem/openwbem/loadmof.sh b/meta-oe/recipes-support/openwbem/openwbem/loadmof.sh new file mode 100644 index 000000000..dd87811a3 --- /dev/null +++ b/meta-oe/recipes-support/openwbem/openwbem/loadmof.sh | |||
@@ -0,0 +1,118 @@ | |||
1 | #!/bin/sh | ||
2 | # | ||
3 | # options: | ||
4 | # loadmof.sh <MOF_PATH> <NAMESPACE> <FILES> | ||
5 | # | ||
6 | # - or - | ||
7 | # | ||
8 | # options: | ||
9 | # loadmof.sh -n <NAMESPACE> <FILES> [...] | ||
10 | # | ||
11 | # The former is preserved for compatibility with Pegasus and | ||
12 | # sblim providers. The latter is preferred. If $1 is "-n", | ||
13 | # the latter code path is executed. Otherwise the former is | ||
14 | # executed. | ||
15 | |||
16 | if [ "x$1" != "x-n" -a "x$1" != "x-v" ]; then | ||
17 | # OLD STYLE | ||
18 | if [ -f "/etc/init.d/owcimomd" ]; then | ||
19 | /etc/init.d/owcimomd status 1>&2 > /dev/null | ||
20 | if [ $? = "0" ]; then | ||
21 | CIMOM_RUNNING="true" | ||
22 | else | ||
23 | CIMOM_RUNNING="false" | ||
24 | fi | ||
25 | else | ||
26 | exit 1 | ||
27 | fi | ||
28 | if [ "$YAST_IS_RUNNING" = "instsys" ]; then | ||
29 | CIMOM_RUNNING="false" | ||
30 | fi | ||
31 | |||
32 | CIMOM=$1 | ||
33 | shift | ||
34 | case "$CIMOM" in | ||
35 | pegasus) | ||
36 | exit 0 | ||
37 | ;; | ||
38 | esac | ||
39 | MOF_PATH=$1 | ||
40 | shift | ||
41 | NS=$1 | ||
42 | shift | ||
43 | |||
44 | REPOSITORY="/var/lib/openwbem" | ||
45 | #tmp_dir=`mktemp -d -p /tmp openwbem.XXXXXX` | ||
46 | case "$CIMOM_RUNNING" in | ||
47 | true|false) | ||
48 | while [ "$#" -gt 0 ] | ||
49 | do | ||
50 | echo "Loading $MOF_PATH/$1" | ||
51 | #sed "s/cmpi:/cmpi::/g" $MOF_PATH/$1 > $tmp_dir/$1 | ||
52 | /usr/bin/owmofc -c -n $NS -d $REPOSITORY $MOF_PATH/$1 > /dev/null 2>&1 | ||
53 | shift | ||
54 | done | ||
55 | ;; | ||
56 | esac | ||
57 | #rm -rf $tmp_dir | ||
58 | # END OLD STYLE | ||
59 | |||
60 | else | ||
61 | # NEW STYLE | ||
62 | if [ "x$3" = "x" ]; then | ||
63 | echo "Usage: $0 -n <NAMESPACE> <FILES> [...]" | ||
64 | exit 1 | ||
65 | fi | ||
66 | |||
67 | if [ "x$1" = "x-v" ]; then | ||
68 | VERBOSE=1 | ||
69 | shift | ||
70 | fi | ||
71 | |||
72 | # get rid of "-n" arg | ||
73 | shift | ||
74 | |||
75 | NS="$1" | ||
76 | |||
77 | shift | ||
78 | |||
79 | DBDIR=/var/lib/openwbem | ||
80 | LOGFILE=$DBDIR/loadmof.log | ||
81 | CIMOM_INIT=/etc/init.d/owcimomd | ||
82 | if [ "$YAST_IS_RUNNING" != "instsys" ] ; then | ||
83 | $CIMOM_INIT status > /dev/null 2>&1 | ||
84 | CIMOM_RUNNING=$? | ||
85 | fi | ||
86 | if [ "x$CIMOM_RUNNING" = "x0" ]; then | ||
87 | $CIMOM_INIT stop > /dev/null 2>&1 | ||
88 | fi | ||
89 | bkpdir=$DBDIR/backup-$$ | ||
90 | mkdir $bkpdir | ||
91 | cp -a $DBDIR/*.{dat,ndx,lock} $bkpdir/ | ||
92 | rm -f $LOGFILE.9 | ||
93 | for i in 8 7 6 5 4 3 2 1 0; do | ||
94 | let newI=$i+1 | ||
95 | if [ -f $LOGFILE.$i ]; then | ||
96 | mv $LOGFILE.$i $LOGFILE.$newI | ||
97 | fi | ||
98 | done | ||
99 | if [ -f $LOGFILE ]; then | ||
100 | mv $LOGFILE $LOGFILE.0 | ||
101 | fi | ||
102 | if [ "x$VERBOSE" = "x1" ]; then | ||
103 | /usr/bin/owmofc -c -n $NS -d $DBDIR -s /usr/share/mof/cim-current "$@" 2>&1 | tee $LOGFILE | ||
104 | else | ||
105 | /usr/bin/owmofc -c -n $NS -d $DBDIR -s /usr/share/mof/cim-current "$@" > $LOGFILE 2>&1 | ||
106 | fi | ||
107 | RVAL=$? | ||
108 | if [ "x$RVAL" != "x0" ]; then | ||
109 | echo "MOF import failed! Check $LOGFILE for details." | ||
110 | mv $bkpdir/* $DBDIR/ | ||
111 | fi | ||
112 | rm -rf $bkpdir | ||
113 | if [ "x$CIMOM_RUNNING" = "x0" ]; then | ||
114 | $CIMOM_INIT start > /dev/null 2>&1 | ||
115 | fi | ||
116 | exit $RVAL | ||
117 | fi | ||
118 | |||
diff --git a/meta-oe/recipes-support/openwbem/openwbem/novell-openwbem-root-acl.mof b/meta-oe/recipes-support/openwbem/openwbem/novell-openwbem-root-acl.mof new file mode 100644 index 000000000..c9970c79e --- /dev/null +++ b/meta-oe/recipes-support/openwbem/openwbem/novell-openwbem-root-acl.mof | |||
@@ -0,0 +1,21 @@ | |||
1 | #pragma namespace("root/security") | ||
2 | |||
3 | instance of OpenWBEM_NamespaceACL | ||
4 | { | ||
5 | nspace = "root"; | ||
6 | capability = ""; | ||
7 | }; | ||
8 | |||
9 | instance of OpenWBEM_NamespaceACL | ||
10 | { | ||
11 | nspace = "root/cimv2"; | ||
12 | capability = ""; | ||
13 | }; | ||
14 | |||
15 | instance of OpenWBEM_UserACL | ||
16 | { | ||
17 | nspace = "root/cimv2"; | ||
18 | username = "root"; | ||
19 | capability = "rw"; | ||
20 | }; | ||
21 | |||
diff --git a/meta-oe/recipes-support/openwbem/openwbem/openwbem-etc_pam.d_openwbem b/meta-oe/recipes-support/openwbem/openwbem/openwbem-etc_pam.d_openwbem new file mode 100644 index 000000000..b3785aa49 --- /dev/null +++ b/meta-oe/recipes-support/openwbem/openwbem/openwbem-etc_pam.d_openwbem | |||
@@ -0,0 +1,7 @@ | |||
1 | #%PAM-1.0 | ||
2 | auth required pam_unix2.so nullok | ||
3 | auth required pam_nologin.so | ||
4 | account required pam_unix2.so | ||
5 | password required pam_pwcheck.so nullok | ||
6 | password required pam_unix2.so nullok use_first_pass use_authtok | ||
7 | session required pam_unix2.so none | ||
diff --git a/meta-oe/recipes-support/openwbem/openwbem/openwbem-owcimomd.init b/meta-oe/recipes-support/openwbem/openwbem/openwbem-owcimomd.init new file mode 100644 index 000000000..47fa8a7c6 --- /dev/null +++ b/meta-oe/recipes-support/openwbem/openwbem/openwbem-owcimomd.init | |||
@@ -0,0 +1,131 @@ | |||
1 | #!/bin/sh | ||
2 | # | ||
3 | ### BEGIN INIT INFO | ||
4 | # Provides: owcimomd | ||
5 | # Required-Start: $network | ||
6 | # Required-Stop: $network | ||
7 | # Default-Start: 2 3 4 5 | ||
8 | # Default-Stop: 0 1 6 | ||
9 | # Short-Description: OpenWBEM CIMOM Daemon | ||
10 | # Description: owcimomd | ||
11 | # Start/Stop the OpenWBEM CIMOM Daemon | ||
12 | ### END INIT INFO | ||
13 | # | ||
14 | # | ||
15 | # chkconfig: 2345 36 64 | ||
16 | # description: OpenWBEM CIMOM Daemon | ||
17 | # processname: owcimomd | ||
18 | |||
19 | NAME=owcimomd | ||
20 | DAEMON=/usr/sbin/$NAME | ||
21 | OPTIONS= | ||
22 | PIDFILE=/var/run/$NAME.pid | ||
23 | |||
24 | if [ $EUID != 0 ]; then | ||
25 | echo "This script must be run as root." | ||
26 | exit 1; | ||
27 | fi | ||
28 | |||
29 | if [ "$DESCRIPTIVE" = "" ]; then | ||
30 | DESCRIPTIVE="OpenWBEM CIMOM Daemon" | ||
31 | fi | ||
32 | |||
33 | lockfile=${SVIlock:-/var/lock/subsys/$NAME} | ||
34 | |||
35 | [ -x $DAEMON ] || exit 0 | ||
36 | |||
37 | # See how we were called. | ||
38 | . /etc/init.d/functions | ||
39 | |||
40 | start() { | ||
41 | if [ ! -f "/etc/openwbem/serverkey.pem" ]; then | ||
42 | if [ -f "/etc/ssl/servercerts/servercert.pem" \ | ||
43 | -a -f "/etc/ssl/servercerts/serverkey.pem" ]; then | ||
44 | echo "Using common server certificate /etc/ssl/servercerts/servercert.pem" | ||
45 | ln -s /etc/ssl/servercerts/server{cert,key}.pem /etc/openwbem/ | ||
46 | else | ||
47 | echo "Generating OpenWBEM server public certificate and private key" | ||
48 | FQDN=`hostname --fqdn` | ||
49 | if [ "x${FQDN}" = "x" ]; then | ||
50 | FQDN=localhost.localdomain | ||
51 | fi | ||
52 | cat << EOF | sh /etc/openwbem/owgencert > /dev/null 2>&1 | ||
53 | -- | ||
54 | SomeState | ||
55 | SomeCity | ||
56 | SomeOrganization | ||
57 | SomeOrganizationalUnit | ||
58 | ${FQDN} | ||
59 | root@${FQDN} | ||
60 | EOF | ||
61 | fi | ||
62 | fi | ||
63 | |||
64 | # Start daemons. | ||
65 | echo -n "Starting the $DESCRIPTIVE" | ||
66 | daemon $DAEMON $OPTIONS > /dev/null 2>&1 | ||
67 | RETVAL=$? | ||
68 | |||
69 | if [ $RETVAL -eq 0 ]; then | ||
70 | touch $lockfile | ||
71 | success | ||
72 | fi | ||
73 | |||
74 | echo | ||
75 | return $RETVAL | ||
76 | } | ||
77 | |||
78 | stop() { | ||
79 | # Stop daemons. | ||
80 | echo -n "Shutting down $DESCRIPTIVE" | ||
81 | killproc $DAEMON | ||
82 | RETVAL=$? | ||
83 | |||
84 | if [ $RETVAL -eq 0 ]; then | ||
85 | rm -f $lockfile | ||
86 | success | ||
87 | else | ||
88 | failure | ||
89 | fi | ||
90 | echo | ||
91 | return $RETVAL | ||
92 | } | ||
93 | |||
94 | restart() { | ||
95 | stop | ||
96 | start | ||
97 | } | ||
98 | |||
99 | case "$1" in | ||
100 | start) | ||
101 | start | ||
102 | ;; | ||
103 | |||
104 | stop) | ||
105 | stop | ||
106 | ;; | ||
107 | |||
108 | restart|force-reload) | ||
109 | restart | ||
110 | ;; | ||
111 | |||
112 | reload) | ||
113 | echo -n "Reload service $DESCRIPTIVE" | ||
114 | killproc -p $PIDFILE -HUP $DAEMON | ||
115 | RETVAL=$? | ||
116 | echo | ||
117 | exit $RETVAL | ||
118 | ;; | ||
119 | |||
120 | status) | ||
121 | echo -n "Checking for service $DESCRIPTIVE" | ||
122 | status $DAEMON | ||
123 | RETVAL=$? | ||
124 | exit $RETVAL | ||
125 | ;; | ||
126 | |||
127 | *) | ||
128 | echo "Usage: $0 {restart|start|stop|reload|force-reload|status}" | ||
129 | esac | ||
130 | |||
131 | exit $RETVAL | ||
diff --git a/meta-oe/recipes-support/openwbem/openwbem/openwbem-rpmlintrc b/meta-oe/recipes-support/openwbem/openwbem/openwbem-rpmlintrc new file mode 100644 index 000000000..785e32aaa --- /dev/null +++ b/meta-oe/recipes-support/openwbem/openwbem/openwbem-rpmlintrc | |||
@@ -0,0 +1,2 @@ | |||
1 | addFilter("devel-file-in-non-devel-package .*/lib.*\.so") | ||
2 | |||
diff --git a/meta-oe/recipes-support/openwbem/openwbem/owcimomd.service b/meta-oe/recipes-support/openwbem/openwbem/owcimomd.service new file mode 100644 index 000000000..c6694b719 --- /dev/null +++ b/meta-oe/recipes-support/openwbem/openwbem/owcimomd.service | |||
@@ -0,0 +1,12 @@ | |||
1 | [Unit] | ||
2 | Description=Web Based Enterprise Management (WBEM) Implementation | ||
3 | After=syslog.target | ||
4 | |||
5 | [Service] | ||
6 | Type=forking | ||
7 | ExecStart=/usr/sbin/owcimomd | ||
8 | ExecStartPre=/etc/openwbem/checkserverkey | ||
9 | PIDFile=/var/run/owcimomd.pid | ||
10 | |||
11 | [Install] | ||
12 | WantedBy=multi-user.target | ||
diff --git a/meta-oe/recipes-support/openwbem/openwbem/rmmof.sh b/meta-oe/recipes-support/openwbem/openwbem/rmmof.sh new file mode 100644 index 000000000..a495415be --- /dev/null +++ b/meta-oe/recipes-support/openwbem/openwbem/rmmof.sh | |||
@@ -0,0 +1,53 @@ | |||
1 | #!/bin/sh | ||
2 | # | ||
3 | # options: | ||
4 | # rmmof.sh <MOF_PATH> <NAMESPACE> <FILES> | ||
5 | # | ||
6 | # - or - | ||
7 | # | ||
8 | # options: | ||
9 | # loadmof.sh -n <NAMESPACE> <FILES> [...] | ||
10 | # | ||
11 | # The former is preserved for compatibility with Pegasus and | ||
12 | # sblim providers. The latter is preferred. If $1 is "-n", | ||
13 | # the latter code path is executed. Otherwise the former is | ||
14 | # executed. | ||
15 | |||
16 | if [ "x$3" = "x" ]; then | ||
17 | echo "Usage: $0 -n <NAMESPACE> <FILES> [...]" | ||
18 | exit 1 | ||
19 | fi | ||
20 | |||
21 | # get rid of "-n" arg | ||
22 | shift | ||
23 | |||
24 | NS="$1" | ||
25 | |||
26 | shift | ||
27 | |||
28 | DBDIR=/var/lib/openwbem | ||
29 | CIMOM_INIT=/etc/init.d/owcimomd | ||
30 | if [ "$YAST_IS_RUNNING" != "instsys" ] ; then | ||
31 | $CIMOM_INIT status | ||
32 | CIMOM_RUNNING=$? | ||
33 | fi | ||
34 | if [ "x$CIMOM_RUNNING" = "x0" ]; then | ||
35 | $CIMOM_INIT stop | ||
36 | fi | ||
37 | bkpdir=/tmp/owrep.bkp-$$ | ||
38 | mkdir $bkpdir | ||
39 | cp -a $DBDIR $bkpdir/ | ||
40 | echo "Compiling MOF files" | ||
41 | /usr/bin/owmofc -r -n $NS -d $DBDIR "$@" > /dev/null 2>&1 | ||
42 | RVAL=$? | ||
43 | if [ "x$RVAL" != "x0" ]; then | ||
44 | echo "MOF import failed!" | ||
45 | rm -rf $DBDIR | ||
46 | mv $bkpdir/openwbem $DBDIR | ||
47 | fi | ||
48 | rm -rf $bkpdir | ||
49 | if [ "x$CIMOM_RUNNING" = "x0" ]; then | ||
50 | $CIMOM_INIT start | ||
51 | fi | ||
52 | exit $RVAL | ||
53 | |||
diff --git a/meta-oe/recipes-support/openwbem/openwbem_3.2.3.bb b/meta-oe/recipes-support/openwbem/openwbem_3.2.3.bb new file mode 100644 index 000000000..1b186329c --- /dev/null +++ b/meta-oe/recipes-support/openwbem/openwbem_3.2.3.bb | |||
@@ -0,0 +1,112 @@ | |||
1 | SUMMARY = "Web Based Enterprise Management (WBEM) Implementation" | ||
2 | DESCRIPTION = "OpenWBEM is a set of software components that help facilitate \ | ||
3 | deployment of the Common Information Model (CIM) and Web-Based \ | ||
4 | Enterprise Management (WBEM) technologies of the Distributed Management \ | ||
5 | Task Force (DMTF). \ | ||
6 | \ | ||
7 | Web-Based Enterprise Management (WBEM) is a set of management and \ | ||
8 | Internet standard technologies developed to unify the management of \ | ||
9 | distributed computing environments. WBEM provides the ability for the \ | ||
10 | industry to deliver a well-integrated set of standards-based management \ | ||
11 | tools, facilitating the exchange of data across otherwise disparate \ | ||
12 | technologies and platforms. \ | ||
13 | \ | ||
14 | For more information about DMTF and its technologies, visit \ | ||
15 | http://www.dmtf.org/standards. " | ||
16 | SECTION = "System/Management" | ||
17 | HOMEPAGE = "http://openwbem.sourceforge.net/" | ||
18 | |||
19 | inherit autotools-brokensep pkgconfig | ||
20 | |||
21 | SOURCE1="novell-openwbem-root-acl.mof" | ||
22 | SOURCE2="loadmof.sh" | ||
23 | SOURCE3="rmmof.sh" | ||
24 | SOURCE4="openwbem-owcimomd.init" | ||
25 | SOURCE5="openwbem-etc_pam.d_openwbem" | ||
26 | SOURCE6="openwbem-rpmlintrc" | ||
27 | |||
28 | SRC_URI = " \ | ||
29 | git://github.com/kkaempf/openwbem.git \ | ||
30 | file://${SOURCE1} \ | ||
31 | file://${SOURCE2} \ | ||
32 | file://${SOURCE3} \ | ||
33 | file://${SOURCE4} \ | ||
34 | file://${SOURCE5} \ | ||
35 | file://${SOURCE6} \ | ||
36 | file://checkserverkey \ | ||
37 | file://owcimomd.service \ | ||
38 | " | ||
39 | SRCREV = "5c688eefc1f8e35a4b1c58529aae5f114c25c2a8" | ||
40 | S = "${WORKDIR}/git" | ||
41 | LICENSE = "BSD-3-Clause" | ||
42 | LIC_FILES_CHKSUM += "file://COPYING;md5=0504a2eb85e01aa92c9efd4125a34660" | ||
43 | INSANE_SKIP_${PN} = "dev-so" | ||
44 | DEPENDS += "openssl libpam bash" | ||
45 | RDEPENDS_${PN} += "bash" | ||
46 | EXTRA_OECONF = " \ | ||
47 | --prefix=/usr \ | ||
48 | --sysconfdir=/etc \ | ||
49 | --libdir=${libdir} \ | ||
50 | --localstatedir=/var/lib \ | ||
51 | --libexecdir=${libdir}/openwbem/bin \ | ||
52 | --mandir=/usr/share/man \ | ||
53 | --enable-threads-run-as-user \ | ||
54 | " | ||
55 | do_configure_prepend() { | ||
56 | autoreconf --force --install | ||
57 | } | ||
58 | |||
59 | do_install() { | ||
60 | oe_runmake DESTDIR=${D} install | ||
61 | install -d ${D}/etc/openwbem/openwbem.conf.d | ||
62 | install -d ${D}/var/adm/fillup-templates | ||
63 | install -m 644 etc/sysconfig/daemons/owcimomd ${D}/var/adm/fillup-templates/sysconfig.owcimomd | ||
64 | |||
65 | # fix up hardcoded paths | ||
66 | sed -i -e 's,/usr/sbin/,${sbindir}/,' ${WORKDIR}/owcimomd.service | ||
67 | if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then | ||
68 | install -d ${D}/${systemd_unitdir}/system | ||
69 | install -m 644 ${WORKDIR}/owcimomd.service ${D}/${systemd_unitdir}/system | ||
70 | install -m 755 ${WORKDIR}/checkserverkey ${D}${sysconfdir}/openwbem/ | ||
71 | fi | ||
72 | |||
73 | install -d ${D}/etc/init.d | ||
74 | ln -sf ../../etc/init.d/owcimomd ${D}/usr/sbin/rcowcimomd | ||
75 | install -m 755 ${WORKDIR}/${SOURCE4} ${D}/etc/init.d/owcimomd | ||
76 | install -d ${D}${sbindir} | ||
77 | install -d ${D}/usr/bin | ||
78 | install -d ${D}/etc/pam.d | ||
79 | install -d ${D}/${libdir}/openwbem/cmpiproviders | ||
80 | install -m 644 etc/pam.d/openwbem ${D}/etc/pam.d | ||
81 | install -d ${D}/${libdir}/openwbem/c++providers | ||
82 | install -d ${D}/var/lib/openwbem | ||
83 | install -m 755 ${WORKDIR}/${SOURCE2} ${D}/usr/bin/ow-loadmof.sh | ||
84 | install -m 755 ${WORKDIR}/${SOURCE3} ${D}/usr/bin/ow-rmmof.sh | ||
85 | install -m 644 ${WORKDIR}/${SOURCE5} ${D}/etc/pam.d/openwbem | ||
86 | |||
87 | MOFPATH=${D}/usr/share/mof/openwbem | ||
88 | install -d $MOFPATH | ||
89 | mv ${D}/usr/share/openwbem/* $MOFPATH/ | ||
90 | rmdir ${D}/usr/share/openwbem | ||
91 | install -m 644 ${WORKDIR}/${SOURCE1} $MOFPATH/ | ||
92 | |||
93 | touch ${D}/var/lib/openwbem/{classassociation,instances,instassociation,namespaces,schema}.{dat,ndx,lock} | ||
94 | } | ||
95 | |||
96 | inherit ${@base_contains('VIRTUAL-RUNTIME_init_manager','systemd','systemd','', d)} | ||
97 | SYSTEMD_SERVICE_${PN} = "owcimomd.service" | ||
98 | SYSTEMD_AUTO_ENABLE = "disable" | ||
99 | FILES_${PN} += " \ | ||
100 | ${libdir} \ | ||
101 | ${datadir}/mof \ | ||
102 | ${systemd_unitdir} \ | ||
103 | " | ||
104 | FILES_${PN}-dbg += " \ | ||
105 | ${libdir}/openwbem/c++providers/.debug \ | ||
106 | ${libdir}/openwbem/provifcs/.debug \ | ||
107 | ${libdir}/openwbem/bin/openwbem/.debug \ | ||
108 | " | ||
109 | FILES_${PN}-dev = " \ | ||
110 | ${includedir} \ | ||
111 | ${datadir}/aclocal/openwbem.m4 \ | ||
112 | " | ||