summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2017-06-23 15:48:46 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-01 09:59:25 +0200
commit7b32361bd7e2a4a65123f90dcc1e9ff9e90ca2ba (patch)
tree4f20e115f1690e41cac57b3d843dde2bb3ad434e /meta-oe/recipes-support
parente50762e09b1624910daaf5bb28c4584c291b089b (diff)
downloadmeta-openembedded-7b32361bd7e2a4a65123f90dcc1e9ff9e90ca2ba.tar.gz
open-vm-tools: style changes
Various cosmetic changes to make the recipe match the style guide: http://www.openembedded.org/wiki/Styleguide Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb22
1 files changed, 14 insertions, 8 deletions
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
index 906eaba64..4ab2820c1 100644
--- a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
+++ b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
@@ -9,7 +9,8 @@
9# in meta-openembedded by agreement of the author (Diego Dompe). 9# in meta-openembedded by agreement of the author (Diego Dompe).
10# 10#
11 11
12DECRIPTION = "open-vm-tools" 12SUMMARY = "Tools to enhance VMWare guest integration and performance"
13HOMEPAGE = "https://github.com/vmware/open-vm-tools"
13SECTION = "vmware-tools" 14SECTION = "vmware-tools"
14 15
15LICENSE = "LGPLv2.1 & GPLv2 & BSD & CDDLv1" 16LICENSE = "LGPLv2.1 & GPLv2 & BSD & CDDLv1"
@@ -32,7 +33,6 @@ SRCREV = "854c0bb374612f7e633b448ca273f970f154458b"
32S = "${WORKDIR}/git/open-vm-tools" 33S = "${WORKDIR}/git/open-vm-tools"
33 34
34DEPENDS = "glib-2.0 glib-2.0-native util-linux libdnet procps" 35DEPENDS = "glib-2.0 glib-2.0-native util-linux libdnet procps"
35RDEPENDS_${PN} = "util-linux libdnet"
36 36
37# open-vm-tools is supported only on x86. 37# open-vm-tools is supported only on x86.
38COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux' 38COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
@@ -53,18 +53,24 @@ PACKAGECONFIG[x11] = ",${NO_X11_FLAGS},${X11_DEPENDS}"
53# fuse gets implicitly detected; there is no --without-fuse option. 53# fuse gets implicitly detected; there is no --without-fuse option.
54PACKAGECONFIG[fuse] = ",,fuse" 54PACKAGECONFIG[fuse] = ",,fuse"
55 55
56CFLAGS += '-Wno-error=deprecated-declarations' 56CFLAGS += "-Wno-error=deprecated-declarations"
57 57
58FILES_${PN} += "/usr/lib/open-vm-tools/plugins/vmsvc/lib*.so \ 58FILES_${PN} += "\
59 /usr/lib/open-vm-tools/plugins/common/lib*.so \ 59 /usr/lib/open-vm-tools/plugins/vmsvc/lib*.so \
60 ${sysconfdir}/vmware-tools/tools.conf" 60 /usr/lib/open-vm-tools/plugins/common/lib*.so \
61 ${sysconfdir}/vmware-tools/tools.conf \
62 "
61FILES_${PN}-locale += "/usr/share/open-vm-tools/messages" 63FILES_${PN}-locale += "/usr/share/open-vm-tools/messages"
62FILES_${PN}-dev += "/usr/lib/open-vm-tools/plugins/common/lib*.la" 64FILES_${PN}-dev += "/usr/lib/open-vm-tools/plugins/common/lib*.la"
63FILES_${PN}-dbg += "/usr/lib/open-vm-tools/plugins/common/.debug \ 65FILES_${PN}-dbg += "\
64 /usr/lib/open-vm-tools/plugins/vmsvc/.debug" 66 /usr/lib/open-vm-tools/plugins/common/.debug \
67 /usr/lib/open-vm-tools/plugins/vmsvc/.debug \
68 "
65 69
66CONFFILES_${PN} += "${sysconfdir}/vmware-tools/tools.conf" 70CONFFILES_${PN} += "${sysconfdir}/vmware-tools/tools.conf"
67 71
72RDEPENDS_${PN} = "util-linux libdnet fuse"
73
68do_install_append() { 74do_install_append() {
69 ln -sf /usr/sbin/mount.vmhgfs ${D}/sbin/mount.vmhgfs 75 ln -sf /usr/sbin/mount.vmhgfs ${D}/sbin/mount.vmhgfs
70 install -d ${D}${systemd_unitdir}/system ${D}${sysconfdir}/vmware-tools 76 install -d ${D}${systemd_unitdir}/system ${D}${sysconfdir}/vmware-tools