diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-04-24 12:37:18 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-26 20:14:15 +0200 |
commit | 6d8fabae746825c27bfd2bfb9b821617d5c94daf (patch) | |
tree | b7c33f7409bbedd6132a3cf104f84adc1f4d554b /meta-oe/recipes-support | |
parent | c9f063c218181e4eac3a0a67d74ce91b898a6443 (diff) | |
download | meta-openembedded-6d8fabae746825c27bfd2bfb9b821617d5c94daf.tar.gz |
geis: Fix build with gcc7
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/canonical-multitouch/geis/0001-libgeis-Compare-the-first-character-of-string-to-nul.patch | 43 | ||||
-rw-r--r-- | meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb | 5 |
2 files changed, 46 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/canonical-multitouch/geis/0001-libgeis-Compare-the-first-character-of-string-to-nul.patch b/meta-oe/recipes-support/canonical-multitouch/geis/0001-libgeis-Compare-the-first-character-of-string-to-nul.patch new file mode 100644 index 000000000..3b3acab24 --- /dev/null +++ b/meta-oe/recipes-support/canonical-multitouch/geis/0001-libgeis-Compare-the-first-character-of-string-to-nul.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | From 1e48821ba109b00e9c2931f12aa206c4ef54fd71 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 24 Apr 2017 12:34:55 -0700 | ||
4 | Subject: [PATCH] libgeis: Compare the first character of string to null | ||
5 | |||
6 | gcc7 wants to be specific when it comes to comparing characters | ||
7 | and strings | ||
8 | |||
9 | fixes | ||
10 | |||
11 | | ../../../../../../../workspace/sources/geis/libgeis/geis_v1.c: In function '_v1_subscribe_device': | ||
12 | | ../../../../../../../workspace/sources/geis/libgeis/geis_v1.c:613:20: error: comparison between pointer and zero character constant [-Werror=pointer-compare] | ||
13 | |||
14 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
15 | --- | ||
16 | libgeis/geis_v1.c | 4 ++-- | ||
17 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
18 | |||
19 | diff --git a/libgeis/geis_v1.c b/libgeis/geis_v1.c | ||
20 | index 67045ee..07c0851 100644 | ||
21 | --- a/libgeis/geis_v1.c | ||
22 | +++ b/libgeis/geis_v1.c | ||
23 | @@ -610,7 +610,7 @@ _v1_subscribe_device(GeisInstance instance, | ||
24 | const char **gesture_list) | ||
25 | { | ||
26 | GeisStatus result = GEIS_UNKNOWN_ERROR; | ||
27 | - if (gesture_list == GEIS_ALL_GESTURES) | ||
28 | + if (gesture_list[0][0] == GEIS_ALL_GESTURES) | ||
29 | { | ||
30 | geis_debug("subscribing device %d for all gestures", device_id); | ||
31 | } | ||
32 | @@ -757,7 +757,7 @@ geis_unsubscribe(GeisInstance instance, | ||
33 | GeisGestureType *gesture_list) | ||
34 | { | ||
35 | GeisStatus status = GEIS_STATUS_NOT_SUPPORTED; | ||
36 | - if (gesture_list == GEIS_ALL_GESTURES) | ||
37 | + if (gesture_list[0] == GEIS_ALL_GESTURES) | ||
38 | { | ||
39 | status = geis_subscription_deactivate(instance->subscription); | ||
40 | } | ||
41 | -- | ||
42 | 2.12.2 | ||
43 | |||
diff --git a/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb b/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb index 281dc3d42..976aafb4f 100644 --- a/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb +++ b/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb | |||
@@ -19,9 +19,10 @@ REQUIRED_DISTRO_FEATURES = "x11" | |||
19 | 19 | ||
20 | DEPENDS += "grail dbus-glib python3 virtual/libx11 libxext libxi libxcb dbus frame" | 20 | DEPENDS += "grail dbus-glib python3 virtual/libx11 libxext libxi libxcb dbus frame" |
21 | 21 | ||
22 | SRC_URI = "https://launchpad.net/${BPN}/trunk/${PV}/+download/${BPN}-${PV}.tar.xz\ | 22 | SRC_URI = "https://launchpad.net/${BPN}/trunk/${PV}/+download/${BPN}-${PV}.tar.xz \ |
23 | file://fix-indentation-for-gcc6.patch \ | 23 | file://fix-indentation-for-gcc6.patch \ |
24 | " | 24 | file://0001-libgeis-Compare-the-first-character-of-string-to-nul.patch \ |
25 | " | ||
25 | SRC_URI[md5sum] = "2ff9d76a3ea5794516bb02c9d1924faf" | 26 | SRC_URI[md5sum] = "2ff9d76a3ea5794516bb02c9d1924faf" |
26 | SRC_URI[sha256sum] = "8a60f5683852094038904e690d23cc5a90a980fc52da67f0f28890baa25c70eb" | 27 | SRC_URI[sha256sum] = "8a60f5683852094038904e690d23cc5a90a980fc52da67f0f28890baa25c70eb" |
27 | 28 | ||