diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-04-08 08:54:41 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-24 11:00:51 +0200 |
commit | 2d384da051f7ff4622c0d1a12b154dd94e4b893d (patch) | |
tree | 4137af925e7332bf3fc3ba2993e236fd4d67faef /meta-oe/recipes-support | |
parent | 4210d1a3eacbdc6fa34c2beffb9b6a79bf9ef0c0 (diff) | |
download | meta-openembedded-2d384da051f7ff4622c0d1a12b154dd94e4b893d.tar.gz |
sharutils: Upgrade to 4.15.2
Fix format error warnings with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
4 files changed, 50 insertions, 47 deletions
diff --git a/meta-oe/recipes-support/sharutils/sharutils-4.14/fix-for-cross-compiling.patch b/meta-oe/recipes-support/sharutils/sharutils-4.14/fix-for-cross-compiling.patch deleted file mode 100644 index 86a7da63c..000000000 --- a/meta-oe/recipes-support/sharutils/sharutils-4.14/fix-for-cross-compiling.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From 990234af84a5399017d1c4fe03c5c756a8e51e23 Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongjun Yang <Hongjun.Yang@windriver.com> | ||
3 | Date: Tue, 20 Aug 2013 09:41:43 +0800 | ||
4 | Subject: [PATCH] fix cross compiling issue | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Hongjun.Yang <hongjun.yang@windriver.com> | ||
9 | |||
10 | --- | ||
11 | configure | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/configure b/configure | ||
15 | index 6ee98e0..8067f54 100755 | ||
16 | --- a/configure | ||
17 | +++ b/configure | ||
18 | @@ -26965,7 +26965,7 @@ fi | ||
19 | if test "$cross_compiling" = yes; then : | ||
20 | { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5 | ||
21 | $as_echo "$as_me: error: in \`$ac_pwd':" >&2;} | ||
22 | -as_fn_error $? "cannot run test program while cross compiling | ||
23 | +$as_echo "cannot run test program while cross compiling | ||
24 | See \`config.log' for more details" "$LINENO" 5; } | ||
25 | else | ||
26 | cat confdefs.h - <<_ACEOF >conftest.$ac_ext | ||
27 | -- | ||
28 | 1.8.1.4 | ||
29 | |||
diff --git a/meta-oe/recipes-support/sharutils/sharutils/0001-Fix-build-with-clang.patch b/meta-oe/recipes-support/sharutils/sharutils/0001-Fix-build-with-clang.patch new file mode 100644 index 000000000..7b627c16d --- /dev/null +++ b/meta-oe/recipes-support/sharutils/sharutils/0001-Fix-build-with-clang.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From fa8371d348f6a8b0799b2e6c38247dd1399d85e3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 8 Apr 2017 08:49:48 -0700 | ||
4 | Subject: [PATCH] Fix build with clang | ||
5 | |||
6 | ATTRIBUTE_FORMAT_ARG macro gets computed to be empty with clang | ||
7 | whereas it does support format attribute, we hard code it | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/shar-opts.h | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/src/shar-opts.h b/src/shar-opts.h | ||
15 | index a287046..172676f 100644 | ||
16 | --- a/src/shar-opts.h | ||
17 | +++ b/src/shar-opts.h | ||
18 | @@ -377,7 +377,7 @@ extern tOptions sharOptions; | ||
19 | # define ATTRIBUTE_FORMAT_ARG(_a) | ||
20 | # endif | ||
21 | |||
22 | -static inline char* aoGetsText(char const* pz) ATTRIBUTE_FORMAT_ARG(1); | ||
23 | +static inline char* aoGetsText(char const* pz) __attribute__ ((format_arg(1))); | ||
24 | static inline char* aoGetsText(char const* pz) { | ||
25 | if (pz == NULL) return NULL; | ||
26 | return (char*)gettext(pz); | ||
27 | -- | ||
28 | 2.12.2 | ||
29 | |||
diff --git a/meta-oe/recipes-support/sharutils/sharutils_4.14.bb b/meta-oe/recipes-support/sharutils/sharutils_4.14.bb deleted file mode 100644 index d69e6ecbd..000000000 --- a/meta-oe/recipes-support/sharutils/sharutils_4.14.bb +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | SUMMARY = "This is the set of GNU shar utilities." | ||
2 | HOMEPAGE = "http://www.gnu.org/software/sharutils/" | ||
3 | SECTION = "console/utils" | ||
4 | LICENSE="GPLv3+" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
6 | |||
7 | inherit gettext autotools-brokensep | ||
8 | |||
9 | SRC_URI = "ftp://ftp.gnu.org/gnu/sharutils/sharutils-4.14.tar.gz \ | ||
10 | file://fix-for-cross-compiling.patch \ | ||
11 | " | ||
12 | |||
13 | SRC_URI[md5sum] = "5686c11131b4c4c0841f8f3ef34d136a" | ||
14 | SRC_URI[sha256sum] = "90f5107c167cfd1b299bb211828d2586471087863dbed698f53109cd5f717208" | ||
15 | |||
16 | do_configure () { | ||
17 | oe_runconf | ||
18 | } | ||
diff --git a/meta-oe/recipes-support/sharutils/sharutils_4.15.2.bb b/meta-oe/recipes-support/sharutils/sharutils_4.15.2.bb new file mode 100644 index 000000000..812fee955 --- /dev/null +++ b/meta-oe/recipes-support/sharutils/sharutils_4.15.2.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | SUMMARY = "This is the set of GNU shar utilities." | ||
2 | HOMEPAGE = "http://www.gnu.org/software/sharutils/" | ||
3 | SECTION = "console/utils" | ||
4 | LICENSE="GPLv3+" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
6 | |||
7 | inherit gettext autotools | ||
8 | |||
9 | SRC_URI = "ftp://ftp.gnu.org/gnu/${BPN}/${BP}.tar.gz \ | ||
10 | file://0001-Fix-build-with-clang.patch \ | ||
11 | " | ||
12 | SRC_URI[md5sum] = "32a51b23e25ad5e6af4b89f228be1800" | ||
13 | SRC_URI[sha256sum] = "ee336e68549664e7a19b117adf02edfdeac6307f22e5ba78baca457116914637" | ||
14 | |||
15 | do_install_append() { | ||
16 | if [ -e ${D}${libdir}/charset.alias ] | ||
17 | then | ||
18 | rm -rf ${D}${libdir}/charset.alias | ||
19 | rmdir --ignore-fail-on-non-empty ${D}${libdir} | ||
20 | fi | ||
21 | } | ||