summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-18 18:05:15 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-22 16:04:13 +0200
commit10bd8e8c6f2421c7e0a5aef5bff193d098f1136d (patch)
tree594ea2619a9378bdbe2fc8c83a39310e3329694d /meta-oe/recipes-support
parent941de88164f86c35bba335e62811582877137e9e (diff)
downloadmeta-openembedded-10bd8e8c6f2421c7e0a5aef5bff193d098f1136d.tar.gz
sqlite: Fix build with hardening flags
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/sqlite/sqlite-2.8.17/0001-shell.c-Fix-format-not-a-string-literal-warning.patch32
-rw-r--r--meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb8
2 files changed, 37 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/sqlite/sqlite-2.8.17/0001-shell.c-Fix-format-not-a-string-literal-warning.patch b/meta-oe/recipes-support/sqlite/sqlite-2.8.17/0001-shell.c-Fix-format-not-a-string-literal-warning.patch
new file mode 100644
index 000000000..c5d7c0c81
--- /dev/null
+++ b/meta-oe/recipes-support/sqlite/sqlite-2.8.17/0001-shell.c-Fix-format-not-a-string-literal-warning.patch
@@ -0,0 +1,32 @@
1From 443980ddc82fb40e2e1f9544f2be169bd23dd246 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 17 Jun 2017 16:49:24 -0700
4Subject: [PATCH] shell.c: Fix format not a string literal warning
5
6src/shell.c:695:20: error: format not a string literal and no format arguments [-Werror=format-security]
7| fprintf(stderr,zHelp);
8| ^~~~~
9
10Upstream-Status: Pending
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 src/shell.c | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/src/shell.c b/src/shell.c
18index bb46c49..3c6fe0f 100644
19--- a/src/shell.c
20+++ b/src/shell.c
21@@ -692,7 +692,7 @@ static int do_meta_command(char *zLine, struct callback_data *p){
22 }else
23
24 if( c=='h' && strncmp(azArg[0], "help", n)==0 ){
25- fprintf(stderr,zHelp);
26+ fprintf(stderr, "%s", zHelp);
27 }else
28
29 if( c=='i' && strncmp(azArg[0], "indices", n)==0 && nArg>1 ){
30--
312.13.1
32
diff --git a/meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb b/meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb
index e6e14c2ad..501c0e3e7 100644
--- a/meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb
+++ b/meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb
@@ -8,9 +8,11 @@ LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=10;md5=e98469a8efa024a
8PR = "r7" 8PR = "r7"
9 9
10SRC_URI = "http://www.hwaci.com/sw/sqlite/sqlite-${PV}.tar.gz \ 10SRC_URI = "http://www.hwaci.com/sw/sqlite/sqlite-${PV}.tar.gz \
11 file://mainmk_build_dynamic.patch \ 11 file://mainmk_build_dynamic.patch \
12 file://mainmk_no_tcl.patch \ 12 file://mainmk_no_tcl.patch \
13 file://sqlite.pc" 13 file://sqlite.pc \
14 file://0001-shell.c-Fix-format-not-a-string-literal-warning.patch \
15 "
14 16
15SOURCES = "attach.o auth.o btree.o btree_rb.o build.o copy.o date.o delete.o \ 17SOURCES = "attach.o auth.o btree.o btree_rb.o build.o copy.o date.o delete.o \
16 expr.o func.o hash.o insert.o main.o opcodes.o os.o pager.o \ 18 expr.o func.o hash.o insert.o main.o opcodes.o os.o pager.o \