diff options
author | Nick D'Ademo <nickdademo@gmail.com> | 2013-11-28 13:38:38 +1100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-12-05 19:48:08 +0100 |
commit | f7ab0eb3bab2924ba46994c0843efe970796da36 (patch) | |
tree | 5f7a3f66ba2391d24eba2a2da86d7ab9070c842f /meta-oe/recipes-support | |
parent | 99f52e58d13cb0a1cda03a6f75d8b3fb527f6dd2 (diff) | |
download | meta-openembedded-f7ab0eb3bab2924ba46994c0843efe970796da36.tar.gz |
opencv: bump SRCREV and make recipe multilib build compatible
Pass LIB_SUFFIX to CMake during a multilib build so that the generated library folder has the correct suffix.
Signed-off-by: Nick D'Ademo <nickdademo@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/opencv/opencv_2.4.bb | 10 |
1 files changed, 9 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_2.4.bb b/meta-oe/recipes-support/opencv/opencv_2.4.bb index 9dd9cd0477..df89b0a431 100644 --- a/meta-oe/recipes-support/opencv/opencv_2.4.bb +++ b/meta-oe/recipes-support/opencv/opencv_2.4.bb | |||
@@ -9,7 +9,7 @@ ARM_INSTRUCTION_SET = "arm" | |||
9 | 9 | ||
10 | DEPENDS = "python-numpy libtool swig swig-native python bzip2 zlib glib-2.0" | 10 | DEPENDS = "python-numpy libtool swig swig-native python bzip2 zlib glib-2.0" |
11 | 11 | ||
12 | SRCREV = "c5afaa4e8dfe507e87531f7688b9cf65c1f701c6" | 12 | SRCREV = "1253c2101b22b9e89400553fd220858cda8d6ea5" |
13 | SRC_URI = "git://github.com/Itseez/opencv.git;branch=2.4 \ | 13 | SRC_URI = "git://github.com/Itseez/opencv.git;branch=2.4 \ |
14 | file://opencv-fix-pkgconfig-generation.patch \ | 14 | file://opencv-fix-pkgconfig-generation.patch \ |
15 | " | 15 | " |
@@ -27,6 +27,8 @@ EXTRA_OECMAKE = "-DPYTHON_NUMPY_INCLUDE_DIR:PATH=${STAGING_LIBDIR}/${PYTHON_DIR} | |||
27 | -DWITH_GSTREAMER=OFF \ | 27 | -DWITH_GSTREAMER=OFF \ |
28 | -DCMAKE_SKIP_RPATH=ON \ | 28 | -DCMAKE_SKIP_RPATH=ON \ |
29 | ${@bb.utils.contains("TARGET_CC_ARCH", "-msse3", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1", "", d)} \ | 29 | ${@bb.utils.contains("TARGET_CC_ARCH", "-msse3", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1", "", d)} \ |
30 | ${@base_conditional("libdir", "/usr/lib64", "-DLIB_SUFFIX=64", "", d)} \ | ||
31 | ${@base_conditional("libdir", "/usr/lib32", "-DLIB_SUFFIX=32", "", d)} \ | ||
30 | " | 32 | " |
31 | 33 | ||
32 | PACKAGECONFIG ??= "eigen gtk jpeg libav png tiff v4l" | 34 | PACKAGECONFIG ??= "eigen gtk jpeg libav png tiff v4l" |
@@ -88,4 +90,10 @@ RDEPENDS_python-opencv = "python-core python-numpy" | |||
88 | do_install_append() { | 90 | do_install_append() { |
89 | cp ${S}/include/opencv/*.h ${D}${includedir}/opencv/ | 91 | cp ${S}/include/opencv/*.h ${D}${includedir}/opencv/ |
90 | sed -i '/blobtrack/d' ${D}${includedir}/opencv/cvaux.h | 92 | sed -i '/blobtrack/d' ${D}${includedir}/opencv/cvaux.h |
93 | |||
94 | # Move Python files into correct library folder (for multilib build) | ||
95 | if [ "$libdir" != "/usr/lib" ]; then | ||
96 | mv ${D}/usr/lib/* ${D}/${libdir}/ | ||
97 | rm -rf ${D}/usr/lib | ||
98 | fi | ||
91 | } | 99 | } |