diff options
author | mike.looijmans@topic.nl <mike.looijmans@topic.nl> | 2015-03-05 11:24:25 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-03-06 07:33:25 +0100 |
commit | aa030ae90fb8fadcff320f5d7c751ccb4fdd82bf (patch) | |
tree | b62bd177245bc2f882ee93c5a32a07ef655f6558 /meta-oe/recipes-support | |
parent | f67d6c8b121554b4a323a2d354cd60e302d28cd9 (diff) | |
download | meta-openembedded-aa030ae90fb8fadcff320f5d7c751ccb4fdd82bf.tar.gz |
opencv: Upgrade to 2.4.11
Upgrade OpenCV to the 2.4.11 release.
Remove the opencv-fix-pkgconfig-generation patch which has been integrated upstream,
be it in modified form.
Disable 1394 support by default to get a deterministic build.
Fix "jasper" dependency, the BUILD_JASPER parameter served only to build an internal
library, while WITH_JASPER actually controls whether jpeg2000 support was desired.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/opencv/opencv/opencv-fix-pkgconfig-generation.patch | 44 | ||||
-rw-r--r-- | meta-oe/recipes-support/opencv/opencv_2.4.bb | 11 |
2 files changed, 5 insertions, 50 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv/opencv-fix-pkgconfig-generation.patch b/meta-oe/recipes-support/opencv/opencv/opencv-fix-pkgconfig-generation.patch deleted file mode 100644 index d352778c94..0000000000 --- a/meta-oe/recipes-support/opencv/opencv/opencv-fix-pkgconfig-generation.patch +++ /dev/null | |||
@@ -1,44 +0,0 @@ | |||
1 | Fix pkg-config generation | ||
2 | |||
3 | Replace absolute library path with library name spec and library search | ||
4 | path option. | ||
5 | |||
6 | The fix has been provided by Ray Rashif (code.opencv.org/issues/1925) | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | |||
10 | diff -Nbaur OpenCV-2.4.3.orig/cmake/OpenCVGenPkgconfig.cmake OpenCV-2.4.3/cmake/OpenCVGenPkgconfig.cmake | ||
11 | --- OpenCV-2.4.3.orig/cmake/OpenCVGenPkgconfig.cmake 2012-11-04 08:40:14.243505926 +0000 | ||
12 | +++ OpenCV-2.4.3/cmake/OpenCVGenPkgconfig.cmake 2012-11-04 08:40:42.286649120 +0000 | ||
13 | @@ -10,7 +10,7 @@ | ||
14 | # ------------------------------------------------------------------------------------------- | ||
15 | set(prefix "${CMAKE_INSTALL_PREFIX}") | ||
16 | set(exec_prefix "\${prefix}") | ||
17 | -set(libdir "") #TODO: need link paths for OpenCV_EXTRA_COMPONENTS | ||
18 | +set(libdir "\${prefix}/${OPENCV_LIB_INSTALL_PATH}") | ||
19 | set(includedir "\${prefix}/${OPENCV_INCLUDE_INSTALL_PATH}") | ||
20 | set(VERSION ${OPENCV_VERSION}) | ||
21 | |||
22 | @@ -36,10 +36,11 @@ | ||
23 | ocv_list_reverse(OpenCV_EXTRA_COMPONENTS) | ||
24 | |||
25 | #build the list of components | ||
26 | -set(OpenCV_LIB_COMPONENTS_ "") | ||
27 | +set(OpenCV_LIB_COMPONENTS_ "-L\${libdir}") | ||
28 | foreach(CVLib ${OpenCV_LIB_COMPONENTS}) | ||
29 | get_target_property(libpath ${CVLib} LOCATION_${CMAKE_BUILD_TYPE}) | ||
30 | get_filename_component(libname "${libpath}" NAME) | ||
31 | + get_filename_component(lname "${libpath}" NAME_WE) | ||
32 | |||
33 | if(INSTALL_TO_MANGLED_PATHS) | ||
34 | set(libname "${libname}.${OPENCV_VERSION}") | ||
35 | @@ -52,7 +53,8 @@ | ||
36 | set(installDir "${OPENCV_LIB_INSTALL_PATH}") | ||
37 | endif() | ||
38 | |||
39 | - set(OpenCV_LIB_COMPONENTS_ "${OpenCV_LIB_COMPONENTS_} \${exec_prefix}/${installDir}/${libname}") | ||
40 | + string(REPLACE "libopencv" "-lopencv" lname "${lname}") | ||
41 | + set(OpenCV_LIB_COMPONENTS_ "${OpenCV_LIB_COMPONENTS_} ${lname}") | ||
42 | endforeach() | ||
43 | |||
44 | # add extra dependencies required for OpenCV | ||
diff --git a/meta-oe/recipes-support/opencv/opencv_2.4.bb b/meta-oe/recipes-support/opencv/opencv_2.4.bb index 63d7c8b25b..27546161d2 100644 --- a/meta-oe/recipes-support/opencv/opencv_2.4.bb +++ b/meta-oe/recipes-support/opencv/opencv_2.4.bb | |||
@@ -9,12 +9,10 @@ ARM_INSTRUCTION_SET = "arm" | |||
9 | 9 | ||
10 | DEPENDS = "python-numpy libtool swig swig-native python bzip2 zlib glib-2.0" | 10 | DEPENDS = "python-numpy libtool swig swig-native python bzip2 zlib glib-2.0" |
11 | 11 | ||
12 | SRCREV = "df8e28283f09825cca0c2902160b7abebcfe1b64" | 12 | SRCREV = "2c9547e3147779001811d01936aed38f560929fc" |
13 | SRC_URI = "git://github.com/Itseez/opencv.git;branch=2.4 \ | 13 | SRC_URI = "git://github.com/Itseez/opencv.git;branch=2.4" |
14 | file://opencv-fix-pkgconfig-generation.patch \ | ||
15 | " | ||
16 | 14 | ||
17 | PV = "2.4.9+git${SRCPV}" | 15 | PV = "2.4.11+git${SRCPV}" |
18 | 16 | ||
19 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
20 | 18 | ||
@@ -25,6 +23,7 @@ OECMAKE_BUILDPATH = "${WORKDIR}/build-${TARGET_ARCH}" | |||
25 | EXTRA_OECMAKE = "-DPYTHON_NUMPY_INCLUDE_DIR:PATH=${STAGING_LIBDIR}/${PYTHON_DIR}/site-packages/numpy/core/include \ | 23 | EXTRA_OECMAKE = "-DPYTHON_NUMPY_INCLUDE_DIR:PATH=${STAGING_LIBDIR}/${PYTHON_DIR}/site-packages/numpy/core/include \ |
26 | -DBUILD_PYTHON_SUPPORT=ON \ | 24 | -DBUILD_PYTHON_SUPPORT=ON \ |
27 | -DWITH_GSTREAMER=OFF \ | 25 | -DWITH_GSTREAMER=OFF \ |
26 | -DWITH_1394=OFF \ | ||
28 | -DCMAKE_SKIP_RPATH=ON \ | 27 | -DCMAKE_SKIP_RPATH=ON \ |
29 | ${@bb.utils.contains("TARGET_CC_ARCH", "-msse3", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1", "", d)} \ | 28 | ${@bb.utils.contains("TARGET_CC_ARCH", "-msse3", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1", "", d)} \ |
30 | ${@base_conditional("libdir", "/usr/lib64", "-DLIB_SUFFIX=64", "", d)} \ | 29 | ${@base_conditional("libdir", "/usr/lib64", "-DLIB_SUFFIX=64", "", d)} \ |
@@ -40,7 +39,7 @@ PACKAGECONFIG[libav] = "-DWITH_FFMPEG=ON,-DWITH_FFMPEG=OFF,libav," | |||
40 | PACKAGECONFIG[png] = "-DWITH_PNG=ON,-DWITH_PNG=OFF,libpng," | 39 | PACKAGECONFIG[png] = "-DWITH_PNG=ON,-DWITH_PNG=OFF,libpng," |
41 | PACKAGECONFIG[tiff] = "-DWITH_TIFF=ON,-DWITH_TIFF=OFF,tiff," | 40 | PACKAGECONFIG[tiff] = "-DWITH_TIFF=ON,-DWITH_TIFF=OFF,tiff," |
42 | PACKAGECONFIG[v4l] = "-DWITH_V4L=ON,-DWITH_V4L=OFF,v4l-utils," | 41 | PACKAGECONFIG[v4l] = "-DWITH_V4L=ON,-DWITH_V4L=OFF,v4l-utils," |
43 | PACKAGECONFIG[jasper] = "-DBUILD_JASPER=ON,-DBUILD_JASPER=OFF,jasper" | 42 | PACKAGECONFIG[jasper] = "-DWITH_JASPER=ON,-DWITH_JASPER=OFF,jasper," |
44 | 43 | ||
45 | inherit distutils-base pkgconfig cmake | 44 | inherit distutils-base pkgconfig cmake |
46 | 45 | ||