summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorstephen.arnold42 <stephen.arnold42@gmail.com>2014-09-12 18:13:43 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-09-26 05:42:53 +0200
commit48452bcd3001e26898d8156fa16fdd5dbbaa9d4b (patch)
tree5be56dc4ce4f9e2eea10b9fc780ddce16121a1b7 /meta-oe/recipes-support
parentbb1773547109be47968b0e644ca8449e50d847bb (diff)
downloadmeta-openembedded-48452bcd3001e26898d8156fa16fdd5dbbaa9d4b.tar.gz
xchat: update recipe with build/configure fixes
Update recipe with build/configure fixes (rework autotools config, add patch for separate build dir, add patch for automake foreign, add PACKAGECONFIG option for python interface, move dbus to RDEPEND, as dbus-glib header is required for build; the last one is a workaround for the QA depend warning on more than one dep in PKGCONF). Upstream-Status: Inappropriate (no more upstream) Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Steve Arnold <stephen.arnold42@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/xchat/xchat-2.8.8/automake-foreign.patch11
-rw-r--r--meta-oe/recipes-support/xchat/xchat-2.8.8/fix-includes-for-separate-build.patch78
-rw-r--r--meta-oe/recipes-support/xchat/xchat_2.8.8.bb19
3 files changed, 99 insertions, 9 deletions
diff --git a/meta-oe/recipes-support/xchat/xchat-2.8.8/automake-foreign.patch b/meta-oe/recipes-support/xchat/xchat-2.8.8/automake-foreign.patch
new file mode 100644
index 000000000..cfa2f6c7f
--- /dev/null
+++ b/meta-oe/recipes-support/xchat/xchat-2.8.8/automake-foreign.patch
@@ -0,0 +1,11 @@
1--- a/configure.in 2014-08-18 01:25:43.911597023 -0700
2+++ b/configure.in 2014-08-18 01:26:27.763786629 -0700
3@@ -8,7 +8,7 @@
4 AC_CONFIG_HEADERS([config.h])
5 AC_CONFIG_SRCDIR([configure.in])
6
7-AM_INIT_AUTOMAKE([1.9 dist-bzip2 subdir-objects no-define])
8+AM_INIT_AUTOMAKE([1.9 foreign dist-bzip2 subdir-objects no-define])
9
10 AM_MAINTAINER_MODE
11 AC_PROG_CC
diff --git a/meta-oe/recipes-support/xchat/xchat-2.8.8/fix-includes-for-separate-build.patch b/meta-oe/recipes-support/xchat/xchat-2.8.8/fix-includes-for-separate-build.patch
new file mode 100644
index 000000000..4394e5257
--- /dev/null
+++ b/meta-oe/recipes-support/xchat/xchat-2.8.8/fix-includes-for-separate-build.patch
@@ -0,0 +1,78 @@
1diff -ur xchat-2.8.8-orig/plugins/perl/perl.c xchat-2.8.8/plugins/perl/perl.c
2--- xchat-2.8.8-orig/plugins/perl/perl.c 2014-08-30 14:09:05.125116286 -0700
3+++ xchat-2.8.8/plugins/perl/perl.c 2014-08-30 14:09:45.281106532 -0700
4@@ -31,7 +31,7 @@
5 #endif
6
7 #undef PACKAGE
8-#include "../../config.h" /* for #define OLD_PERL */
9+#include <config.h> /* for #define OLD_PERL */
10 #include "xchat-plugin.h"
11
12 static xchat_plugin *ph; /* plugin handle */
13diff -ur xchat-2.8.8-orig/src/common/network.c xchat-2.8.8/src/common/network.c
14--- xchat-2.8.8-orig/src/common/network.c 2014-08-30 14:09:05.137116222 -0700
15+++ xchat-2.8.8/src/common/network.c 2014-08-30 14:13:52.729116323 -0700
16@@ -24,7 +24,7 @@
17 #include <unistd.h>
18 #include <glib.h>
19
20-#include "../../config.h" /* grab USE_IPV6 and LOOKUPD defines */
21+#include <config.h> /* grab USE_IPV6 and LOOKUPD defines */
22
23 #define WANTSOCKET
24 #define WANTARPA
25diff -ur xchat-2.8.8-orig/src/common/ssl.c xchat-2.8.8/src/common/ssl.c
26--- xchat-2.8.8-orig/src/common/ssl.c 2014-08-30 14:09:05.137116222 -0700
27+++ xchat-2.8.8/src/common/ssl.c 2014-08-30 14:14:08.449133899 -0700
28@@ -23,7 +23,7 @@
29 #include <string.h> /* strncpy() */
30 #include "ssl.h" /* struct cert_info */
31 #include "inet.h"
32-#include "../../config.h" /* HAVE_SNPRINTF */
33+#include <config.h> /* HAVE_SNPRINTF */
34
35 #ifndef HAVE_SNPRINTF
36 #define snprintf g_snprintf
37diff -ur xchat-2.8.8-orig/src/common/util.c xchat-2.8.8/src/common/util.c
38--- xchat-2.8.8-orig/src/common/util.c 2014-08-30 14:09:05.133116243 -0700
39+++ xchat-2.8.8/src/common/util.c 2014-08-30 14:10:23.633116070 -0700
40@@ -41,7 +41,7 @@
41 #include "xchatc.h"
42 #include <ctype.h>
43 #include "util.h"
44-#include "../../config.h"
45+#include <config.h>
46
47 #define WANTSOCKET
48 #include "inet.h"
49diff -ur xchat-2.8.8-orig/src/common/xchat.h xchat-2.8.8/src/common/xchat.h
50--- xchat-2.8.8-orig/src/common/xchat.h 2014-08-30 14:09:05.133116243 -0700
51+++ xchat-2.8.8/src/common/xchat.h 2014-08-30 14:13:42.797116472 -0700
52@@ -1,4 +1,4 @@
53-#include "../../config.h"
54+#include <config.h>
55
56 #include <glib.h>
57 #include <time.h> /* need time_t */
58diff -ur xchat-2.8.8-orig/src/fe-gtk/fe-gtk.h xchat-2.8.8/src/fe-gtk/fe-gtk.h
59--- xchat-2.8.8-orig/src/fe-gtk/fe-gtk.h 2014-08-30 14:09:05.129116272 -0700
60+++ xchat-2.8.8/src/fe-gtk/fe-gtk.h 2014-08-30 14:10:13.309115951 -0700
61@@ -1,4 +1,4 @@
62-#include "../../config.h"
63+#include <config.h>
64
65 #ifdef WIN32
66 /* If you're compiling this for Windows, your release is un-official
67diff -ur xchat-2.8.8-orig/src/fe-gtk/xtext.c xchat-2.8.8/src/fe-gtk/xtext.c
68--- xchat-2.8.8-orig/src/fe-gtk/xtext.c 2014-08-30 14:09:05.129116272 -0700
69+++ xchat-2.8.8/src/fe-gtk/xtext.c 2014-08-30 14:10:00.313138254 -0700
70@@ -51,7 +51,7 @@
71 #include <gtk/gtkwindow.h>
72
73 #ifdef XCHAT
74-#include "../../config.h" /* can define USE_XLIB here */
75+#include <config.h> /* can define USE_XLIB here */
76 #else
77 #define USE_XLIB
78 #endif
diff --git a/meta-oe/recipes-support/xchat/xchat_2.8.8.bb b/meta-oe/recipes-support/xchat/xchat_2.8.8.bb
index fe07bc26b..6da11cd94 100644
--- a/meta-oe/recipes-support/xchat/xchat_2.8.8.bb
+++ b/meta-oe/recipes-support/xchat/xchat_2.8.8.bb
@@ -2,33 +2,34 @@ SUMMARY = "Full-featured IRC chat client with scripting support"
2LICENSE = "GPLv2+" 2LICENSE = "GPLv2+"
3HOMEPAGE = "http://www.xchat.org" 3HOMEPAGE = "http://www.xchat.org"
4SECTION = "x11/network" 4SECTION = "x11/network"
5
5DEPENDS = "libgcrypt zlib gtk+ libsexy" 6DEPENDS = "libgcrypt zlib gtk+ libsexy"
6DEPENDS += "gdk-pixbuf-native" 7DEPENDS += "gdk-pixbuf-native"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
8 8
9PR = "r1" 9LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
10 10
11PNBLACKLIST[xchat] = "BROKEN: Doesn't work with B!=S" 11PR = "r2"
12 12
13SRC_URI = "http://xchat.org/files/source/2.8/xchat-${PV}.tar.bz2 \ 13SRC_URI = "http://xchat.org/files/source/2.8/xchat-${PV}.tar.bz2 \
14 file://glib-2.32.patch \ 14 file://glib-2.32.patch \
15 file://automake-foreign.patch \
16 file://fix-includes-for-separate-build.patch \
15" 17"
16 18
17inherit autotools gettext 19inherit autotools gettext pkgconfig
18 20
19PACKAGECONFIG ??= "dbus" 21PACKAGECONFIG ??= "dbus"
20PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus dbus-glib" 22PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus-glib"
21PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" 23PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
24PACKAGECONFIG[python] = "--enable-python,--disable-python,python"
22 25
23EXTRA_OECONF = "\ 26EXTRA_OECONF = "\
27 --enable-maintainer-mode \
24 --disable-perl \ 28 --disable-perl \
25 --disable-python \
26 --disable-tcl \ 29 --disable-tcl \
27" 30"
28do_configure_prepend(){
29 rm -f ${S}/po/Makefile.in.in
30}
31 31
32RDEPENDS_${PN} += "dbus"
32FILES_${PN} += "${datadir}/dbus-1" 33FILES_${PN} += "${datadir}/dbus-1"
33FILES_${PN}-dbg += "${libdir}/xchat/plugins/.debug" 34FILES_${PN}-dbg += "${libdir}/xchat/plugins/.debug"
34 35