diff options
author | Matthieu CRAPET <Matthieu.CRAPET@ingenico.com> | 2014-05-12 12:00:59 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-05-15 12:30:19 +0200 |
commit | 228119cb3e06460192035966b18d3c24c3d0f3d9 (patch) | |
tree | 6cf89b9caa66e9e254048c2bd57a07f1112d3271 /meta-oe/recipes-support/xdelta | |
parent | de87d83a642d720d8330808978d4cf0ea3c22d96 (diff) | |
download | meta-openembedded-228119cb3e06460192035966b18d3c24c3d0f3d9.tar.gz |
xdelta3: add optional lzma support
Using PACKAGECONFIG. Disabled by default.
Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/xdelta')
-rw-r--r-- | meta-oe/recipes-support/xdelta/files/with-liblzma-configure-option.patch | 55 | ||||
-rw-r--r-- | meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb | 8 |
2 files changed, 62 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/xdelta/files/with-liblzma-configure-option.patch b/meta-oe/recipes-support/xdelta/files/with-liblzma-configure-option.patch new file mode 100644 index 000000000..4b99290d2 --- /dev/null +++ b/meta-oe/recipes-support/xdelta/files/with-liblzma-configure-option.patch | |||
@@ -0,0 +1,55 @@ | |||
1 | Upstream-Status: Pending, Submitted | ||
2 | http://code.google.com/p/xdelta/issues/detail?id=178 | ||
3 | |||
4 | xdelta3: add --with-liblzma configure option | ||
5 | |||
6 | As xdelta3 can be compiled with or without liblzma external library, make it configurable. | ||
7 | Default is autodetect (unchanged behavior). | ||
8 | |||
9 | Signed-off-by: Matthieu Crapet <mcrapet@gmail.com> | ||
10 | --- | ||
11 | configure.ac | 21 +++++++++++++++++++-- | ||
12 | 1 file changed, 19 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/configure.ac b/configure.ac | ||
15 | index 3b430d7..8c53ba8 100644 | ||
16 | --- a/configure.ac | ||
17 | +++ b/configure.ac | ||
18 | @@ -8,8 +8,6 @@ AM_INIT_AUTOMAKE([1.9 no-define foreign tar-ustar]) | ||
19 | AX_CHECK_ALIGNED_ACCESS_REQUIRED | ||
20 | AC_PROG_CC | ||
21 | AC_PROG_CXX | ||
22 | -AC_CHECK_HEADERS([lzma.h]) | ||
23 | -AC_CHECK_LIB(lzma, lzma_easy_buffer_encode) | ||
24 | AC_CHECK_SIZEOF(size_t) | ||
25 | #AM_PATH_PYTHON(,, [:]) | ||
26 | #AM_CONDITIONAL([HAVE_PYTHON], [test "$PYTHON" != :]) | ||
27 | @@ -22,6 +20,25 @@ AC_ARG_ENABLE(debug-symbols, | ||
28 | AS_HELP_STRING(--enable-debug-symbols,[Build with debug symbols (default is NO)]),,enableval=no) | ||
29 | AM_CONDITIONAL([DEBUG_SYMBOLS], [test ${enableval} = "yes"]) | ||
30 | |||
31 | +AC_ARG_WITH( | ||
32 | + [liblzma], | ||
33 | + [AC_HELP_STRING( | ||
34 | + [--with-liblzma], | ||
35 | + [build with liblzma support @<:@default=autodetect@:>@])], | ||
36 | + [USE_LIBLZMA=$withval], | ||
37 | + [USE_LIBLZMA=auto]) | ||
38 | + | ||
39 | +if test "x$USE_LIBLZMA" != xno ; then | ||
40 | + AC_CHECK_HEADERS([lzma.h],,[ | ||
41 | + if test "x$with_liblzma" = xyes ; then | ||
42 | + AC_MSG_FAILURE([liblzma includes was not found]) | ||
43 | + fi]) | ||
44 | + AC_CHECK_LIB([lzma], [lzma_easy_buffer_encode],,[ | ||
45 | + if test "x$with_liblzma" = xyes ; then | ||
46 | + AC_MSG_FAILURE([liblzma library was not found]) | ||
47 | + fi]) | ||
48 | +fi | ||
49 | + | ||
50 | AC_CONFIG_HEADERS([config.h]) | ||
51 | AC_CONFIG_FILES([Makefile]) | ||
52 | AC_OUTPUT | ||
53 | -- | ||
54 | 1.8.5.4 | ||
55 | |||
diff --git a/meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb b/meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb index 16a72ee8e..baa92e4bb 100644 --- a/meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb +++ b/meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb | |||
@@ -8,8 +8,14 @@ LICENSE = "GPLv2" | |||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" |
9 | 9 | ||
10 | SRC_URI = "http://xdelta.googlecode.com/files/${BPN}-${PV}.tar.xz \ | 10 | SRC_URI = "http://xdelta.googlecode.com/files/${BPN}-${PV}.tar.xz \ |
11 | file://compilation-fix.patch" | 11 | file://compilation-fix.patch \ |
12 | file://with-liblzma-configure-option.patch \ | ||
13 | " | ||
12 | SRC_URI[md5sum] = "c3ae3286ce4193de8e03d5bcaccf3bc3" | 14 | SRC_URI[md5sum] = "c3ae3286ce4193de8e03d5bcaccf3bc3" |
13 | SRC_URI[sha256sum] = "3a86f29c95664fb44b8a40ff22d9bcc3e87aa8c01f0ff75931a7fa78ed3d2e55" | 15 | SRC_URI[sha256sum] = "3a86f29c95664fb44b8a40ff22d9bcc3e87aa8c01f0ff75931a7fa78ed3d2e55" |
14 | 16 | ||
15 | inherit autotools | 17 | inherit autotools |
18 | |||
19 | # Optional secondary compression | ||
20 | PACKAGECONFIG ??= "" | ||
21 | PACKAGECONFIG[lzma] = "--with-liblzma,--without-liblzma,xz" | ||