summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/xdelta
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/xdelta
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/xdelta')
-rw-r--r--meta-oe/recipes-support/xdelta/files/compilation-fix.patch29
-rw-r--r--meta-oe/recipes-support/xdelta/files/with-liblzma-configure-option.patch55
-rw-r--r--meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb21
3 files changed, 105 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/xdelta/files/compilation-fix.patch b/meta-oe/recipes-support/xdelta/files/compilation-fix.patch
new file mode 100644
index 000000000..377a0436d
--- /dev/null
+++ b/meta-oe/recipes-support/xdelta/files/compilation-fix.patch
@@ -0,0 +1,29 @@
1Upstream-Status: Pending
2http://code.google.com/p/xdelta/issues/detail?id=174
3
4Compilation fix:
5<code>
6| testing/regtest.cc:763:3: error: no matching function for call to 'max(xoff_t, size_t&)'
7</code>
8
9Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com>
10---
11 testing/regtest.cc | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/testing/regtest.cc b/testing/regtest.cc
15index 12b712e..b63a1f9 100644
16--- a/testing/regtest.cc
17+++ b/testing/regtest.cc
18@@ -12,7 +12,7 @@ public:
19 Options() : encode_srcwin_maxsz(1<<20),
20 block_size(Constants::BLOCK_SIZE),
21 size_known(false) { }
22- size_t encode_srcwin_maxsz;
23+ xoff_t encode_srcwin_maxsz;
24 size_t block_size;
25 bool size_known;
26 };
27--
281.8.5.4
29
diff --git a/meta-oe/recipes-support/xdelta/files/with-liblzma-configure-option.patch b/meta-oe/recipes-support/xdelta/files/with-liblzma-configure-option.patch
new file mode 100644
index 000000000..4b99290d2
--- /dev/null
+++ b/meta-oe/recipes-support/xdelta/files/with-liblzma-configure-option.patch
@@ -0,0 +1,55 @@
1Upstream-Status: Pending, Submitted
2http://code.google.com/p/xdelta/issues/detail?id=178
3
4xdelta3: add --with-liblzma configure option
5
6As xdelta3 can be compiled with or without liblzma external library, make it configurable.
7Default is autodetect (unchanged behavior).
8
9Signed-off-by: Matthieu Crapet <mcrapet@gmail.com>
10---
11 configure.ac | 21 +++++++++++++++++++--
12 1 file changed, 19 insertions(+), 2 deletions(-)
13
14diff --git a/configure.ac b/configure.ac
15index 3b430d7..8c53ba8 100644
16--- a/configure.ac
17+++ b/configure.ac
18@@ -8,8 +8,6 @@ AM_INIT_AUTOMAKE([1.9 no-define foreign tar-ustar])
19 AX_CHECK_ALIGNED_ACCESS_REQUIRED
20 AC_PROG_CC
21 AC_PROG_CXX
22-AC_CHECK_HEADERS([lzma.h])
23-AC_CHECK_LIB(lzma, lzma_easy_buffer_encode)
24 AC_CHECK_SIZEOF(size_t)
25 #AM_PATH_PYTHON(,, [:])
26 #AM_CONDITIONAL([HAVE_PYTHON], [test "$PYTHON" != :])
27@@ -22,6 +20,25 @@ AC_ARG_ENABLE(debug-symbols,
28 AS_HELP_STRING(--enable-debug-symbols,[Build with debug symbols (default is NO)]),,enableval=no)
29 AM_CONDITIONAL([DEBUG_SYMBOLS], [test ${enableval} = "yes"])
30
31+AC_ARG_WITH(
32+ [liblzma],
33+ [AC_HELP_STRING(
34+ [--with-liblzma],
35+ [build with liblzma support @<:@default=autodetect@:>@])],
36+ [USE_LIBLZMA=$withval],
37+ [USE_LIBLZMA=auto])
38+
39+if test "x$USE_LIBLZMA" != xno ; then
40+ AC_CHECK_HEADERS([lzma.h],,[
41+ if test "x$with_liblzma" = xyes ; then
42+ AC_MSG_FAILURE([liblzma includes was not found])
43+ fi])
44+ AC_CHECK_LIB([lzma], [lzma_easy_buffer_encode],,[
45+ if test "x$with_liblzma" = xyes ; then
46+ AC_MSG_FAILURE([liblzma library was not found])
47+ fi])
48+fi
49+
50 AC_CONFIG_HEADERS([config.h])
51 AC_CONFIG_FILES([Makefile])
52 AC_OUTPUT
53--
541.8.5.4
55
diff --git a/meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb b/meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb
new file mode 100644
index 000000000..baa92e4bb
--- /dev/null
+++ b/meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Xdelta is a tool for differential compression"
2DESCRIPTION = "Open-source binary diff, differential compression tools, \
3 VCDIFF (RFC 3284) delta compression."
4HOMEPAGE = "http://xdelta.org/"
5SECTION = "console/utils"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
9
10SRC_URI = "http://xdelta.googlecode.com/files/${BPN}-${PV}.tar.xz \
11 file://compilation-fix.patch \
12 file://with-liblzma-configure-option.patch \
13"
14SRC_URI[md5sum] = "c3ae3286ce4193de8e03d5bcaccf3bc3"
15SRC_URI[sha256sum] = "3a86f29c95664fb44b8a40ff22d9bcc3e87aa8c01f0ff75931a7fa78ed3d2e55"
16
17inherit autotools
18
19# Optional secondary compression
20PACKAGECONFIG ??= ""
21PACKAGECONFIG[lzma] = "--with-liblzma,--without-liblzma,xz"