summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/xchat
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/xchat
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/xchat')
-rw-r--r--meta-oe/recipes-support/xchat/xchat-2.8.8/automake-foreign.patch11
-rw-r--r--meta-oe/recipes-support/xchat/xchat-2.8.8/fix-includes-for-separate-build.patch78
-rw-r--r--meta-oe/recipes-support/xchat/xchat-2.8.8/glib-2.32.patch44
-rw-r--r--meta-oe/recipes-support/xchat/xchat_2.8.8.bb37
4 files changed, 170 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/xchat/xchat-2.8.8/automake-foreign.patch b/meta-oe/recipes-support/xchat/xchat-2.8.8/automake-foreign.patch
new file mode 100644
index 000000000..cfa2f6c7f
--- /dev/null
+++ b/meta-oe/recipes-support/xchat/xchat-2.8.8/automake-foreign.patch
@@ -0,0 +1,11 @@
1--- a/configure.in 2014-08-18 01:25:43.911597023 -0700
2+++ b/configure.in 2014-08-18 01:26:27.763786629 -0700
3@@ -8,7 +8,7 @@
4 AC_CONFIG_HEADERS([config.h])
5 AC_CONFIG_SRCDIR([configure.in])
6
7-AM_INIT_AUTOMAKE([1.9 dist-bzip2 subdir-objects no-define])
8+AM_INIT_AUTOMAKE([1.9 foreign dist-bzip2 subdir-objects no-define])
9
10 AM_MAINTAINER_MODE
11 AC_PROG_CC
diff --git a/meta-oe/recipes-support/xchat/xchat-2.8.8/fix-includes-for-separate-build.patch b/meta-oe/recipes-support/xchat/xchat-2.8.8/fix-includes-for-separate-build.patch
new file mode 100644
index 000000000..4394e5257
--- /dev/null
+++ b/meta-oe/recipes-support/xchat/xchat-2.8.8/fix-includes-for-separate-build.patch
@@ -0,0 +1,78 @@
1diff -ur xchat-2.8.8-orig/plugins/perl/perl.c xchat-2.8.8/plugins/perl/perl.c
2--- xchat-2.8.8-orig/plugins/perl/perl.c 2014-08-30 14:09:05.125116286 -0700
3+++ xchat-2.8.8/plugins/perl/perl.c 2014-08-30 14:09:45.281106532 -0700
4@@ -31,7 +31,7 @@
5 #endif
6
7 #undef PACKAGE
8-#include "../../config.h" /* for #define OLD_PERL */
9+#include <config.h> /* for #define OLD_PERL */
10 #include "xchat-plugin.h"
11
12 static xchat_plugin *ph; /* plugin handle */
13diff -ur xchat-2.8.8-orig/src/common/network.c xchat-2.8.8/src/common/network.c
14--- xchat-2.8.8-orig/src/common/network.c 2014-08-30 14:09:05.137116222 -0700
15+++ xchat-2.8.8/src/common/network.c 2014-08-30 14:13:52.729116323 -0700
16@@ -24,7 +24,7 @@
17 #include <unistd.h>
18 #include <glib.h>
19
20-#include "../../config.h" /* grab USE_IPV6 and LOOKUPD defines */
21+#include <config.h> /* grab USE_IPV6 and LOOKUPD defines */
22
23 #define WANTSOCKET
24 #define WANTARPA
25diff -ur xchat-2.8.8-orig/src/common/ssl.c xchat-2.8.8/src/common/ssl.c
26--- xchat-2.8.8-orig/src/common/ssl.c 2014-08-30 14:09:05.137116222 -0700
27+++ xchat-2.8.8/src/common/ssl.c 2014-08-30 14:14:08.449133899 -0700
28@@ -23,7 +23,7 @@
29 #include <string.h> /* strncpy() */
30 #include "ssl.h" /* struct cert_info */
31 #include "inet.h"
32-#include "../../config.h" /* HAVE_SNPRINTF */
33+#include <config.h> /* HAVE_SNPRINTF */
34
35 #ifndef HAVE_SNPRINTF
36 #define snprintf g_snprintf
37diff -ur xchat-2.8.8-orig/src/common/util.c xchat-2.8.8/src/common/util.c
38--- xchat-2.8.8-orig/src/common/util.c 2014-08-30 14:09:05.133116243 -0700
39+++ xchat-2.8.8/src/common/util.c 2014-08-30 14:10:23.633116070 -0700
40@@ -41,7 +41,7 @@
41 #include "xchatc.h"
42 #include <ctype.h>
43 #include "util.h"
44-#include "../../config.h"
45+#include <config.h>
46
47 #define WANTSOCKET
48 #include "inet.h"
49diff -ur xchat-2.8.8-orig/src/common/xchat.h xchat-2.8.8/src/common/xchat.h
50--- xchat-2.8.8-orig/src/common/xchat.h 2014-08-30 14:09:05.133116243 -0700
51+++ xchat-2.8.8/src/common/xchat.h 2014-08-30 14:13:42.797116472 -0700
52@@ -1,4 +1,4 @@
53-#include "../../config.h"
54+#include <config.h>
55
56 #include <glib.h>
57 #include <time.h> /* need time_t */
58diff -ur xchat-2.8.8-orig/src/fe-gtk/fe-gtk.h xchat-2.8.8/src/fe-gtk/fe-gtk.h
59--- xchat-2.8.8-orig/src/fe-gtk/fe-gtk.h 2014-08-30 14:09:05.129116272 -0700
60+++ xchat-2.8.8/src/fe-gtk/fe-gtk.h 2014-08-30 14:10:13.309115951 -0700
61@@ -1,4 +1,4 @@
62-#include "../../config.h"
63+#include <config.h>
64
65 #ifdef WIN32
66 /* If you're compiling this for Windows, your release is un-official
67diff -ur xchat-2.8.8-orig/src/fe-gtk/xtext.c xchat-2.8.8/src/fe-gtk/xtext.c
68--- xchat-2.8.8-orig/src/fe-gtk/xtext.c 2014-08-30 14:09:05.129116272 -0700
69+++ xchat-2.8.8/src/fe-gtk/xtext.c 2014-08-30 14:10:00.313138254 -0700
70@@ -51,7 +51,7 @@
71 #include <gtk/gtkwindow.h>
72
73 #ifdef XCHAT
74-#include "../../config.h" /* can define USE_XLIB here */
75+#include <config.h> /* can define USE_XLIB here */
76 #else
77 #define USE_XLIB
78 #endif
diff --git a/meta-oe/recipes-support/xchat/xchat-2.8.8/glib-2.32.patch b/meta-oe/recipes-support/xchat/xchat-2.8.8/glib-2.32.patch
new file mode 100644
index 000000000..c9bce6a9c
--- /dev/null
+++ b/meta-oe/recipes-support/xchat/xchat-2.8.8/glib-2.32.patch
@@ -0,0 +1,44 @@
1--- xchat-2.8.8.orig/src/common/xchat.h 2009-08-16 11:40:16.000000000 +0200
2+++ xchat-2.8.8/src/common/xchat.h 2012-05-06 08:30:16.125755497 +0200
3@@ -1,10 +1,6 @@
4 #include "../../config.h"
5
6-#include <glib/gslist.h>
7-#include <glib/glist.h>
8-#include <glib/gutils.h>
9-#include <glib/giochannel.h>
10-#include <glib/gstrfuncs.h>
11+#include <glib.h>
12 #include <time.h> /* need time_t */
13
14 #ifndef XCHAT_H
15--- xchat-2.8.8.orig/src/common/servlist.c 2010-05-16 09:24:26.000000000 +0200
16+++ xchat-2.8.8/src/common/servlist.c 2012-05-06 08:30:45.681758019 +0200
17@@ -24,7 +24,6 @@
18 #include <unistd.h>
19
20 #include "xchat.h"
21-#include <glib/ghash.h>
22
23 #include "cfgfiles.h"
24 #include "fe.h"
25--- xchat-2.8.8.orig/src/common/util.c 2009-08-16 11:40:16.000000000 +0200
26+++ xchat-2.8.8/src/common/util.c 2012-05-06 08:31:10.389760122 +0200
27@@ -39,7 +39,6 @@
28 #include <errno.h>
29 #include "xchat.h"
30 #include "xchatc.h"
31-#include <glib/gmarkup.h>
32 #include <ctype.h>
33 #include "util.h"
34 #include "../../config.h"
35--- xchat-2.8.8.orig/src/common/text.c 2010-05-30 04:14:41.000000000 +0200
36+++ xchat-2.8.8/src/common/text.c 2012-05-06 08:31:22.300761137 +0200
37@@ -28,7 +28,6 @@
38 #include <sys/mman.h>
39
40 #include "xchat.h"
41-#include <glib/ghash.h>
42 #include "cfgfiles.h"
43 #include "chanopt.h"
44 #include "plugin.h"
diff --git a/meta-oe/recipes-support/xchat/xchat_2.8.8.bb b/meta-oe/recipes-support/xchat/xchat_2.8.8.bb
new file mode 100644
index 000000000..6da11cd94
--- /dev/null
+++ b/meta-oe/recipes-support/xchat/xchat_2.8.8.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Full-featured IRC chat client with scripting support"
2LICENSE = "GPLv2+"
3HOMEPAGE = "http://www.xchat.org"
4SECTION = "x11/network"
5
6DEPENDS = "libgcrypt zlib gtk+ libsexy"
7DEPENDS += "gdk-pixbuf-native"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
10
11PR = "r2"
12
13SRC_URI = "http://xchat.org/files/source/2.8/xchat-${PV}.tar.bz2 \
14 file://glib-2.32.patch \
15 file://automake-foreign.patch \
16 file://fix-includes-for-separate-build.patch \
17"
18
19inherit autotools gettext pkgconfig
20
21PACKAGECONFIG ??= "dbus"
22PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus-glib"
23PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
24PACKAGECONFIG[python] = "--enable-python,--disable-python,python"
25
26EXTRA_OECONF = "\
27 --enable-maintainer-mode \
28 --disable-perl \
29 --disable-tcl \
30"
31
32RDEPENDS_${PN} += "dbus"
33FILES_${PN} += "${datadir}/dbus-1"
34FILES_${PN}-dbg += "${libdir}/xchat/plugins/.debug"
35
36SRC_URI[md5sum] = "6775c44f38e84d06c06c336b32c4a452"
37SRC_URI[sha256sum] = "0d6d69437b5e1e45f3e66270fe369344943de8a1190e498fafa5296315a27db0"