diff options
author | Paul Barker <paul@paulbarker.me.uk> | 2013-09-13 20:08:22 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-09-19 13:56:28 +0200 |
commit | 7be78a939bde5228a7f92a58ac08dd10901a8a4f (patch) | |
tree | 6c728c4f6f4c4c47e61f7f820c860da9f7e86fb8 /meta-oe/recipes-support/vim | |
parent | 3000970fcd979ac2d68ef406778dbc4da86da73f (diff) | |
download | meta-openembedded-7be78a939bde5228a7f92a58ac08dd10901a8a4f.tar.gz |
vim: upgrade to v7.4.27 and refactor
'vim.inc' is merged into the new recipe 'vim_7.4.27.bb', the recipe is slightly
reorganised and a minor omission in the comments is corrected.
DESCRIPTION is replaced with SUMMARY. PR and INC_PR values are dropped. The
variable PV_MAJOR is also dropped as it isn't used.
LIC_FILES_CHECKSUM is updated as an address and version number given in the
license have been modified. The main license text itself is unchanged.
The setting of PARALLEL_MAKE to force single-threaded compilation is removed as
there is no justification in the git history for this being needed and the
compilation completes fine without it.
Signed-off-by: Paul Barker <paul@paulbarker.me.uk>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/vim')
-rw-r--r-- | meta-oe/recipes-support/vim/vim_7.3.1314.bb | 7 | ||||
-rw-r--r-- | meta-oe/recipes-support/vim/vim_7.4.27.bb (renamed from meta-oe/recipes-support/vim/vim.inc) | 19 |
2 files changed, 8 insertions, 18 deletions
diff --git a/meta-oe/recipes-support/vim/vim_7.3.1314.bb b/meta-oe/recipes-support/vim/vim_7.3.1314.bb deleted file mode 100644 index 1be5a9102..000000000 --- a/meta-oe/recipes-support/vim/vim_7.3.1314.bb +++ /dev/null | |||
@@ -1,7 +0,0 @@ | |||
1 | require ${PN}.inc | ||
2 | |||
3 | PR = "${INC_PR}.0" | ||
4 | |||
5 | SRCREV = "v7-3-1314" | ||
6 | |||
7 | SRC_URI += "file://configure.in_remove_CC_quotes.patch;patchdir=.." | ||
diff --git a/meta-oe/recipes-support/vim/vim.inc b/meta-oe/recipes-support/vim/vim_7.4.27.bb index 991ba74f1..77507d4c5 100644 --- a/meta-oe/recipes-support/vim/vim.inc +++ b/meta-oe/recipes-support/vim/vim_7.4.27.bb | |||
@@ -1,20 +1,19 @@ | |||
1 | DESCRIPTION = "Vi IMproved - enhanced vi editor" | 1 | SUMMARY = "Vi IMproved - enhanced vi editor" |
2 | SECTION = "console/utils" | 2 | SECTION = "console/utils" |
3 | DEPENDS = "ncurses" | 3 | DEPENDS = "ncurses" |
4 | # vimdiff doesn't like busybox diff | 4 | # vimdiff doesn't like busybox diff |
5 | RSUGGESTS_${PN} = "diffutils" | 5 | RSUGGESTS_${PN} = "diffutils" |
6 | LICENSE = "vim" | 6 | LICENSE = "vim" |
7 | LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=4c91d841bb7b75f68b5bb8ad7118f5b8" | 7 | LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=b779e18be6ed77facc770691c967b8f8" |
8 | 8 | ||
9 | PV_MAJOR = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" | 9 | SRC_URI = "hg://vim.googlecode.com/hg/;protocol=https;module=vim \ |
10 | VIMDIR = "${PN}${@d.getVar('PV',1).split('.')[0]}${@d.getVar('PV',1).split('.')[1]}" | 10 | file://configure.in_remove_CC_quotes.patch;patchdir=.." |
11 | 11 | SRCREV = "v7-4-027" | |
12 | INC_PR = "r13" | ||
13 | |||
14 | SRC_URI = "hg://vim.googlecode.com/hg/;protocol=https;module=vim" | ||
15 | 12 | ||
16 | S = "${WORKDIR}/${PN}/src" | 13 | S = "${WORKDIR}/${PN}/src" |
17 | 14 | ||
15 | VIMDIR = "${PN}${@d.getVar('PV',1).split('.')[0]}${@d.getVar('PV',1).split('.')[1]}" | ||
16 | |||
18 | inherit autotools update-alternatives | 17 | inherit autotools update-alternatives |
19 | 18 | ||
20 | # vim configure.in contains functions which got 'dropped' by autotools.bbclass | 19 | # vim configure.in contains functions which got 'dropped' by autotools.bbclass |
@@ -28,7 +27,7 @@ do_configure () { | |||
28 | touch auto/config.mk auto/config.h | 27 | touch auto/config.mk auto/config.h |
29 | } | 28 | } |
30 | 29 | ||
31 | #Available PACKAGECONFIG options are gtkgui, x11, tiny | 30 | #Available PACKAGECONFIG options are gtkgui, acl, x11, tiny |
32 | PACKAGECONFIG ??= "" | 31 | PACKAGECONFIG ??= "" |
33 | 32 | ||
34 | PACKAGECONFIG[gtkgui] = "--enable-gtk2-test --enable-gui=gtk2,--enable-gui=no,gtk+," | 33 | PACKAGECONFIG[gtkgui] = "--enable-gtk2-test --enable-gui=gtk2,--enable-gui=no,gtk+," |
@@ -76,5 +75,3 @@ ALTERNATIVE_${PN} = "vi" | |||
76 | ALTERNATIVE_TARGET[vi] = "${bindir}/${PN}" | 75 | ALTERNATIVE_TARGET[vi] = "${bindir}/${PN}" |
77 | ALTERNATIVE_LINK_NAME[vi] = "${base_bindir}/vi" | 76 | ALTERNATIVE_LINK_NAME[vi] = "${base_bindir}/vi" |
78 | ALTERNATIVE_PRIORITY[vi] = "100" | 77 | ALTERNATIVE_PRIORITY[vi] = "100" |
79 | |||
80 | PARALLEL_MAKE = "" | ||