summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/vim
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/vim
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/vim')
-rw-r--r--meta-oe/recipes-support/vim/files/disable_acl_header_check.patch27
-rw-r--r--meta-oe/recipes-support/vim/files/vim-add-knob-whether-elf.h-are-checked.patch38
-rw-r--r--meta-oe/recipes-support/vim/vim_7.4.481.bb103
3 files changed, 168 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch b/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch
new file mode 100644
index 000000000..8f824e78b
--- /dev/null
+++ b/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch
@@ -0,0 +1,27 @@
1Upstream-Status: pending
2
3Don't check 'sys/acl.h' if acl support disabled for vim/vim-tiny.
4
5Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
6================================================
7diff --git a/src/configure.in b/src/configure.in
8index fb965e5..d734064 100644
9--- a/src/configure.in
10+++ b/src/configure.in
11@@ -2511,7 +2511,7 @@ AC_CHECK_HEADERS(stdarg.h stdint.h stdlib.h string.h \
12 sys/systeminfo.h locale.h sys/stream.h termios.h \
13 libc.h sys/statfs.h poll.h sys/poll.h pwd.h \
14 utime.h sys/param.h libintl.h libgen.h \
15- util/debug.h util/msg18n.h frame.h sys/acl.h \
16+ util/debug.h util/msg18n.h frame.h \
17 sys/access.h sys/sysinfo.h wchar.h wctype.h)
18
19 dnl sys/ptem.h depends on sys/stream.h on Solaris
20@@ -3112,6 +3112,7 @@ AC_ARG_ENABLE(acl,
21 , [enable_acl="yes"])
22 if test "$enable_acl" = "yes"; then
23 AC_MSG_RESULT(no)
24+AC_CHECK_HEADERS(sys/acl.h)
25 AC_CHECK_LIB(posix1e, acl_get_file, [LIBS="$LIBS -lposix1e"],
26 AC_CHECK_LIB(acl, acl_get_file, [LIBS="$LIBS -lacl"
27 AC_CHECK_LIB(attr, fgetxattr, LIBS="$LIBS -lattr",,)],,),)
diff --git a/meta-oe/recipes-support/vim/files/vim-add-knob-whether-elf.h-are-checked.patch b/meta-oe/recipes-support/vim/files/vim-add-knob-whether-elf.h-are-checked.patch
new file mode 100644
index 000000000..693d130e4
--- /dev/null
+++ b/meta-oe/recipes-support/vim/files/vim-add-knob-whether-elf.h-are-checked.patch
@@ -0,0 +1,38 @@
1vim: add knob whether elf.h are checked
2
3Previously, it still was checked when there was no elf library in sysroots directory.
4Add knob to decide whether elf.h are checked or not.
5
6Upstream-status: Pending
7
8Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
9---
10 src/configure.in | 7 +++++++
11 1 file changed, 7 insertions(+)
12
13diff --git a/src/configure.in b/src/configure.in
14index d734064..f504fa6 100644
15--- a/src/configure.in
16+++ b/src/configure.in
17@@ -2483,11 +2483,18 @@ AC_TRY_COMPILE([#include <stdio.h>], [int x __attribute__((unused));],
18 AC_MSG_RESULT(no))
19
20 dnl Checks for header files.
21+AC_MSG_CHECKING(whether or not to look for elf.h)
22+AC_ARG_ENABLE(elf-check,
23+ [ --enable-elf-check If elfutils, check for elf.h [default=no]],
24+ , enable_elf_check="no")
25+AC_MSG_RESULT($enable_elf_check)
26+if test "x$enable_elf_check" != "xno"; then
27 AC_CHECK_HEADER(elf.h, HAS_ELF=1)
28 dnl AC_CHECK_HEADER(dwarf.h, SVR4=1)
29 if test "$HAS_ELF" = 1; then
30 AC_CHECK_LIB(elf, main)
31 fi
32+fi
33
34 AC_HEADER_DIRENT
35
36--
371.7.9.5
38
diff --git a/meta-oe/recipes-support/vim/vim_7.4.481.bb b/meta-oe/recipes-support/vim/vim_7.4.481.bb
new file mode 100644
index 000000000..b85ff63d5
--- /dev/null
+++ b/meta-oe/recipes-support/vim/vim_7.4.481.bb
@@ -0,0 +1,103 @@
1SUMMARY = "Vi IMproved - enhanced vi editor"
2SECTION = "console/utils"
3DEPENDS = "ncurses gettext-native"
4# vimdiff doesn't like busybox diff
5RSUGGESTS_${PN} = "diffutils"
6LICENSE = "vim"
7LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=b779e18be6ed77facc770691c967b8f8"
8
9SRC_URI = "hg://vim.googlecode.com/hg/;protocol=https;module=vim \
10 file://disable_acl_header_check.patch;patchdir=.. \
11 file://vim-add-knob-whether-elf.h-are-checked.patch;patchdir=.. \
12"
13SRCREV = "v7-4-481"
14
15S = "${WORKDIR}/${BPN}/src"
16
17VIMDIR = "${BPN}${@d.getVar('PV',1).split('.')[0]}${@d.getVar('PV',1).split('.')[1]}"
18
19inherit autotools update-alternatives
20inherit autotools-brokensep
21
22# vim configure.in contains functions which got 'dropped' by autotools.bbclass
23do_configure () {
24 rm -f auto/*
25 touch auto/config.mk
26 aclocal
27 autoconf
28 oe_runconf
29 touch auto/configure
30 touch auto/config.mk auto/config.h
31}
32
33#Available PACKAGECONFIG options are gtkgui, acl, x11, tiny
34PACKAGECONFIG ??= ""
35PACKAGECONFIG += "${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
36PACKAGECONFIG += "${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
37
38PACKAGECONFIG[gtkgui] = "--enable-gtk2-test --enable-gui=gtk2,--enable-gui=no,gtk+,"
39PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
40PACKAGECONFIG[x11] = "--with-x,--without-x,xt,"
41PACKAGECONFIG[tiny] = "--with-features=tiny,--with-features=big,,"
42PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,"
43PACKAGECONFIG[elfutils] = "--enable-elf-check,,elfutils,"
44
45EXTRA_OECONF = " \
46 --disable-gpm \
47 --disable-gtktest \
48 --disable-xim \
49 --disable-netbeans \
50 --with-tlib=ncurses \
51 ac_cv_small_wchar_t=no \
52 vim_cv_getcwd_broken=no \
53 vim_cv_memmove_handles_overlap=yes \
54 vim_cv_stat_ignores_slash=no \
55 vim_cv_terminfo=yes \
56 vim_cv_tgent=non-zero \
57 vim_cv_toupper_broken=no \
58 vim_cv_tty_group=world \
59 STRIP=/bin/true \
60"
61
62do_install_append() {
63 # Work around rpm picking up csh or awk or perl as a dep
64 chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/vim132
65 chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/mve.awk
66 chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/*.pl
67
68 # Install example vimrc from runtime files
69 install -m 0644 ../runtime/vimrc_example.vim ${D}/${datadir}/${BPN}/vimrc
70}
71
72PARALLEL_MAKEINST = ""
73
74PACKAGES =+ "${PN}-common ${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc"
75FILES_${PN}-syntax = "${datadir}/${BPN}/${VIMDIR}/syntax"
76FILES_${PN}-help = "${datadir}/${BPN}/${VIMDIR}/doc"
77FILES_${PN}-tutor = "${datadir}/${BPN}/${VIMDIR}/tutor ${bindir}/${BPN}tutor"
78FILES_${PN}-vimrc = "${datadir}/${BPN}/vimrc"
79FILES_${PN}-data = "${datadir}/${BPN}"
80FILES_${PN}-common = " \
81 ${datadir}/${BPN}/${VIMDIR}/*.vim \
82 ${datadir}/${BPN}/${VIMDIR}/autoload \
83 ${datadir}/${BPN}/${VIMDIR}/colors \
84 ${datadir}/${BPN}/${VIMDIR}/compiler \
85 ${datadir}/${BPN}/${VIMDIR}/ftplugin \
86 ${datadir}/${BPN}/${VIMDIR}/indent \
87 ${datadir}/${BPN}/${VIMDIR}/keymap \
88 ${datadir}/${BPN}/${VIMDIR}/lang \
89 ${datadir}/${BPN}/${VIMDIR}/macros \
90 ${datadir}/${BPN}/${VIMDIR}/plugin \
91 ${datadir}/${BPN}/${VIMDIR}/print \
92 ${datadir}/${BPN}/${VIMDIR}/spell \
93 ${datadir}/${BPN}/${VIMDIR}/tools \
94"
95
96RDEPENDS_${PN} = "ncurses-terminfo-base"
97# Recommend that runtime data is installed along with vim
98RRECOMMENDS_${PN} = "${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-common"
99
100ALTERNATIVE_${PN} = "vi"
101ALTERNATIVE_TARGET[vi] = "${bindir}/${BPN}"
102ALTERNATIVE_LINK_NAME[vi] = "${base_bindir}/vi"
103ALTERNATIVE_PRIORITY[vi] = "100"