summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/vim/files
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/vim/files
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/vim/files')
-rw-r--r--meta-oe/recipes-support/vim/files/disable_acl_header_check.patch27
-rw-r--r--meta-oe/recipes-support/vim/files/vim-add-knob-whether-elf.h-are-checked.patch38
2 files changed, 65 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch b/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch
new file mode 100644
index 000000000..8f824e78b
--- /dev/null
+++ b/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch
@@ -0,0 +1,27 @@
1Upstream-Status: pending
2
3Don't check 'sys/acl.h' if acl support disabled for vim/vim-tiny.
4
5Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
6================================================
7diff --git a/src/configure.in b/src/configure.in
8index fb965e5..d734064 100644
9--- a/src/configure.in
10+++ b/src/configure.in
11@@ -2511,7 +2511,7 @@ AC_CHECK_HEADERS(stdarg.h stdint.h stdlib.h string.h \
12 sys/systeminfo.h locale.h sys/stream.h termios.h \
13 libc.h sys/statfs.h poll.h sys/poll.h pwd.h \
14 utime.h sys/param.h libintl.h libgen.h \
15- util/debug.h util/msg18n.h frame.h sys/acl.h \
16+ util/debug.h util/msg18n.h frame.h \
17 sys/access.h sys/sysinfo.h wchar.h wctype.h)
18
19 dnl sys/ptem.h depends on sys/stream.h on Solaris
20@@ -3112,6 +3112,7 @@ AC_ARG_ENABLE(acl,
21 , [enable_acl="yes"])
22 if test "$enable_acl" = "yes"; then
23 AC_MSG_RESULT(no)
24+AC_CHECK_HEADERS(sys/acl.h)
25 AC_CHECK_LIB(posix1e, acl_get_file, [LIBS="$LIBS -lposix1e"],
26 AC_CHECK_LIB(acl, acl_get_file, [LIBS="$LIBS -lacl"
27 AC_CHECK_LIB(attr, fgetxattr, LIBS="$LIBS -lattr",,)],,),)
diff --git a/meta-oe/recipes-support/vim/files/vim-add-knob-whether-elf.h-are-checked.patch b/meta-oe/recipes-support/vim/files/vim-add-knob-whether-elf.h-are-checked.patch
new file mode 100644
index 000000000..693d130e4
--- /dev/null
+++ b/meta-oe/recipes-support/vim/files/vim-add-knob-whether-elf.h-are-checked.patch
@@ -0,0 +1,38 @@
1vim: add knob whether elf.h are checked
2
3Previously, it still was checked when there was no elf library in sysroots directory.
4Add knob to decide whether elf.h are checked or not.
5
6Upstream-status: Pending
7
8Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
9---
10 src/configure.in | 7 +++++++
11 1 file changed, 7 insertions(+)
12
13diff --git a/src/configure.in b/src/configure.in
14index d734064..f504fa6 100644
15--- a/src/configure.in
16+++ b/src/configure.in
17@@ -2483,11 +2483,18 @@ AC_TRY_COMPILE([#include <stdio.h>], [int x __attribute__((unused));],
18 AC_MSG_RESULT(no))
19
20 dnl Checks for header files.
21+AC_MSG_CHECKING(whether or not to look for elf.h)
22+AC_ARG_ENABLE(elf-check,
23+ [ --enable-elf-check If elfutils, check for elf.h [default=no]],
24+ , enable_elf_check="no")
25+AC_MSG_RESULT($enable_elf_check)
26+if test "x$enable_elf_check" != "xno"; then
27 AC_CHECK_HEADER(elf.h, HAS_ELF=1)
28 dnl AC_CHECK_HEADER(dwarf.h, SVR4=1)
29 if test "$HAS_ELF" = 1; then
30 AC_CHECK_LIB(elf, main)
31 fi
32+fi
33
34 AC_HEADER_DIRENT
35
36--
371.7.9.5
38