diff options
author | Khem Raj <raj.khem@gmail.com> | 2018-09-05 23:03:49 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-09-08 13:32:12 -0700 |
commit | 791a1c612f4bf36c6154e31cc80de868ff7e2c27 (patch) | |
tree | 9fdc69a5a127cc995ff659a57f05eb1411f4dfb0 /meta-oe/recipes-support/vboxguestdrivers | |
parent | 19246b82df1981ec82da8cac25e6dc148be3a85a (diff) | |
download | meta-openembedded-791a1c612f4bf36c6154e31cc80de868ff7e2c27.tar.gz |
vboxguestdrivers: Update to 5.2.18
* Fix build with 4.18 kernel
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/vboxguestdrivers')
-rw-r--r-- | meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers/kernel-4.18.patch | 33 | ||||
-rw-r--r-- | meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_5.2.18.bb (renamed from meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_5.2.8.bb) | 6 |
2 files changed, 36 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers/kernel-4.18.patch b/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers/kernel-4.18.patch new file mode 100644 index 000000000..93eaa3d6c --- /dev/null +++ b/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers/kernel-4.18.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | Description: Fix build failure with new kernel 4.18 | ||
2 | Author: Gianfranco Costamagna <locutusofborg@debian.org> | ||
3 | |||
4 | Upstream-Status:Pending | ||
5 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
6 | Index: vbox_module/vboxsf/utils.c | ||
7 | =================================================================== | ||
8 | --- vbox_module.orig/vboxsf/utils.c | ||
9 | +++ vbox_module/vboxsf/utils.c | ||
10 | @@ -50,7 +50,11 @@ static void sf_timespec_from_ftime(RTTIM | ||
11 | RTTimeSpecSetNano(ts, t); | ||
12 | } | ||
13 | #else /* >= 2.6.0 */ | ||
14 | +#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 18, 0) | ||
15 | static void sf_ftime_from_timespec(struct timespec *tv, RTTIMESPEC *ts) | ||
16 | +#else | ||
17 | +static void sf_ftime_from_timespec(struct timespec64 *tv, RTTIMESPEC *ts) | ||
18 | +#endif | ||
19 | { | ||
20 | int64_t t = RTTimeSpecGetNano(ts); | ||
21 | int64_t nsec; | ||
22 | @@ -60,7 +64,11 @@ static void sf_ftime_from_timespec(struc | ||
23 | tv->tv_nsec = nsec; | ||
24 | } | ||
25 | |||
26 | +#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 18, 0) | ||
27 | static void sf_timespec_from_ftime(RTTIMESPEC *ts, struct timespec *tv) | ||
28 | +#else | ||
29 | +static void sf_timespec_from_ftime(RTTIMESPEC *ts, struct timespec64 *tv) | ||
30 | +#endif | ||
31 | { | ||
32 | int64_t t = (int64_t)tv->tv_nsec + (int64_t)tv->tv_sec * 1000000000; | ||
33 | RTTimeSpecSetNano(ts, t); | ||
diff --git a/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_5.2.8.bb b/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_5.2.18.bb index e00db4d7e..2a4cc387f 100644 --- a/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_5.2.8.bb +++ b/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_5.2.18.bb | |||
@@ -13,10 +13,10 @@ VBOX_NAME = "VirtualBox-${PV}" | |||
13 | 13 | ||
14 | SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/${VBOX_NAME}.tar.bz2 \ | 14 | SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/${VBOX_NAME}.tar.bz2 \ |
15 | file://Makefile.utils \ | 15 | file://Makefile.utils \ |
16 | file://kernel-4.18.patch \ | ||
16 | " | 17 | " |
17 | 18 | SRC_URI[md5sum] = "d8e291525b84569356773eef507c49ce" | |
18 | SRC_URI[md5sum] = "e731ea9c5c31096ec4c2a3bfba26665c" | 19 | SRC_URI[sha256sum] = "ed0a7efd56c7f39fae79c7ec3321473da412ef0d7914457b66f42679d513efcf" |
19 | SRC_URI[sha256sum] = "ee2759d47b0b4ac81b8b671c9485c87fb2db12c097b3e7e69b94c1291a8084e8" | ||
20 | 20 | ||
21 | S = "${WORKDIR}/vbox_module" | 21 | S = "${WORKDIR}/vbox_module" |
22 | 22 | ||