diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-09-19 18:18:55 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-09-20 19:09:06 -0700 |
commit | 290ad988fb94ccde70dcfcba573d162a5c56c339 (patch) | |
tree | c821a5f79dca4a9e286a69af004cddd44b293eb2 /meta-oe/recipes-support/uim/uim_1.8.8.bb | |
parent | e6b7da8d871239f95df31d8572c3244206d3e1d1 (diff) | |
download | meta-openembedded-290ad988fb94ccde70dcfcba573d162a5c56c339.tar.gz |
uim: Update to 1.8.8
License-Update: Change URI from code.google.com to github.com [1]
Drop the patches they seem to be not needed
Add dependency on libedit
Disable parallel make due to races
aarch64 support is upstream so drop the patch
[1] https://github.com/uim/uim/commit/a1cf71ec3719389874c42dd4c719a15509983485#diff-7116ef0705885343c9e1b2171a06be0e
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/uim/uim_1.8.8.bb')
-rw-r--r-- | meta-oe/recipes-support/uim/uim_1.8.8.bb | 147 |
1 files changed, 147 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/uim/uim_1.8.8.bb b/meta-oe/recipes-support/uim/uim_1.8.8.bb new file mode 100644 index 000000000..cc28e6e8f --- /dev/null +++ b/meta-oe/recipes-support/uim/uim_1.8.8.bb | |||
@@ -0,0 +1,147 @@ | |||
1 | DESCRIPTION = "A multilingual user input method library" | ||
2 | HOMEPAGE = "http://uim.freedesktop.org/" | ||
3 | LICENSE = "BSD-3-Clause & LGPLv2+" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=ab2826b41ca0ff4030d38cc39791d1c8" | ||
5 | SECTION = "inputmethods" | ||
6 | |||
7 | SRC_URI = "https://github.com/uim/uim/releases/download/${PV}/uim-${PV}.tar.bz2" | ||
8 | |||
9 | SRC_URI_append_class-target = "\ | ||
10 | file://uim-module-manager.patch \ | ||
11 | file://0001-fix-bug-for-cross-compile.patch \ | ||
12 | " | ||
13 | SRC_URI[md5sum] = "01c7bd5d0d4f3a9f6f5befe6f57a470b" | ||
14 | SRC_URI[sha256sum] = "34599bbcc4e5ab87832370763e38be5100984a64237555e9234a1ea225a0fadc" | ||
15 | |||
16 | DEPENDS = "anthy fontconfig libxft libxt glib-2.0 ncurses intltool libedit" | ||
17 | DEPENDS_append_class-target = " intltool-native gtk+ gtk+3 uim-native takao-fonts" | ||
18 | |||
19 | RDEPENDS_uim = "libuim0 libedit" | ||
20 | RDEPENDS_uim-anthy = "takao-fonts anthy libanthy0" | ||
21 | RDEPENDS_uim-anthy_append_libc-glibc = " glibc-utils glibc-gconv-euc-jp" | ||
22 | |||
23 | LEAD_SONAME = "libuim.so.1" | ||
24 | |||
25 | inherit distro_features_check autotools pkgconfig gettext qemu gtk-immodules-cache | ||
26 | |||
27 | REQUIRED_DISTRO_FEATURES = "x11" | ||
28 | |||
29 | GTKIMMODULES_PACKAGES = "uim-gtk2.0 uim-gtk3" | ||
30 | |||
31 | EXTRA_OECONF += "--disable-emacs \ | ||
32 | --without-scim \ | ||
33 | --without-m17nlib \ | ||
34 | --without-prime \ | ||
35 | --without-canna \ | ||
36 | --without-mana \ | ||
37 | --without-eb \ | ||
38 | " | ||
39 | |||
40 | CONFIGUREOPTS_remove_class-target = "--disable-silent-rules" | ||
41 | |||
42 | # https://github.com/uim/uim/issues/44 | ||
43 | PARALLEL_MAKE = "" | ||
44 | |||
45 | #Because m4 file's find maxdepth=2, so copy the m4 files of the deep depth. | ||
46 | do_configure_prepend () { | ||
47 | cp ${S}/sigscheme/m4/* ${S}/m4/ | ||
48 | } | ||
49 | |||
50 | do_install_append() { | ||
51 | rm -rf ${D}/${datadir}/applications | ||
52 | } | ||
53 | |||
54 | PACKAGES =+ "uim-xim uim-utils uim-skk uim-gtk2.0 uim-gtk3 uim-fep uim-anthy uim-common libuim0 libuim-dev" | ||
55 | |||
56 | FILES_${PN} = "${bindir}/uim-help \ | ||
57 | ${libdir}/uim/plugin/libuim-* \ | ||
58 | ${libdir}/libuim-scm* \ | ||
59 | ${libdir}/libgcroots* \ | ||
60 | ${libdir}/uim/plugin/libuim-* \ | ||
61 | " | ||
62 | |||
63 | FILES_libuim0 = "${libdir}/uim/plugin/libuim-custom-enabler.* \ | ||
64 | ${libdir}/libuim-custom.so.* \ | ||
65 | ${datadir}/locale/ja/LC_MESSAGES/uim.mo \ | ||
66 | ${datadir}/locale/fr/LC_MESSAGES/uim.mo \ | ||
67 | ${datadir}/locale/ko/LC_MESSAGES/uim.mo \ | ||
68 | ${libdir}/libuim.so.* \ | ||
69 | " | ||
70 | FILES_libuim-dev = "${libdir}/libuim*.a \ | ||
71 | ${libdir}/libuim*.la \ | ||
72 | ${libdir}/libuim*.so \ | ||
73 | ${includedir}/uim \ | ||
74 | ${libdir}/pkgconfig/uim.pc \ | ||
75 | " | ||
76 | FILES_uim-anthy = "${libdir}/uim/plugin/libuim-anthy.* \ | ||
77 | ${datadir}/uim/anthy*.scm \ | ||
78 | " | ||
79 | FILES_${PN}-dbg += "${libdir}/*/*/*/.debug ${libdir}/*/*/.debug" | ||
80 | FILES_${PN}-dev += "${libdir}/uim/plugin/*.la" | ||
81 | |||
82 | FILES_uim-utils = "${bindir}/uim-sh \ | ||
83 | ${bindir}/uim-module-manager \ | ||
84 | ${libexecdir}/uim-helper-server \ | ||
85 | " | ||
86 | FILES_uim-xim = "${bindir}/uim-xim \ | ||
87 | ${libexecdir}/uim-candwin-*gtk \ | ||
88 | ${libexecdir}/uim-candwin-*gtk3 \ | ||
89 | ${datadir}/man/man1/uim-xim.1 \ | ||
90 | ${sysconfdir}/X11/xinit/xinput.d/uim* \ | ||
91 | " | ||
92 | FILES_uim-common = "${datadir}/uim/pixmaps/*.png \ | ||
93 | ${datadir}/uim \ | ||
94 | " | ||
95 | FILES_uim-fep = "${bindir}/uim-fep*" | ||
96 | |||
97 | FILES_uim-gtk2.0 = "${libdir}/gtk-2.0 \ | ||
98 | ${bindir}/uim-toolbar-gtk \ | ||
99 | ${bindir}/uim-toolbar-gtk-systray \ | ||
100 | ${bindir}/uim-*-gtk \ | ||
101 | ${bindir}/uim-input-pad-ja \ | ||
102 | ${libdir}/uim/uim-*-gtk \ | ||
103 | " | ||
104 | FILES_uim-gtk3 = "${libdir}/gtk-3.0 \ | ||
105 | ${bindir}/uim-toolbar-gtk3 \ | ||
106 | ${bindir}/uim-toolbar-gtk3-systray \ | ||
107 | ${bindir}/uim-*-gtk3 \ | ||
108 | ${libdir}/uim/uim-*-gtk3 \ | ||
109 | " | ||
110 | FILES_uim-skk = "${libdir}/uim/plugin/libuim-skk.* \ | ||
111 | ${datadir}/uim/skk*.scm \ | ||
112 | " | ||
113 | |||
114 | PACKAGE_WRITE_DEPS += "qemu-native" | ||
115 | pkg_postinst_uim-anthy() { | ||
116 | if test -n "$D"; then | ||
117 | ${@qemu_run_binary(d, '$D', '${bindir}/uim-module-manager')} --register anthy --path $D${datadir}/uim | ||
118 | else | ||
119 | uim-module-manager --register anthy --path ${datadir}/uim | ||
120 | fi | ||
121 | } | ||
122 | |||
123 | pkg_prerm_uim-anthy() { | ||
124 | if test -n "$D"; then | ||
125 | ${@qemu_run_binary(d, '$D', '${bindir}/uim-module-manager')} --path $D${datadir}/uim --unregister anthy | ||
126 | else | ||
127 | uim-module-manager --path ${datadir}/uim --unregister anthy | ||
128 | fi | ||
129 | } | ||
130 | |||
131 | pkg_postinst_uim-skk() { | ||
132 | if test -n "$D"; then | ||
133 | ${@qemu_run_binary(d, '$D', '${bindir}/uim-module-manager')} --register skk --path $D${datadir}/uim | ||
134 | else | ||
135 | uim-module-manager --register skk --path ${datadir}/uim | ||
136 | fi | ||
137 | } | ||
138 | |||
139 | pkg_postrm_uim-skk() { | ||
140 | if test -n "$D"; then | ||
141 | ${@qemu_run_binary(d, '$D', '${bindir}/uim-module-manager')} --path $D${datadir}/uim --unregister skk | ||
142 | else | ||
143 | uim-module-manager --path ${datadir}/uim --unregister skk | ||
144 | fi | ||
145 | } | ||
146 | |||
147 | BBCLASSEXTEND = "native" | ||