summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/uhubctl
diff options
context:
space:
mode:
authorRichard Leitner <richard.leitner@skidata.com>2018-05-23 00:11:29 +0200
committerKhem Raj <raj.khem@gmail.com>2018-05-26 21:10:55 -0700
commita2abbc840755cd563568537a0908c7c7e3ae7e67 (patch)
tree1d193f8383e9b308c67f72fca60ec834d6905cea /meta-oe/recipes-support/uhubctl
parent3ba4e21bb8e8f8b4d9f32a53103d67ae1fa46139 (diff)
downloadmeta-openembedded-a2abbc840755cd563568537a0908c7c7e3ae7e67.tar.gz
uhubctl: add recipe
Add recipe for uhubctl v2.0.0, an utility to control USB power per-port on "smart" USB hubs. Signed-off-by: Richard Leitner <richard.leitner@skidata.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/uhubctl')
-rw-r--r--meta-oe/recipes-support/uhubctl/uhubctl_2.0.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/uhubctl/uhubctl_2.0.0.bb b/meta-oe/recipes-support/uhubctl/uhubctl_2.0.0.bb
new file mode 100644
index 000000000..6306ddb55
--- /dev/null
+++ b/meta-oe/recipes-support/uhubctl/uhubctl_2.0.0.bb
@@ -0,0 +1,21 @@
1SUMMARY = "USB hub per-port power control"
2HOMEPAGE = "https://github.com/mvp/uhubctl"
3BUGTRACKER = "https://github.com/mvp/uhubctl/issues"
4DEPENDS = "libusb1"
5
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
9SRC_URI = "https://github.com/mvp/${PN}/archive/v${PV}.tar.gz"
10SRC_URI[md5sum] = "5c711911d766d76813333c3812277574"
11SRC_URI[sha256sum] = "4c31278b2c03e5be5a696c3088bc86cf2557a70e00f697799c163aba18e3c40e"
12
13# uhubctl gets its program version from "git describe". As we use the source
14# archive do reduce download size replace the call with our hardcoded version.
15do_configure_append() {
16 sed -i "s/^\(GIT_VERSION :=\).*$/\1 ${PV}/g" ${S}/Makefile
17}
18
19do_install () {
20 oe_runmake install DESTDIR=${D}
21}