diff options
author | Shakeel, Muhammad <muhammad_shakeel@mentor.com> | 2013-09-06 11:52:58 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-09-17 19:06:27 +0200 |
commit | 19a61e1f0cbe9e59b7de9f36106a2f9e32f880fa (patch) | |
tree | 2754b541800a9a695831936444fa3ea3e6a85bf2 /meta-oe/recipes-support/tracker | |
parent | c5ae85fec74412cf3bb1c8f3cdcc43d25a4c5fc5 (diff) | |
download | meta-openembedded-19a61e1f0cbe9e59b7de9f36106a2f9e32f880fa.tar.gz |
tracker: Do not use hardcoded paths in systemd service files
- 'sed' base_bindir and libexecdir in service files to align these
with a particular distro
- Fix whitespaces
Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/tracker')
5 files changed, 45 insertions, 6 deletions
diff --git a/meta-oe/recipes-support/tracker/files/tracker-dbus.service b/meta-oe/recipes-support/tracker/files/tracker-dbus.service index 9d4fb7471..c97f49a89 100644 --- a/meta-oe/recipes-support/tracker/files/tracker-dbus.service +++ b/meta-oe/recipes-support/tracker/files/tracker-dbus.service | |||
@@ -8,7 +8,7 @@ BindTo=tracker-store.service | |||
8 | [Service] | 8 | [Service] |
9 | Type=forking | 9 | Type=forking |
10 | EnvironmentFile=-/tmp/tracker.env | 10 | EnvironmentFile=-/tmp/tracker.env |
11 | ExecStartPre=/bin/rm -rf /tmp/tracker.env | 11 | ExecStartPre=@BASE_BINDIR@/rm -rf /tmp/tracker.env |
12 | ExecStart=/bin/sh -c 'echo "DBUS_SESSION_BUS_ADDRESS=`dbus-daemon --fork --session --print-address`" > /tmp/tracker.env' | 12 | ExecStart=/bin/sh -c 'echo "DBUS_SESSION_BUS_ADDRESS=`dbus-daemon --fork --session --print-address`" > /tmp/tracker.env' |
13 | 13 | ||
14 | [Install] | 14 | [Install] |
diff --git a/meta-oe/recipes-support/tracker/files/tracker-miner-fs.service b/meta-oe/recipes-support/tracker/files/tracker-miner-fs.service index f14392472..34d9a1e68 100644 --- a/meta-oe/recipes-support/tracker/files/tracker-miner-fs.service +++ b/meta-oe/recipes-support/tracker/files/tracker-miner-fs.service | |||
@@ -6,7 +6,7 @@ Requires=tracker-store.service | |||
6 | [Service] | 6 | [Service] |
7 | Environment=HOME=/home/root | 7 | Environment=HOME=/home/root |
8 | EnvironmentFile=-/tmp/tracker.env | 8 | EnvironmentFile=-/tmp/tracker.env |
9 | ExecStart=/usr/libexec/tracker-miner-fs | 9 | ExecStart=@LIBEXECDIR@/tracker-miner-fs |
10 | 10 | ||
11 | [Install] | 11 | [Install] |
12 | WantedBy=multi-user.target | 12 | WantedBy=multi-user.target |
diff --git a/meta-oe/recipes-support/tracker/files/tracker-store.service b/meta-oe/recipes-support/tracker/files/tracker-store.service index 7ca9ff08b..c5037f3ab 100644 --- a/meta-oe/recipes-support/tracker/files/tracker-store.service +++ b/meta-oe/recipes-support/tracker/files/tracker-store.service | |||
@@ -6,7 +6,7 @@ BindTo=tracker-dbus.service | |||
6 | 6 | ||
7 | [Service] | 7 | [Service] |
8 | EnvironmentFile=-/tmp/tracker.env | 8 | EnvironmentFile=-/tmp/tracker.env |
9 | ExecStart=/usr/libexec/tracker-store | 9 | ExecStart=@LIBEXECDIR@/tracker-store |
10 | 10 | ||
11 | [Install] | 11 | [Install] |
12 | WantedBy=multi-user.target | 12 | WantedBy=multi-user.target |
diff --git a/meta-oe/recipes-support/tracker/tracker_0.14.2.bb b/meta-oe/recipes-support/tracker/tracker_0.14.2.bb index 5838c2d3c..fc6db4b4a 100644 --- a/meta-oe/recipes-support/tracker/tracker_0.14.2.bb +++ b/meta-oe/recipes-support/tracker/tracker_0.14.2.bb | |||
@@ -32,14 +32,17 @@ EXTRA_OECONF += "--disable-miner-thunderbird --disable-miner-firefox \ | |||
32 | LEAD_SONAME = "libtrackerclient.so.0" | 32 | LEAD_SONAME = "libtrackerclient.so.0" |
33 | 33 | ||
34 | do_install_append() { | 34 | do_install_append() { |
35 | cp -PpR ${D}${STAGING_DATADIR}/* ${D}${datadir}/ || true | 35 | cp -PpR ${D}${STAGING_DATADIR}/* ${D}${datadir}/ || true |
36 | # install -d ${D}/${sysconfdir}/X11/Xsession.d/ | 36 | # install -d ${D}/${sysconfdir}/X11/Xsession.d/ |
37 | # install -m 0755 ${WORKDIR}/90tracker ${D}/${sysconfdir}/X11/Xsession.d/ | 37 | # install -m 0755 ${WORKDIR}/90tracker ${D}/${sysconfdir}/X11/Xsession.d/ |
38 | 38 | ||
39 | install -d ${D}${systemd_unitdir}/system | 39 | install -d ${D}${systemd_unitdir}/system |
40 | install -m 0644 ${WORKDIR}/tracker-store.service ${D}${systemd_unitdir}/system | 40 | install -m 0644 ${WORKDIR}/tracker-store.service ${D}${systemd_unitdir}/system |
41 | install -m 0644 ${WORKDIR}/tracker-miner-fs.service ${D}${systemd_unitdir}/system | 41 | install -m 0644 ${WORKDIR}/tracker-miner-fs.service ${D}${systemd_unitdir}/system |
42 | install -m 0644 ${WORKDIR}/tracker-dbus.service ${D}${systemd_unitdir}/system | 42 | install -m 0644 ${WORKDIR}/tracker-dbus.service ${D}${systemd_unitdir}/system |
43 | sed -i -e 's,@LIBEXECDIR@,${libexecdir},g' \ | ||
44 | -e 's,@BASE_BINDIR@,${base_bindir},g' \ | ||
45 | ${D}${systemd_unitdir}/system/*.service | ||
43 | } | 46 | } |
44 | 47 | ||
45 | PACKAGES =+ "${PN}-tests ${PN}-vala ${PN}-nautilus-extension" | 48 | PACKAGES =+ "${PN}-tests ${PN}-vala ${PN}-nautilus-extension" |
diff --git a/meta-oe/recipes-support/tracker/tracker_0.14.2.bb.rej b/meta-oe/recipes-support/tracker/tracker_0.14.2.bb.rej new file mode 100644 index 000000000..d04482973 --- /dev/null +++ b/meta-oe/recipes-support/tracker/tracker_0.14.2.bb.rej | |||
@@ -0,0 +1,36 @@ | |||
1 | --- meta-oe/recipes-support/tracker/tracker_0.14.2.bb | ||
2 | +++ meta-oe/recipes-support/tracker/tracker_0.14.2.bb | ||
3 | @@ -13,7 +13,7 @@ | ||
4 | SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/tracker/${VER_DIR}/tracker-${PV}.tar.xz \ | ||
5 | file://0005-Fix-missing-gobject-introspection-checks.patch \ | ||
6 | file://enable-sqlite-crosscompile.patch \ | ||
7 | - file://fix-removable-media-detection.patch \ | ||
8 | + file://fix-removable-media-detection.patch \ | ||
9 | file://90tracker \ | ||
10 | file://tracker-store.service \ | ||
11 | file://tracker-miner-fs.service \ | ||
12 | @@ -32,14 +32,17 @@ | ||
13 | LEAD_SONAME = "libtrackerclient.so.0" | ||
14 | |||
15 | do_install_append() { | ||
16 | - cp -PpR ${D}${STAGING_DATADIR}/* ${D}${datadir}/ || true | ||
17 | -# install -d ${D}/${sysconfdir}/X11/Xsession.d/ | ||
18 | -# install -m 0755 ${WORKDIR}/90tracker ${D}/${sysconfdir}/X11/Xsession.d/ | ||
19 | + cp -PpR ${D}${STAGING_DATADIR}/* ${D}${datadir}/ || true | ||
20 | + # install -d ${D}/${sysconfdir}/X11/Xsession.d/ | ||
21 | + # install -m 0755 ${WORKDIR}/90tracker ${D}/${sysconfdir}/X11/Xsession.d/ | ||
22 | |||
23 | - install -d ${D}${systemd_unitdir}/system | ||
24 | - install -m 0644 ${WORKDIR}/tracker-store.service ${D}${systemd_unitdir}/system | ||
25 | - install -m 0644 ${WORKDIR}/tracker-miner-fs.service ${D}${systemd_unitdir}/system | ||
26 | - install -m 0644 ${WORKDIR}/tracker-dbus.service ${D}${systemd_unitdir}/system | ||
27 | + install -d ${D}${systemd_unitdir}/system | ||
28 | + install -m 0644 ${WORKDIR}/tracker-store.service ${D}${systemd_unitdir}/system | ||
29 | + install -m 0644 ${WORKDIR}/tracker-miner-fs.service ${D}${systemd_unitdir}/system | ||
30 | + install -m 0644 ${WORKDIR}/tracker-dbus.service ${D}${systemd_unitdir}/system | ||
31 | + sed -i -e 's,@LIBEXECDIR@,${libexecdir},g' \ | ||
32 | + -e 's,@BASE_BINDIR@,${base_bindir},g' \ | ||
33 | + ${D}${systemd_unitdir}/system/*.service | ||
34 | } | ||
35 | |||
36 | PACKAGES =+ "${PN}-tests ${PN}-vala ${PN}-nautilus-extension" | ||