summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/toscoterm
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/toscoterm
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/toscoterm')
-rw-r--r--meta-oe/recipes-support/toscoterm/toscoterm_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/toscoterm/toscoterm_git.bb b/meta-oe/recipes-support/toscoterm/toscoterm_git.bb
new file mode 100644
index 000000000..24f813b62
--- /dev/null
+++ b/meta-oe/recipes-support/toscoterm/toscoterm_git.bb
@@ -0,0 +1,27 @@
1SUMMARY = "A very small and simple terminal emulator"
2SECTION = "x11/applications"
3DEPENDS = "vte"
4
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://main.c;start_line=5;end_line=16;md5=9ae4bf20caf291afa94530026bd15229"
7
8# 0.2 version
9SRCREV = "8586d617aed19fc75f5ae1e07270752c1b2f9a30"
10SRC_URI = "git://github.com/OSSystems/toscoterm.git"
11
12S = "${WORKDIR}/git"
13
14inherit gitpkgv pkgconfig
15
16do_compile() {
17 oe_runmake \
18 CC="${CC}" \
19 CFLAGS="`pkg-config --cflags vte`${CFLAGS}" \
20 LDFLAGS="`pkg-config --libs vte` ${LDFLAGS}"
21}
22
23do_install() {
24 oe_runmake PREFIX="${prefix}" DESTDIR="${D}" install
25}
26
27RDEPENDS_${PN}_append_libc-glibc += "glibc-gconv-ibm437"