diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-03-06 23:13:42 -0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-03-11 17:56:42 +0100 |
commit | 475ba851dec91e854255204d8e54f3104a5350b8 (patch) | |
tree | d9196b0b49856aa57f25e070dd7c873d03a95d18 /meta-oe/recipes-support/tbb | |
parent | e2975aee7c89f87d42ca83d7f40bec5a35ccd9c4 (diff) | |
download | meta-openembedded-475ba851dec91e854255204d8e54f3104a5350b8.tar.gz |
tbb: Update to 2017 release
Update license to reflect new Apache 2.0 license
Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/tbb')
-rw-r--r-- | meta-oe/recipes-support/tbb/tbb.bb (renamed from meta-oe/recipes-support/tbb/tbb_4.1.bb) | 23 | ||||
-rw-r--r-- | meta-oe/recipes-support/tbb/tbb/allow-to-build-for-older-arm-cores.patch | 30 | ||||
-rw-r--r-- | meta-oe/recipes-support/tbb/tbb/cross-compile.patch | 30 |
3 files changed, 33 insertions, 50 deletions
diff --git a/meta-oe/recipes-support/tbb/tbb_4.1.bb b/meta-oe/recipes-support/tbb/tbb.bb index 09ed6ec52..d8eb1c2f3 100644 --- a/meta-oe/recipes-support/tbb/tbb_4.1.bb +++ b/meta-oe/recipes-support/tbb/tbb.bb | |||
@@ -4,23 +4,22 @@ DESCRIPTION = "Parallelism library for C++ - runtime files \ | |||
4 | higher-level, task-based parallelism that abstracts platform details \ | 4 | higher-level, task-based parallelism that abstracts platform details \ |
5 | and threading mechanism for performance and scalability." | 5 | and threading mechanism for performance and scalability." |
6 | HOMEPAGE = "http://threadingbuildingblocks.org/" | 6 | HOMEPAGE = "http://threadingbuildingblocks.org/" |
7 | LICENSE = "GPLv2" | 7 | LICENSE = "Apache-2.0" |
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=2c7f2caf277a3933e3acdf7f89d54cc1" | 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
9 | PRDATE = "20130314" | 9 | PRDATE = "20170118" |
10 | PR = "r${PRDATE}" | 10 | PV = "${PRDATE}" |
11 | 11 | SRC_URI = "https://www.threadingbuildingblocks.org/sites/default/files/software_releases/source/tbb2017_${PRDATE}oss_src.tgz \ | |
12 | SRC_URI = "http://threadingbuildingblocks.org/sites/default/files/software_releases/source/tbb41_${PRDATE}oss_src.tgz \ | ||
13 | file://cross-compile.patch \ | 12 | file://cross-compile.patch \ |
14 | file://allow-to-build-for-older-arm-cores.patch \ | ||
15 | file://tbb.pc" | 13 | file://tbb.pc" |
14 | SRC_URI[md5sum] = "26baa6fbcc8f03ee45c0641b91d9588a" | ||
15 | SRC_URI[sha256sum] = "48bb526287fa8b4e7d1e1b2ba9e5fb9c3e372b497772c06ef9ccd7f93f344e74" | ||
16 | 16 | ||
17 | S = "${WORKDIR}/tbb41_${PRDATE}oss/" | 17 | S = "${WORKDIR}/tbb2017_${PRDATE}oss/" |
18 | |||
19 | SRC_URI[md5sum] = "ed4af7ccfa122f16cf9920b241633a3a" | ||
20 | SRC_URI[sha256sum] = "32fd5979971b772caa96d40646cee585ed0070516ba2dbbcb1f9b6033d08a92d" | ||
21 | 18 | ||
19 | COMPILER ?= "gcc" | ||
20 | COMPILER_toolchain-clang = "clang" | ||
22 | do_compile() { | 21 | do_compile() { |
23 | oe_runmake compiler=gcc arch=${HOST_ARCH} runtime=cc4 | 22 | oe_runmake compiler=${COMPILER} arch=${HOST_ARCH} runtime=cc4 |
24 | } | 23 | } |
25 | 24 | ||
26 | do_install() { | 25 | do_install() { |
diff --git a/meta-oe/recipes-support/tbb/tbb/allow-to-build-for-older-arm-cores.patch b/meta-oe/recipes-support/tbb/tbb/allow-to-build-for-older-arm-cores.patch deleted file mode 100644 index cd2ec9499..000000000 --- a/meta-oe/recipes-support/tbb/tbb/allow-to-build-for-older-arm-cores.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | From: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org> | ||
2 | Description: Allow to build TBB for ARM cores older than ARMv7a | ||
3 | |||
4 | | ../../include/tbb/machine/gcc_armv7.h:39:2: error: #error Threading | ||
5 | Building Blocks ARM port requires an ARMv7-a architecture. | ||
6 | | make[1]: *** [concurrent_hash_map.o] Error 1 | ||
7 | |||
8 | https://bugs.launchpad.net/linaro-oe/+bug/1167144 | ||
9 | |||
10 | Upstream-status: pending | ||
11 | |||
12 | --- | ||
13 | include/tbb/tbb_machine.h | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | --- tbb41_20130314oss.orig/include/tbb/tbb_machine.h | ||
17 | +++ tbb41_20130314oss/include/tbb/tbb_machine.h | ||
18 | @@ -237,11 +237,11 @@ template<> struct atomic_selector<8> { | ||
19 | #include "machine/linux_intel64.h" | ||
20 | #elif __ia64__ | ||
21 | #include "machine/linux_ia64.h" | ||
22 | #elif __powerpc__ | ||
23 | #include "machine/mac_ppc.h" | ||
24 | - #elif __arm__ | ||
25 | + #elif __ARM_ARCH_7A__ | ||
26 | #include "machine/gcc_armv7.h" | ||
27 | #elif __TBB_GCC_BUILTIN_ATOMICS_PRESENT | ||
28 | #include "machine/gcc_generic.h" | ||
29 | #endif | ||
30 | #include "machine/linux_common.h" | ||
diff --git a/meta-oe/recipes-support/tbb/tbb/cross-compile.patch b/meta-oe/recipes-support/tbb/tbb/cross-compile.patch index b970a374e..d54b307ee 100644 --- a/meta-oe/recipes-support/tbb/tbb/cross-compile.patch +++ b/meta-oe/recipes-support/tbb/tbb/cross-compile.patch | |||
@@ -5,14 +5,14 @@ Upstream-Status: unsuitable | |||
5 | build/linux.gcc.inc | 5 +++-- | 5 | build/linux.gcc.inc | 5 +++-- |
6 | 1 file changed, 3 insertions(+), 2 deletions(-) | 6 | 1 file changed, 3 insertions(+), 2 deletions(-) |
7 | 7 | ||
8 | --- tbb41_20121003oss.orig/build/linux.gcc.inc | 8 | Index: tbb2017_20170118oss/build/linux.gcc.inc |
9 | +++ tbb41_20121003oss/build/linux.gcc.inc | 9 | =================================================================== |
10 | @@ -40,12 +40,13 @@ DYLIB_KEY = -shared | 10 | --- tbb2017_20170118oss.orig/build/linux.gcc.inc |
11 | +++ tbb2017_20170118oss/build/linux.gcc.inc | ||
12 | @@ -32,8 +32,9 @@ DYLIB_KEY = -shared | ||
11 | EXPORT_KEY = -Wl,--version-script, | 13 | EXPORT_KEY = -Wl,--version-script, |
12 | LIBDL = -ldl | 14 | LIBDL = -ldl |
13 | 15 | ||
14 | TBB_NOSTRICT = 1 | ||
15 | |||
16 | -CPLUS = g++ | 16 | -CPLUS = g++ |
17 | -CONLY = gcc | 17 | -CONLY = gcc |
18 | +CPLUS = $(CXX) | 18 | +CPLUS = $(CXX) |
@@ -20,6 +20,20 @@ Upstream-Status: unsuitable | |||
20 | +CPLUS_FLAGS = $(CXXFLAGS) | 20 | +CPLUS_FLAGS = $(CXXFLAGS) |
21 | LIB_LINK_FLAGS = $(DYLIB_KEY) -Wl,-soname=$(BUILDING_LIBRARY) | 21 | LIB_LINK_FLAGS = $(DYLIB_KEY) -Wl,-soname=$(BUILDING_LIBRARY) |
22 | LIBS += -lpthread -lrt | 22 | LIBS += -lpthread -lrt |
23 | LINK_FLAGS = -Wl,-rpath-link=. | 23 | LINK_FLAGS = -Wl,-rpath-link=. -rdynamic |
24 | C_FLAGS = $(CPLUS_FLAGS) | 24 | Index: tbb2017_20170118oss/build/linux.clang.inc |
25 | # gcc 4.4 and higher support -std=c++0x | 25 | =================================================================== |
26 | --- tbb2017_20170118oss.orig/build/linux.clang.inc | ||
27 | +++ tbb2017_20170118oss/build/linux.clang.inc | ||
28 | @@ -31,8 +31,9 @@ DYLIB_KEY = -shared | ||
29 | EXPORT_KEY = -Wl,--version-script, | ||
30 | LIBDL = -ldl | ||
31 | |||
32 | -CPLUS = clang++ | ||
33 | -CONLY = clang | ||
34 | +CPLUS = $(CXX) | ||
35 | +CONLY = $(CC) | ||
36 | +CPLUS_FLAGS = $(CXXFLAGS) | ||
37 | LIB_LINK_FLAGS = $(DYLIB_KEY) -Wl,-soname=$(BUILDING_LIBRARY) | ||
38 | LIBS += -lpthread -lrt | ||
39 | LINK_FLAGS = -Wl,-rpath-link=. -rdynamic | ||