diff options
author | Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org> | 2013-04-15 18:00:47 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-19 02:45:27 +0200 |
commit | 3c2891137dc35872264164eba58599e74ac3f57c (patch) | |
tree | 67ed677a98666851a2114fc45b3bc28b2b7d653f /meta-oe/recipes-support/tbb | |
parent | b3beff1f2457f4d591c6a94ee8441d9dba27feb2 (diff) | |
download | meta-openembedded-3c2891137dc35872264164eba58599e74ac3f57c.tar.gz |
tbb: update to 4.1 Update 3 version from 20130314
ARMv7a support was added in 4.1 Update 3
Older ARM cores support was added by me.
Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/tbb')
-rw-r--r-- | meta-oe/recipes-support/tbb/tbb/allow-to-build-for-older-arm-cores.patch | 30 | ||||
-rw-r--r-- | meta-oe/recipes-support/tbb/tbb_4.1.bb | 7 |
2 files changed, 34 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/tbb/tbb/allow-to-build-for-older-arm-cores.patch b/meta-oe/recipes-support/tbb/tbb/allow-to-build-for-older-arm-cores.patch new file mode 100644 index 000000000..cd2ec9499 --- /dev/null +++ b/meta-oe/recipes-support/tbb/tbb/allow-to-build-for-older-arm-cores.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org> | ||
2 | Description: Allow to build TBB for ARM cores older than ARMv7a | ||
3 | |||
4 | | ../../include/tbb/machine/gcc_armv7.h:39:2: error: #error Threading | ||
5 | Building Blocks ARM port requires an ARMv7-a architecture. | ||
6 | | make[1]: *** [concurrent_hash_map.o] Error 1 | ||
7 | |||
8 | https://bugs.launchpad.net/linaro-oe/+bug/1167144 | ||
9 | |||
10 | Upstream-status: pending | ||
11 | |||
12 | --- | ||
13 | include/tbb/tbb_machine.h | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | --- tbb41_20130314oss.orig/include/tbb/tbb_machine.h | ||
17 | +++ tbb41_20130314oss/include/tbb/tbb_machine.h | ||
18 | @@ -237,11 +237,11 @@ template<> struct atomic_selector<8> { | ||
19 | #include "machine/linux_intel64.h" | ||
20 | #elif __ia64__ | ||
21 | #include "machine/linux_ia64.h" | ||
22 | #elif __powerpc__ | ||
23 | #include "machine/mac_ppc.h" | ||
24 | - #elif __arm__ | ||
25 | + #elif __ARM_ARCH_7A__ | ||
26 | #include "machine/gcc_armv7.h" | ||
27 | #elif __TBB_GCC_BUILTIN_ATOMICS_PRESENT | ||
28 | #include "machine/gcc_generic.h" | ||
29 | #endif | ||
30 | #include "machine/linux_common.h" | ||
diff --git a/meta-oe/recipes-support/tbb/tbb_4.1.bb b/meta-oe/recipes-support/tbb/tbb_4.1.bb index a159321c1..96137bc94 100644 --- a/meta-oe/recipes-support/tbb/tbb_4.1.bb +++ b/meta-oe/recipes-support/tbb/tbb_4.1.bb | |||
@@ -6,17 +6,18 @@ DESCRIPTION = "Parallelism library for C++ - runtime files \ | |||
6 | HOMEPAGE = "http://threadingbuildingblocks.org/" | 6 | HOMEPAGE = "http://threadingbuildingblocks.org/" |
7 | LICENSE = "GPLv2" | 7 | LICENSE = "GPLv2" |
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=2c7f2caf277a3933e3acdf7f89d54cc1" | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=2c7f2caf277a3933e3acdf7f89d54cc1" |
9 | PRDATE = "20130116" | 9 | PRDATE = "20130314" |
10 | PR = "r${PRDATE}" | 10 | PR = "r${PRDATE}" |
11 | 11 | ||
12 | SRC_URI = "http://threadingbuildingblocks.org/sites/default/files/software_releases/source/tbb41_${PRDATE}oss_src.tgz \ | 12 | SRC_URI = "http://threadingbuildingblocks.org/sites/default/files/software_releases/source/tbb41_${PRDATE}oss_src.tgz \ |
13 | file://cross-compile.patch \ | 13 | file://cross-compile.patch \ |
14 | file://allow-to-build-for-older-arm-cores.patch \ | ||
14 | file://tbb.pc" | 15 | file://tbb.pc" |
15 | 16 | ||
16 | S = "${WORKDIR}/tbb41_${PRDATE}oss/" | 17 | S = "${WORKDIR}/tbb41_${PRDATE}oss/" |
17 | 18 | ||
18 | SRC_URI[md5sum] = "3809790e1001a1b32d59c9fee590ee85" | 19 | SRC_URI[md5sum] = "ed4af7ccfa122f16cf9920b241633a3a" |
19 | SRC_URI[sha256sum] = "4ae2c10899e3b6ef2f686013ec5901fc658444ca90178efaca6014b0665c34b6" | 20 | SRC_URI[sha256sum] = "32fd5979971b772caa96d40646cee585ed0070516ba2dbbcb1f9b6033d08a92d" |
20 | 21 | ||
21 | do_compile() { | 22 | do_compile() { |
22 | oe_runmake compiler=gcc arch=${HOST_ARCH} runtime=cc4 | 23 | oe_runmake compiler=gcc arch=${HOST_ARCH} runtime=cc4 |