summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/tbb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-03-29 16:51:39 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-29 17:32:21 -0700
commit6ffd5b456f7c1587e59b411365586e8ff959ee48 (patch)
tree492b1e89818e950cebf022b55986b3651b6501b4 /meta-oe/recipes-support/tbb
parent76db1c71ef8fc6e6f521f921b3361b37d96e6e3c (diff)
downloadmeta-openembedded-6ffd5b456f7c1587e59b411365586e8ff959ee48.tar.gz
tbb: Ensure that install does not race
This fixes install: will not overwrite just-created 'TOPDIR/build/tmp/work/core2-64-yoe-linux/tbb/20170412+AUTOINC+a2cfdfe946-r0/image/usr/lib/libtbbmalloc_proxy.so' with 'TOPDIR/build/tmp/work/core2-64-yoe-linux/tbb/20170412+AUTOINC+a2cfdfe946-r0/git/build/linux_x86_64_gcc_cc4_release/libtbbmalloc_proxy.so' Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/tbb')
-rw-r--r--meta-oe/recipes-support/tbb/tbb.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/tbb/tbb.bb b/meta-oe/recipes-support/tbb/tbb.bb
index f87010401..911139b0d 100644
--- a/meta-oe/recipes-support/tbb/tbb.bb
+++ b/meta-oe/recipes-support/tbb/tbb.bb
@@ -27,11 +27,14 @@ do_compile() {
27} 27}
28 28
29do_install() { 29do_install() {
30 install -d ${D}${includedir} ${D}${libdir}/pkgconfig 30 install -d ${D}${includedir} ${D}${libdir}
31 rm ${S}/include/tbb/index.html -f 31 rm ${S}/include/tbb/index.html -f
32 cp -R --no-dereference --preserve=mode,links -v ${S}/include/tbb ${D}${includedir} 32 cp -R --no-dereference --preserve=mode,links -v ${S}/include/tbb ${D}${includedir}
33 install -m 0755 ${B}/build/linux_*_release/lib*.so* ${D}${libdir} 33 for f in ${B}/build/linux_*_release/lib*.so*
34 install -m 0644 ${WORKDIR}/tbb.pc ${D}${libdir}/pkgconfig 34 do
35 install -Dm 0755 $f ${D}${libdir}/
36 done
37 install -Dm 0644 ${WORKDIR}/tbb.pc ${D}${libdir}/pkgconfig/tbb.pc
35} 38}
36 39
37# fails with thumb enabled: 40# fails with thumb enabled: