summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/tbb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/tbb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/tbb')
-rw-r--r--meta-oe/recipes-support/tbb/tbb/allow-to-build-for-older-arm-cores.patch30
-rw-r--r--meta-oe/recipes-support/tbb/tbb/cross-compile.patch25
-rw-r--r--meta-oe/recipes-support/tbb/tbb/tbb.pc11
-rw-r--r--meta-oe/recipes-support/tbb/tbb_4.1.bb40
4 files changed, 106 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/tbb/tbb/allow-to-build-for-older-arm-cores.patch b/meta-oe/recipes-support/tbb/tbb/allow-to-build-for-older-arm-cores.patch
new file mode 100644
index 000000000..cd2ec9499
--- /dev/null
+++ b/meta-oe/recipes-support/tbb/tbb/allow-to-build-for-older-arm-cores.patch
@@ -0,0 +1,30 @@
1From: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
2Description: Allow to build TBB for ARM cores older than ARMv7a
3
4| ../../include/tbb/machine/gcc_armv7.h:39:2: error: #error Threading
5Building Blocks ARM port requires an ARMv7-a architecture.
6| make[1]: *** [concurrent_hash_map.o] Error 1
7
8https://bugs.launchpad.net/linaro-oe/+bug/1167144
9
10Upstream-status: pending
11
12---
13 include/tbb/tbb_machine.h | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16--- tbb41_20130314oss.orig/include/tbb/tbb_machine.h
17+++ tbb41_20130314oss/include/tbb/tbb_machine.h
18@@ -237,11 +237,11 @@ template<> struct atomic_selector<8> {
19 #include "machine/linux_intel64.h"
20 #elif __ia64__
21 #include "machine/linux_ia64.h"
22 #elif __powerpc__
23 #include "machine/mac_ppc.h"
24- #elif __arm__
25+ #elif __ARM_ARCH_7A__
26 #include "machine/gcc_armv7.h"
27 #elif __TBB_GCC_BUILTIN_ATOMICS_PRESENT
28 #include "machine/gcc_generic.h"
29 #endif
30 #include "machine/linux_common.h"
diff --git a/meta-oe/recipes-support/tbb/tbb/cross-compile.patch b/meta-oe/recipes-support/tbb/tbb/cross-compile.patch
new file mode 100644
index 000000000..b970a374e
--- /dev/null
+++ b/meta-oe/recipes-support/tbb/tbb/cross-compile.patch
@@ -0,0 +1,25 @@
1Author: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
2
3Upstream-Status: unsuitable
4---
5 build/linux.gcc.inc | 5 +++--
6 1 file changed, 3 insertions(+), 2 deletions(-)
7
8--- tbb41_20121003oss.orig/build/linux.gcc.inc
9+++ tbb41_20121003oss/build/linux.gcc.inc
10@@ -40,12 +40,13 @@ DYLIB_KEY = -shared
11 EXPORT_KEY = -Wl,--version-script,
12 LIBDL = -ldl
13
14 TBB_NOSTRICT = 1
15
16-CPLUS = g++
17-CONLY = gcc
18+CPLUS = $(CXX)
19+CONLY = $(CC)
20+CPLUS_FLAGS = $(CXXFLAGS)
21 LIB_LINK_FLAGS = $(DYLIB_KEY) -Wl,-soname=$(BUILDING_LIBRARY)
22 LIBS += -lpthread -lrt
23 LINK_FLAGS = -Wl,-rpath-link=.
24 C_FLAGS = $(CPLUS_FLAGS)
25 # gcc 4.4 and higher support -std=c++0x
diff --git a/meta-oe/recipes-support/tbb/tbb/tbb.pc b/meta-oe/recipes-support/tbb/tbb/tbb.pc
new file mode 100644
index 000000000..644b64fbf
--- /dev/null
+++ b/meta-oe/recipes-support/tbb/tbb/tbb.pc
@@ -0,0 +1,11 @@
1prefix=/usr
2exec_prefix=${prefix}
3libdir=${exec_prefix}/lib
4includedir=${prefix}/include
5
6Name: Threading Building Blocks
7Description: Intel's parallelism library for C++
8URL: http://www.threadingbuildingblocks.org/
9Version: 3.0+r018
10Libs: -L${libdir} -ltbb
11Cflags: -I${includedir}
diff --git a/meta-oe/recipes-support/tbb/tbb_4.1.bb b/meta-oe/recipes-support/tbb/tbb_4.1.bb
new file mode 100644
index 000000000..55212dc6c
--- /dev/null
+++ b/meta-oe/recipes-support/tbb/tbb_4.1.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "Parallelism library for C++ - runtime files \
2 TBB is a library that helps you leverage multi-core processor \
3 performance without having to be a threading expert. It represents a \
4 higher-level, task-based parallelism that abstracts platform details \
5 and threading mechanism for performance and scalability."
6HOMEPAGE = "http://threadingbuildingblocks.org/"
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=2c7f2caf277a3933e3acdf7f89d54cc1"
9PRDATE = "20130314"
10PR = "r${PRDATE}"
11
12SRC_URI = "http://threadingbuildingblocks.org/sites/default/files/software_releases/source/tbb41_${PRDATE}oss_src.tgz \
13 file://cross-compile.patch \
14 file://allow-to-build-for-older-arm-cores.patch \
15 file://tbb.pc"
16
17S = "${WORKDIR}/tbb41_${PRDATE}oss/"
18
19SRC_URI[md5sum] = "ed4af7ccfa122f16cf9920b241633a3a"
20SRC_URI[sha256sum] = "32fd5979971b772caa96d40646cee585ed0070516ba2dbbcb1f9b6033d08a92d"
21
22do_compile() {
23 oe_runmake compiler=gcc arch=${HOST_ARCH} runtime=cc4
24}
25
26do_install() {
27 install -d ${D}${includedir} ${D}${libdir}/pkgconfig
28 rm ${S}/include/tbb/index.html -f
29 cp -a ${S}/include/tbb ${D}${includedir}
30 install -m 0755 ${B}/build/linux_*_release/lib*.so* ${D}${libdir}
31 install -m 0644 ${WORKDIR}/tbb.pc ${D}${libdir}/pkgconfig
32}
33
34# fails with thumb enabled:
35# | arm-oe-linux-gnueabi-g++ -march=armv7-a -mthumb -mthumb-interwork -mfloat-abi=softfp -mfpu=neon -mtune=cortex-a9 -mcpu=cortex-a9 -D__ARM__ -D__LINUX_ARM_ARCH__=7 -funwind-tables -mvectorize-with-neon-quad -rdynamic --sysroot=/OE/sysroots/m14tv -c -MMD -DTBB_USE_DEBUG -g -O0 -DUSE_PTHREAD -fPIC -D__TBB_BUILD=1 -Wall -Wno-parentheses -Wno-non-virtual-dtor -O2 -pipe -g -feliminate-unused-debug-types -fpermissive -fvisibility-inlines-hidden -I../../src -I../../src/rml/include -I../../include ../../src/tbb/concurrent_queue.cpp
36# | {standard input}: Assembler messages:
37# | {standard input}:250: Error: thumb conditional instruction should be in IT block -- `strexeq r2,r3,[r4]'
38# ...
39# | make[1]: *** [concurrent_queue.o] Error 1
40ARM_INSTRUCTION_SET = "arm"