diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 22:49:41 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:23:17 +0200 |
commit | a45830a39bb47a9eab27980d52966226c9504ea4 (patch) | |
tree | 001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-support/talloc | |
parent | 6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff) | |
download | meta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz |
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python
tasks).
* Some recipes were using tabs.
* Some were using 8 spaces.
* Some were using mix or different number of spaces.
* Make them consistently use 4 spaces everywhere.
* Yocto styleguide advises to use tabs (but the only reason to keep
tabs is the need to update a lot of recipes). Lately this advice
was also merged into the styleguide on the OE wiki.
* Using 4 spaces in both types of tasks is better because it's less
error prone when someone is not sure if e.g.
do_generate_toolchain_file() is Python or shell task and also allows
to highlight every tab used in .bb, .inc, .bbappend, .bbclass as
potentially bad (shouldn't be used for indenting of multiline
variable assignments and cannot be used for Python tasks).
* Don't indent closing quote on multiline variables
we're quite inconsistent wheater it's first character on line
under opening quote or under first non-whitespace character in
previous line.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/talloc')
-rw-r--r-- | meta-oe/recipes-support/talloc/talloc_2.0.1.bb | 20 |
1 files changed, 10 insertions, 10 deletions
diff --git a/meta-oe/recipes-support/talloc/talloc_2.0.1.bb b/meta-oe/recipes-support/talloc/talloc_2.0.1.bb index 6aa5a9e80..83bb0c248 100644 --- a/meta-oe/recipes-support/talloc/talloc_2.0.1.bb +++ b/meta-oe/recipes-support/talloc/talloc_2.0.1.bb | |||
@@ -7,7 +7,7 @@ inherit autotools pkgconfig | |||
7 | 7 | ||
8 | SRC_URI = "http://samba.org/ftp/${BPN}/${BPN}-${PV}.tar.gz \ | 8 | SRC_URI = "http://samba.org/ftp/${BPN}/${BPN}-${PV}.tar.gz \ |
9 | file://install-swig-interface-in-SWINGLIBDIR.patch \ | 9 | file://install-swig-interface-in-SWINGLIBDIR.patch \ |
10 | " | 10 | " |
11 | SRC_URI[md5sum] = "c6e736540145ca58cb3dcb42f91cf57b" | 11 | SRC_URI[md5sum] = "c6e736540145ca58cb3dcb42f91cf57b" |
12 | SRC_URI[sha256sum] = "5b810527405f29d54f50efd78bf2c89e318f2cd8bed001f22f2a1412fd27c9b4" | 12 | SRC_URI[sha256sum] = "5b810527405f29d54f50efd78bf2c89e318f2cd8bed001f22f2a1412fd27c9b4" |
13 | 13 | ||
@@ -17,21 +17,21 @@ PR = "r2" | |||
17 | 17 | ||
18 | # autoreconf doesn't work well while reconfiguring included libreplace | 18 | # autoreconf doesn't work well while reconfiguring included libreplace |
19 | do_configure () { | 19 | do_configure () { |
20 | gnu-configize | 20 | gnu-configize |
21 | oe_runconf | 21 | oe_runconf |
22 | } | 22 | } |
23 | 23 | ||
24 | do_install_prepend() { | 24 | do_install_prepend() { |
25 | # Hack the way swig interface for talloc is installed | 25 | # Hack the way swig interface for talloc is installed |
26 | # This hack is accompanied by install-swig-interface-in-SWINGLIBDIR.patch | 26 | # This hack is accompanied by install-swig-interface-in-SWINGLIBDIR.patch |
27 | type swig > /dev/null 2>&1 && SWIGLIBDIR=`swig -swiglib` && SWIGLIBDIR=${SWIGLIBDIR##${STAGING_DIR_NATIVE}} && export SWIGLIBDIR || echo "No swig found" | 27 | type swig > /dev/null 2>&1 && SWIGLIBDIR=`swig -swiglib` && SWIGLIBDIR=${SWIGLIBDIR##${STAGING_DIR_NATIVE}} && export SWIGLIBDIR || echo "No swig found" |
28 | } | 28 | } |
29 | 29 | ||
30 | do_install_append() { | 30 | do_install_append() { |
31 | install -d ${D}${libdir} | 31 | install -d ${D}${libdir} |
32 | ln -s libtalloc.so.2.0.1 ${D}${libdir}/libtalloc.so.2.0 | 32 | ln -s libtalloc.so.2.0.1 ${D}${libdir}/libtalloc.so.2.0 |
33 | ln -s libtalloc.so.2.0 ${D}${libdir}/libtalloc.so.2 | 33 | ln -s libtalloc.so.2.0 ${D}${libdir}/libtalloc.so.2 |
34 | ln -s libtalloc.so.2 ${D}${libdir}/libtalloc.so | 34 | ln -s libtalloc.so.2 ${D}${libdir}/libtalloc.so |
35 | } | 35 | } |
36 | 36 | ||
37 | PACKAGES += "${PN}-swig" | 37 | PACKAGES += "${PN}-swig" |