diff options
author | Andrei Gherzan <andrei@gherzan.ro> | 2012-10-03 13:41:30 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-10-04 15:52:27 +0200 |
commit | d4c73cbdfede37e9dce069e8770c112f16ce0b5a (patch) | |
tree | 66e83c2a2a9dca3e9ff74a4f8866b8f13e548581 /meta-oe/recipes-support/talloc | |
parent | 3871d4561464eedc6a9a83b2c682ec7d29682873 (diff) | |
download | meta-openembedded-d4c73cbdfede37e9dce069e8770c112f16ce0b5a.tar.gz |
talloc: Fix swig interface install path
Using the way swig interface is installed leads to a bad path in ${D}.
The interface ended up in ${D}/${STAGING_DIR_NATIVE} which is wrong. The
fix is to define a variable in recipe which is used in install rule by
talloc.
As well, LICENSE variable modified to reflect the real license:
LGPL-3.0
Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/talloc')
-rw-r--r-- | meta-oe/recipes-support/talloc/talloc/install-swig-interface-in-SWINGLIBDIR.patch | 23 | ||||
-rw-r--r-- | meta-oe/recipes-support/talloc/talloc_2.0.1.bb | 17 |
2 files changed, 37 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/talloc/talloc/install-swig-interface-in-SWINGLIBDIR.patch b/meta-oe/recipes-support/talloc/talloc/install-swig-interface-in-SWINGLIBDIR.patch new file mode 100644 index 000000000..e1339a078 --- /dev/null +++ b/meta-oe/recipes-support/talloc/talloc/install-swig-interface-in-SWINGLIBDIR.patch | |||
@@ -0,0 +1,23 @@ | |||
1 | Using the way swig interface is installed leads to a bad path in ${D}. | ||
2 | The interface ended up in ${D}/${STAGING_DIR_NATIVE} which is wrong. The | ||
3 | fix is to define a variable in recipe which is used in install rule by | ||
4 | talloc. | ||
5 | |||
6 | Upstream-Status: Inappropriate [build system specific] | ||
7 | Signed-off-by: Andrei Gherzan <andrei@gherzan.ro> | ||
8 | |||
9 | Index: talloc-2.0.1/talloc.mk | ||
10 | =================================================================== | ||
11 | --- talloc-2.0.1.orig/talloc.mk 2009-10-11 16:42:24.000000000 +0300 | ||
12 | +++ talloc-2.0.1/talloc.mk 2012-09-13 23:15:05.283539702 +0300 | ||
13 | @@ -23,8 +23,8 @@ | ||
14 | ${INSTALLCMD} -m 644 talloc.pc $(DESTDIR)$(libdir)/pkgconfig | ||
15 | if [ -f talloc.3 ];then ${INSTALLCMD} -d $(DESTDIR)$(mandir)/man3; fi | ||
16 | if [ -f talloc.3 ];then ${INSTALLCMD} -m 644 talloc.3 $(DESTDIR)$(mandir)/man3; fi | ||
17 | - which swig >/dev/null 2>&1 && ${INSTALLCMD} -d $(DESTDIR)`swig -swiglib` || true | ||
18 | - which swig >/dev/null 2>&1 && ${INSTALLCMD} -m 644 talloc.i $(DESTDIR)`swig -swiglib` || true | ||
19 | + which swig >/dev/null 2>&1 && ${INSTALLCMD} -d $(DESTDIR)/$(SWIGLIBDIR) || true | ||
20 | + which swig >/dev/null 2>&1 && ${INSTALLCMD} -m 644 talloc.i $(DESTDIR)/$(SWIGLIBDIR) || true | ||
21 | |||
22 | doc:: talloc.3 talloc.3.html | ||
23 | |||
diff --git a/meta-oe/recipes-support/talloc/talloc_2.0.1.bb b/meta-oe/recipes-support/talloc/talloc_2.0.1.bb index a69bd401e..6aa5a9e80 100644 --- a/meta-oe/recipes-support/talloc/talloc_2.0.1.bb +++ b/meta-oe/recipes-support/talloc/talloc_2.0.1.bb | |||
@@ -1,17 +1,19 @@ | |||
1 | DESCRIPTION = "Hierarchical, reference counted memory pool system with destructors" | 1 | DESCRIPTION = "Hierarchical, reference counted memory pool system with destructors" |
2 | HOMEPAGE = "http://talloc.samba.org" | 2 | HOMEPAGE = "http://talloc.samba.org" |
3 | LICENSE = "LGPL" | 3 | LICENSE = "LGPL-3.0" |
4 | LIC_FILES_CHKSUM = "file://NEWS;md5=5fe776b23a711c9153ee94bc87e47334" | 4 | LIC_FILES_CHKSUM = "file://NEWS;md5=5fe776b23a711c9153ee94bc87e47334" |
5 | 5 | ||
6 | inherit autotools pkgconfig | 6 | inherit autotools pkgconfig |
7 | 7 | ||
8 | SRC_URI = "http://samba.org/ftp/${BPN}/${BPN}-${PV}.tar.gz" | 8 | SRC_URI = "http://samba.org/ftp/${BPN}/${BPN}-${PV}.tar.gz \ |
9 | file://install-swig-interface-in-SWINGLIBDIR.patch \ | ||
10 | " | ||
9 | SRC_URI[md5sum] = "c6e736540145ca58cb3dcb42f91cf57b" | 11 | SRC_URI[md5sum] = "c6e736540145ca58cb3dcb42f91cf57b" |
10 | SRC_URI[sha256sum] = "5b810527405f29d54f50efd78bf2c89e318f2cd8bed001f22f2a1412fd27c9b4" | 12 | SRC_URI[sha256sum] = "5b810527405f29d54f50efd78bf2c89e318f2cd8bed001f22f2a1412fd27c9b4" |
11 | 13 | ||
12 | TARGET_CC_ARCH += "${LDFLAGS}" | 14 | TARGET_CC_ARCH += "${LDFLAGS}" |
13 | 15 | ||
14 | PR = "r1" | 16 | PR = "r2" |
15 | 17 | ||
16 | # autoreconf doesn't work well while reconfiguring included libreplace | 18 | # autoreconf doesn't work well while reconfiguring included libreplace |
17 | do_configure () { | 19 | do_configure () { |
@@ -19,9 +21,18 @@ do_configure () { | |||
19 | oe_runconf | 21 | oe_runconf |
20 | } | 22 | } |
21 | 23 | ||
24 | do_install_prepend() { | ||
25 | # Hack the way swig interface for talloc is installed | ||
26 | # This hack is accompanied by install-swig-interface-in-SWINGLIBDIR.patch | ||
27 | type swig > /dev/null 2>&1 && SWIGLIBDIR=`swig -swiglib` && SWIGLIBDIR=${SWIGLIBDIR##${STAGING_DIR_NATIVE}} && export SWIGLIBDIR || echo "No swig found" | ||
28 | } | ||
29 | |||
22 | do_install_append() { | 30 | do_install_append() { |
23 | install -d ${D}${libdir} | 31 | install -d ${D}${libdir} |
24 | ln -s libtalloc.so.2.0.1 ${D}${libdir}/libtalloc.so.2.0 | 32 | ln -s libtalloc.so.2.0.1 ${D}${libdir}/libtalloc.so.2.0 |
25 | ln -s libtalloc.so.2.0 ${D}${libdir}/libtalloc.so.2 | 33 | ln -s libtalloc.so.2.0 ${D}${libdir}/libtalloc.so.2 |
26 | ln -s libtalloc.so.2 ${D}${libdir}/libtalloc.so | 34 | ln -s libtalloc.so.2 ${D}${libdir}/libtalloc.so |
27 | } | 35 | } |
36 | |||
37 | PACKAGES += "${PN}-swig" | ||
38 | FILES_${PN}-swig += "${datadir}" | ||