summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/talloc
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/talloc
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/talloc')
-rw-r--r--meta-oe/recipes-support/talloc/talloc/install-swig-interface-in-SWINGLIBDIR.patch23
-rw-r--r--meta-oe/recipes-support/talloc/talloc/sepbuild.patch27
-rw-r--r--meta-oe/recipes-support/talloc/talloc_2.0.1.bb45
3 files changed, 95 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/talloc/talloc/install-swig-interface-in-SWINGLIBDIR.patch b/meta-oe/recipes-support/talloc/talloc/install-swig-interface-in-SWINGLIBDIR.patch
new file mode 100644
index 000000000..635c60e46
--- /dev/null
+++ b/meta-oe/recipes-support/talloc/talloc/install-swig-interface-in-SWINGLIBDIR.patch
@@ -0,0 +1,23 @@
1Using the way swig interface is installed leads to a bad path in ${D}.
2The interface ended up in ${D}/${STAGING_DIR_NATIVE} which is wrong. The
3fix is to define a variable in recipe which is used in install rule by
4talloc.
5
6Upstream-Status: Inappropriate [build system specific]
7Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
8
9Index: talloc-2.0.1/talloc.mk
10===================================================================
11--- talloc-2.0.1.orig/talloc.mk 2009-10-11 16:42:24.000000000 +0300
12+++ talloc-2.0.1/talloc.mk 2012-09-13 23:15:05.283539702 +0300
13@@ -23,8 +23,8 @@
14 ${INSTALLCMD} -m 644 talloc.pc $(DESTDIR)$(libdir)/pkgconfig
15 if [ -f talloc.3 ];then ${INSTALLCMD} -d $(DESTDIR)$(mandir)/man3; fi
16 if [ -f talloc.3 ];then ${INSTALLCMD} -m 644 talloc.3 $(DESTDIR)$(mandir)/man3; fi
17- which swig >/dev/null 2>&1 && ${INSTALLCMD} -d $(DESTDIR)`swig -swiglib` || true
18- which swig >/dev/null 2>&1 && ${INSTALLCMD} -m 644 talloc.i $(DESTDIR)`swig -swiglib` || true
19+ which swig >/dev/null 2>&1 && ${INSTALLCMD} -d $(DESTDIR)/$(SWIGLIBDIR) || true
20+ which swig >/dev/null 2>&1 && ${INSTALLCMD} -m 644 $(srcdir)/$(tallocdir)/talloc.i $(DESTDIR)/$(SWIGLIBDIR) || true
21
22 doc:: talloc.3 talloc.3.html
23
diff --git a/meta-oe/recipes-support/talloc/talloc/sepbuild.patch b/meta-oe/recipes-support/talloc/talloc/sepbuild.patch
new file mode 100644
index 000000000..05506c342
--- /dev/null
+++ b/meta-oe/recipes-support/talloc/talloc/sepbuild.patch
@@ -0,0 +1,27 @@
1Index: talloc-2.0.1/Makefile.in
2===================================================================
3--- talloc-2.0.1.orig/Makefile.in
4+++ talloc-2.0.1/Makefile.in
5@@ -33,8 +33,8 @@ EXPORTSFILE = @EXPORTSFILE@
6
7 all:: showflags $(EXTRA_TARGETS)
8
9-include $(tallocdir)/rules.mk
10-include $(tallocdir)/talloc.mk
11+include $(srcdir)/$(tallocdir)/rules.mk
12+include $(srcdir)/$(tallocdir)/talloc.mk
13
14 @TALLOC_COMPAT1_MK@
15
16Index: talloc-2.0.1/libtalloc.m4
17===================================================================
18--- talloc-2.0.1.orig/libtalloc.m4
19+++ talloc-2.0.1/libtalloc.m4
20@@ -33,6 +33,6 @@ if test $ac_cv_sizeof_size_t -lt $ac_cv_
21 fi
22
23 if test x"$VERSIONSCRIPT" != "x"; then
24- EXPORTSFILE=talloc.exports
25+ EXPORTSFILE=$srcdir/$tallocdir/talloc.exports
26 AC_SUBST(EXPORTSFILE)
27 fi
diff --git a/meta-oe/recipes-support/talloc/talloc_2.0.1.bb b/meta-oe/recipes-support/talloc/talloc_2.0.1.bb
new file mode 100644
index 000000000..7bbfbc291
--- /dev/null
+++ b/meta-oe/recipes-support/talloc/talloc_2.0.1.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
2HOMEPAGE = "http://talloc.samba.org"
3LICENSE = "LGPL-3.0"
4LIC_FILES_CHKSUM = "file://NEWS;md5=5fe776b23a711c9153ee94bc87e47334"
5
6inherit autotools pkgconfig
7
8SRC_URI = "http://samba.org/ftp/${BPN}/${BPN}-${PV}.tar.gz \
9 file://install-swig-interface-in-SWINGLIBDIR.patch \
10 file://sepbuild.patch \
11"
12SRC_URI[md5sum] = "c6e736540145ca58cb3dcb42f91cf57b"
13SRC_URI[sha256sum] = "5b810527405f29d54f50efd78bf2c89e318f2cd8bed001f22f2a1412fd27c9b4"
14
15TARGET_CC_ARCH += "${LDFLAGS}"
16
17PR = "r2"
18
19EXTRA_AUTORECONF = "--exclude=autopoint --exclude=aclocal"
20
21DEPENDS += "swig-native"
22
23do_install_prepend() {
24 # Hack the way swig interface for talloc is installed
25 # This hack is accompanied by install-swig-interface-in-SWINGLIBDIR.patch
26 if which swig > /dev/null; then
27 SWIGLIBDIR="$(echo $(readlink -f $(swig -swiglib)) | \
28 sed -e 's#^${STAGING_DIR_NATIVE}##')"
29 fi
30 if [ -n "$SWIGLIBDIR" ]; then
31 export SWIGLIBDIR
32 else
33 echo "No swig found"
34 fi
35}
36
37do_install_append() {
38 install -d ${D}${libdir}
39 ln -s libtalloc.so.2.0.1 ${D}${libdir}/libtalloc.so.2.0
40 ln -s libtalloc.so.2.0 ${D}${libdir}/libtalloc.so.2
41 ln -s libtalloc.so.2 ${D}${libdir}/libtalloc.so
42}
43
44PACKAGES += "${PN}-swig"
45FILES_${PN}-swig += "${datadir}"