summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/talloc/talloc
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/talloc/talloc
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/talloc/talloc')
-rw-r--r--meta-oe/recipes-support/talloc/talloc/install-swig-interface-in-SWINGLIBDIR.patch23
-rw-r--r--meta-oe/recipes-support/talloc/talloc/sepbuild.patch27
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/talloc/talloc/install-swig-interface-in-SWINGLIBDIR.patch b/meta-oe/recipes-support/talloc/talloc/install-swig-interface-in-SWINGLIBDIR.patch
new file mode 100644
index 000000000..635c60e46
--- /dev/null
+++ b/meta-oe/recipes-support/talloc/talloc/install-swig-interface-in-SWINGLIBDIR.patch
@@ -0,0 +1,23 @@
1Using the way swig interface is installed leads to a bad path in ${D}.
2The interface ended up in ${D}/${STAGING_DIR_NATIVE} which is wrong. The
3fix is to define a variable in recipe which is used in install rule by
4talloc.
5
6Upstream-Status: Inappropriate [build system specific]
7Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
8
9Index: talloc-2.0.1/talloc.mk
10===================================================================
11--- talloc-2.0.1.orig/talloc.mk 2009-10-11 16:42:24.000000000 +0300
12+++ talloc-2.0.1/talloc.mk 2012-09-13 23:15:05.283539702 +0300
13@@ -23,8 +23,8 @@
14 ${INSTALLCMD} -m 644 talloc.pc $(DESTDIR)$(libdir)/pkgconfig
15 if [ -f talloc.3 ];then ${INSTALLCMD} -d $(DESTDIR)$(mandir)/man3; fi
16 if [ -f talloc.3 ];then ${INSTALLCMD} -m 644 talloc.3 $(DESTDIR)$(mandir)/man3; fi
17- which swig >/dev/null 2>&1 && ${INSTALLCMD} -d $(DESTDIR)`swig -swiglib` || true
18- which swig >/dev/null 2>&1 && ${INSTALLCMD} -m 644 talloc.i $(DESTDIR)`swig -swiglib` || true
19+ which swig >/dev/null 2>&1 && ${INSTALLCMD} -d $(DESTDIR)/$(SWIGLIBDIR) || true
20+ which swig >/dev/null 2>&1 && ${INSTALLCMD} -m 644 $(srcdir)/$(tallocdir)/talloc.i $(DESTDIR)/$(SWIGLIBDIR) || true
21
22 doc:: talloc.3 talloc.3.html
23
diff --git a/meta-oe/recipes-support/talloc/talloc/sepbuild.patch b/meta-oe/recipes-support/talloc/talloc/sepbuild.patch
new file mode 100644
index 000000000..05506c342
--- /dev/null
+++ b/meta-oe/recipes-support/talloc/talloc/sepbuild.patch
@@ -0,0 +1,27 @@
1Index: talloc-2.0.1/Makefile.in
2===================================================================
3--- talloc-2.0.1.orig/Makefile.in
4+++ talloc-2.0.1/Makefile.in
5@@ -33,8 +33,8 @@ EXPORTSFILE = @EXPORTSFILE@
6
7 all:: showflags $(EXTRA_TARGETS)
8
9-include $(tallocdir)/rules.mk
10-include $(tallocdir)/talloc.mk
11+include $(srcdir)/$(tallocdir)/rules.mk
12+include $(srcdir)/$(tallocdir)/talloc.mk
13
14 @TALLOC_COMPAT1_MK@
15
16Index: talloc-2.0.1/libtalloc.m4
17===================================================================
18--- talloc-2.0.1.orig/libtalloc.m4
19+++ talloc-2.0.1/libtalloc.m4
20@@ -33,6 +33,6 @@ if test $ac_cv_sizeof_size_t -lt $ac_cv_
21 fi
22
23 if test x"$VERSIONSCRIPT" != "x"; then
24- EXPORTSFILE=talloc.exports
25+ EXPORTSFILE=$srcdir/$tallocdir/talloc.exports
26 AC_SUBST(EXPORTSFILE)
27 fi