diff options
author | Li xin <lixin.fnst@cn.fujitsu.com> | 2015-01-20 18:10:42 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-01-28 09:52:51 +0100 |
commit | c8f98b15d0a06938e36de91ebf8b2471e50d21d8 (patch) | |
tree | 9d86e5102d3c053b9f90efc3b3e25d62de197f29 /meta-oe/recipes-support/system-setup-keyboard | |
parent | b3cff5d52c53aed5a6ae50dc492b9543ab5e8b7f (diff) | |
download | meta-openembedded-c8f98b15d0a06938e36de91ebf8b2471e50d21d8.tar.gz |
system-setup-keyboard: add new recipe
system-setup-keyboard is a daemon to monitor the keyboard layout
configured in /etc/sysconfig/keyboard and transfer this into the
matching xorg.conf.d snippet.
Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/system-setup-keyboard')
-rw-r--r-- | meta-oe/recipes-support/system-setup-keyboard/system-setup-keyboard_0.8.8.bb | 29 |
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/system-setup-keyboard/system-setup-keyboard_0.8.8.bb b/meta-oe/recipes-support/system-setup-keyboard/system-setup-keyboard_0.8.8.bb new file mode 100644 index 000000000..d2199c2cf --- /dev/null +++ b/meta-oe/recipes-support/system-setup-keyboard/system-setup-keyboard_0.8.8.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | SUMMARY = "xorg.conf keyboard layout callout" | ||
2 | DESCRIPTION = "system-setup-keyboard is a daemon to monitor the keyboard layout configured in \ | ||
3 | /etc/sysconfig/keyboard and transfer this into the matching xorg.conf.d snippet." | ||
4 | |||
5 | HOMEPAGE = "https://git.fedorahosted.org/git/system-setup-keyboard.git" | ||
6 | SECTION = "Applications/System" | ||
7 | |||
8 | SRC_URI = "https://git.fedorahosted.org/cgit/${PN}.git/snapshot/${BP}.tar.gz" | ||
9 | SRC_URI[md5sum] = "399003968ccc739cddd9cc370af377a0" | ||
10 | SRC_URI[sha256sum] = "1ef6ef79c3588e85d7f42e99eb80a2e459f966284cf029c2d6fc1b645abcb860" | ||
11 | |||
12 | LICENSE = "MIT" | ||
13 | LIC_FILES_CHKSUM = "file://COPYING;md5=bf57969a59612c5aca007b340c49d3a2" | ||
14 | |||
15 | inherit pythonnative | ||
16 | |||
17 | DEPENDS = "glib-2.0 system-config-keyboard-native" | ||
18 | |||
19 | do_compile_prepend() { | ||
20 | ${PYTHON} -v get_layouts.py > keyboards.h | ||
21 | } | ||
22 | |||
23 | do_install() { | ||
24 | oe_runmake install DESTDIR=${D} | ||
25 | install -d ${D}/etc/X11/xorg.conf.d | ||
26 | touch ${D}/etc/X11/xorg.conf.d/00-system-setup-keyboard.conf | ||
27 | } | ||
28 | |||
29 | FILES_${PN} += "${systemd_unitdir}/system/${PN}.service" | ||