diff options
author | changqing.li@windriver.com <changqing.li@windriver.com> | 2018-06-29 14:22:16 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-06-29 07:00:52 -0700 |
commit | 6e47ace16f6914d8a0006c790a2dfdff02468ade (patch) | |
tree | 14c7647156e1a5c7cff963d431f4f9eb17596652 /meta-oe/recipes-support/syslog-ng | |
parent | 54aa4c4cdadb1c4a164dd76632091243566fb6f2 (diff) | |
download | meta-openembedded-6e47ace16f6914d8a0006c790a2dfdff02468ade.tar.gz |
syslog-ng: upgrade 3.15.1 -> 3.16.1
Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/syslog-ng')
3 files changed, 15 insertions, 83 deletions
diff --git a/meta-oe/recipes-support/syslog-ng/files/rename-PAGESIZE-variables-to-pagesize.patch b/meta-oe/recipes-support/syslog-ng/files/rename-PAGESIZE-variables-to-pagesize.patch deleted file mode 100644 index 56ffb4a06..000000000 --- a/meta-oe/recipes-support/syslog-ng/files/rename-PAGESIZE-variables-to-pagesize.patch +++ /dev/null | |||
@@ -1,72 +0,0 @@ | |||
1 | From 29f0de401b9df056c7eeb47a025c341654ca579d Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrej Valek <andrej.valek@siemens.com> | ||
3 | Date: Thu, 14 Jun 2018 08:54:14 +0200 | ||
4 | Subject: [PATCH] secret-storage: rename PAGESIZE variables to pagesize | ||
5 | |||
6 | PAGESIZE is a define in some libc libraries, which conflicts with these | ||
7 | local variables. | ||
8 | |||
9 | Upstream-Status: Submitted [https://github.com/balabit/syslog-ng/pull/2111] | ||
10 | |||
11 | Signed-off-by: Andrej Valek <andrej.valek@siemens.com> | ||
12 | Signed-off-by: Marko Peter <peter.marko@siemens.com> | ||
13 | --- | ||
14 | lib/secret-storage/nondumpable-allocator.c | 4 ++-- | ||
15 | lib/secret-storage/tests/test_nondumpable_allocator.c | 6 +++--- | ||
16 | lib/secret-storage/tests/test_secret_storage.c | 4 ++-- | ||
17 | 3 files changed, 7 insertions(+), 7 deletions(-) | ||
18 | |||
19 | diff --git a/lib/secret-storage/nondumpable-allocator.c b/lib/secret-storage/nondumpable-allocator.c | ||
20 | index 07d94fbb0..314ce571f 100644 | ||
21 | --- a/lib/secret-storage/nondumpable-allocator.c | ||
22 | +++ b/lib/secret-storage/nondumpable-allocator.c | ||
23 | @@ -104,8 +104,8 @@ gpointer | ||
24 | nondumpable_buffer_alloc(gsize len) | ||
25 | { | ||
26 | gsize minimum_size = len + ALLOCATION_HEADER_SIZE; | ||
27 | - gsize PAGESIZE = sysconf(_SC_PAGE_SIZE); | ||
28 | - gsize alloc_size = round_to_nearest(minimum_size, PAGESIZE); | ||
29 | + gsize pagesize = sysconf(_SC_PAGE_SIZE); | ||
30 | + gsize alloc_size = round_to_nearest(minimum_size, pagesize); | ||
31 | |||
32 | Allocation *buffer = _mmap(alloc_size); | ||
33 | if (!buffer) | ||
34 | diff --git a/lib/secret-storage/tests/test_nondumpable_allocator.c b/lib/secret-storage/tests/test_nondumpable_allocator.c | ||
35 | index 6ef5b3035..a20b287ff 100644 | ||
36 | --- a/lib/secret-storage/tests/test_nondumpable_allocator.c | ||
37 | +++ b/lib/secret-storage/tests/test_nondumpable_allocator.c | ||
38 | @@ -34,10 +34,10 @@ Test(nondumpableallocator, malloc_realloc_free) | ||
39 | strcpy(buffer, test_string); | ||
40 | cr_assert_str_eq(buffer, test_string); | ||
41 | |||
42 | - const gsize PAGESIZE = sysconf(_SC_PAGE_SIZE); | ||
43 | - gpointer buffer_realloc = nondumpable_buffer_realloc(buffer, 2*PAGESIZE); | ||
44 | + const gsize pagesize = sysconf(_SC_PAGE_SIZE); | ||
45 | + gpointer buffer_realloc = nondumpable_buffer_realloc(buffer, 2*pagesize); | ||
46 | cr_assert_str_eq(buffer_realloc, test_string); | ||
47 | - ((gchar *)buffer_realloc)[2*PAGESIZE] = 'a'; | ||
48 | + ((gchar *)buffer_realloc)[2*pagesize] = 'a'; | ||
49 | |||
50 | nondumpable_buffer_free(buffer_realloc); | ||
51 | } | ||
52 | diff --git a/lib/secret-storage/tests/test_secret_storage.c b/lib/secret-storage/tests/test_secret_storage.c | ||
53 | index 5297d4f60..89122cada 100644 | ||
54 | --- a/lib/secret-storage/tests/test_secret_storage.c | ||
55 | +++ b/lib/secret-storage/tests/test_secret_storage.c | ||
56 | @@ -263,11 +263,11 @@ Test(secretstorage, test_rlimit) | ||
57 | cr_assert(!getrlimit(RLIMIT_MEMLOCK, &locked_limit)); | ||
58 | locked_limit.rlim_cur = MIN(locked_limit.rlim_max, 64 * 1024); | ||
59 | cr_assert(!setrlimit(RLIMIT_MEMLOCK, &locked_limit)); | ||
60 | - const gsize PAGESIZE = sysconf(_SC_PAGE_SIZE); | ||
61 | + const gsize pagesize = sysconf(_SC_PAGE_SIZE); | ||
62 | |||
63 | gchar *key_fmt = g_strdup("keyXXX"); | ||
64 | int i = 0; | ||
65 | - int for_limit = locked_limit.rlim_cur/PAGESIZE; | ||
66 | + int for_limit = locked_limit.rlim_cur/pagesize; | ||
67 | for (; i < for_limit; i++) | ||
68 | { | ||
69 | sprintf(key_fmt, "key%03d", i); | ||
70 | -- | ||
71 | 2.11.0 | ||
72 | |||
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng_3.15.1.bb b/meta-oe/recipes-support/syslog-ng/syslog-ng_3.15.1.bb deleted file mode 100644 index 6d48cc331..000000000 --- a/meta-oe/recipes-support/syslog-ng/syslog-ng_3.15.1.bb +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | require syslog-ng.inc | ||
2 | |||
3 | SRC_URI += " \ | ||
4 | file://fix-config-libnet.patch \ | ||
5 | file://fix-invalid-ownership.patch \ | ||
6 | file://syslog-ng.service-the-syslog-ng-service.patch \ | ||
7 | file://rename-PAGESIZE-variables-to-pagesize.patch \ | ||
8 | " | ||
9 | |||
10 | SRC_URI[md5sum] = "da59a65cd5e293ec0fa3d3ecf4984af9" | ||
11 | SRC_URI[sha256sum] = "a2dabd28674e2b558e4fb92484ad111d77bf7150070aa28556827130b479f9ef" | ||
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng_3.16.1.bb b/meta-oe/recipes-support/syslog-ng/syslog-ng_3.16.1.bb new file mode 100644 index 000000000..2fd57fb93 --- /dev/null +++ b/meta-oe/recipes-support/syslog-ng/syslog-ng_3.16.1.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | require syslog-ng.inc | ||
2 | |||
3 | SRC_URI = "https://github.com/balabit/syslog-ng/releases/download/${BP}/${BP}.tar.gz \ | ||
4 | file://syslog-ng.conf.systemd \ | ||
5 | file://syslog-ng.conf.sysvinit \ | ||
6 | file://initscript \ | ||
7 | file://volatiles.03_syslog-ng \ | ||
8 | file://configure.ac-add-option-enable-thread-tls-to-manage-.patch \ | ||
9 | file://fix-config-libnet.patch \ | ||
10 | file://fix-invalid-ownership.patch \ | ||
11 | file://syslog-ng.service-the-syslog-ng-service.patch \ | ||
12 | " | ||
13 | |||
14 | SRC_URI[md5sum] = "72d44ad02c2e9ba0748b3ecd3f15a7ff" | ||
15 | SRC_URI[sha256sum] = "c7ee6f1d5e98d86f191964e580111bfa71081ecbb3275cea035bbba177b73a29" | ||