summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/start-stop-daemon
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/start-stop-daemon
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/start-stop-daemon')
-rw-r--r--meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb b/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb
new file mode 100644
index 000000000..c232474a0
--- /dev/null
+++ b/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Debian's start-stop-daemon utility extracted from the dpkg \
2package"
3LICENSE = "PD"
4LIC_FILES_CHKSUM = "file://utils/start-stop-daemon.c;md5=a963623e4588f70122865aaa7a370ce4"
5# start-stop-daemon is usually shipped by dpkg
6DEPENDS = "ncurses"
7RCONFLICS_${PN} = "dpkg"
8
9SRC_URI = "http://sources.openembedded.org/dpkg_${PV}.tar.bz2"
10SRC_URI[md5sum] = "d211a84f38987771a49ad1c0f144334a"
11SRC_URI[sha256sum] = "2a3d4ba83c743b3f004533fdd52372cb7b22f5c1da2042d0a31bbcc2b54c0ea5"
12
13inherit autotools gettext pkgconfig
14
15S = "${WORKDIR}/dpkg-${PV}"
16
17EXTRA_OECONF = " \
18 --with-start-stop-daemon \
19 --without-bz2 \
20 --without-install-info \
21 --without-selinux \
22 --without-update-alternatives \
23"
24
25do_install_append () {
26 # remove everything that is not related to start-stop-daemon, since there
27 # is no explicit rule for only installing ssd
28 find ${D} -type f -not -name "*start-stop-daemon*" -exec rm {} \;
29 find ${D} -depth -type d -empty -exec rmdir {} \;
30}