summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/sqlite
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/sqlite
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/sqlite')
-rw-r--r--meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch32
-rw-r--r--meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_no_tcl.patch20
-rw-r--r--meta-oe/recipes-support/sqlite/sqlite-2.8.17/sqlite.pc12
-rw-r--r--meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb59
4 files changed, 123 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch b/meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch
new file mode 100644
index 000000000..914422f1d
--- /dev/null
+++ b/meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch
@@ -0,0 +1,32 @@
1diff -urN sqlite-2.8.17.orig/main.mk sqlite-2.8.17/main.mk
2--- sqlite-2.8.17.orig/main.mk 2005-04-23 22:43:23.000000000 +0000
3+++ sqlite-2.8.17/main.mk 2009-04-02 20:10:36.000000000 +0000
4@@ -139,7 +139,7 @@
5 # This is the default Makefile target. The objects listed here
6 # are what get build when you type just "make" with no arguments.
7 #
8-all: sqlite.h config.h libsqlite.a sqlite$(EXE)
9+all: sqlite.h config.h libsqlite.so sqlite$(EXE)
10
11 # Generate the file "last_change" which contains the date of change
12 # of the most recently modified source code file
13@@ -148,13 +148,12 @@
14 cat $(SRC) | grep '$$Id: ' | sort +4 | tail -1 \
15 | awk '{print $$5,$$6}' >last_change
16
17-libsqlite.a: $(LIBOBJ)
18- $(AR) libsqlite.a $(LIBOBJ)
19- $(RANLIB) libsqlite.a
20-
21-sqlite$(EXE): $(TOP)/src/shell.c libsqlite.a sqlite.h
22- $(TCCX) $(READLINE_FLAGS) -o sqlite$(EXE) $(TOP)/src/shell.c \
23- libsqlite.a $(LIBREADLINE) $(THREADLIB)
24+libsqlite.so: $(LIBOBJ)
25+ $(CC) $(LDFLAGS) -shared -o libsqlite.so -Wl,-soname,libsqlite.so.0 $(LIBOBJ)
26+
27+sqlite$(EXE): $(TOP)/src/shell.c libsqlite.so sqlite.h
28+ $(TCCX) $(LDFLAGS) $(READLINE_FLAGS) -o sqlite$(EXE) $(TOP)/src/shell.c \
29+ -lsqlite $(LIBREADLINE) $(THREADLIB)
30
31 sqlite_analyzer$(EXE): $(TOP)/src/tclsqlite.c libsqlite.a $(TESTSRC) \
32 $(TOP)/tool/spaceanal.tcl
diff --git a/meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_no_tcl.patch b/meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_no_tcl.patch
new file mode 100644
index 000000000..b84b6486e
--- /dev/null
+++ b/meta-oe/recipes-support/sqlite/sqlite-2.8.17/mainmk_no_tcl.patch
@@ -0,0 +1,20 @@
1diff -bur sqlite-2.8.17~orig/main.mk sqlite-2.8.17/main.mk
2--- sqlite-2.8.17~orig/main.mk 2006-02-13 04:09:33.000000000 -0600
3+++ sqlite-2.8.17/main.mk 2006-02-13 04:15:42.000000000 -0600
4@@ -58,7 +58,7 @@
5 expr.o func.o hash.o insert.o \
6 main.o opcodes.o os.o pager.o parse.o pragma.o printf.o random.o \
7 select.o table.o tokenize.o trigger.o update.o util.o \
8- vacuum.o vdbe.o vdbeaux.o where.o tclsqlite.o
9+ vacuum.o vdbe.o vdbeaux.o where.o
10
11 # All of the source code files.
12 #
13@@ -91,7 +91,6 @@
14 $(TOP)/src/sqlite.h.in \
15 $(TOP)/src/sqliteInt.h \
16 $(TOP)/src/table.c \
17- $(TOP)/src/tclsqlite.c \
18 $(TOP)/src/tokenize.c \
19 $(TOP)/src/trigger.c \
20 $(TOP)/src/update.c \
diff --git a/meta-oe/recipes-support/sqlite/sqlite-2.8.17/sqlite.pc b/meta-oe/recipes-support/sqlite/sqlite-2.8.17/sqlite.pc
new file mode 100644
index 000000000..6bc742eec
--- /dev/null
+++ b/meta-oe/recipes-support/sqlite/sqlite-2.8.17/sqlite.pc
@@ -0,0 +1,12 @@
1# Package Information for pkg-config
2
3prefix=/usr
4exec_prefix=${prefix}
5libdir=${exec_prefix}/lib
6includedir=${prefix}/include
7
8Name: SQLite
9Description: SQL database engine
10Version: 2.8.17
11Libs: -L${libdir} -lsqlite
12Cflags: -I${includedir}
diff --git a/meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb b/meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb
new file mode 100644
index 000000000..e6e14c2ad
--- /dev/null
+++ b/meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb
@@ -0,0 +1,59 @@
1SUMMARY = "An Embeddable SQL Database Engine"
2HOMEPAGE = "http://www.sqlite.org/"
3SECTION = "libs"
4DEPENDS = "readline ncurses"
5LICENSE = "PD"
6LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=10;md5=e98469a8efa024a38ad5b2e4b92f4a96"
7
8PR = "r7"
9
10SRC_URI = "http://www.hwaci.com/sw/sqlite/sqlite-${PV}.tar.gz \
11 file://mainmk_build_dynamic.patch \
12 file://mainmk_no_tcl.patch \
13 file://sqlite.pc"
14
15SOURCES = "attach.o auth.o btree.o btree_rb.o build.o copy.o date.o delete.o \
16 expr.o func.o hash.o insert.o main.o opcodes.o os.o pager.o \
17 parse.o pragma.o printf.o random.o select.o table.o tokenize.o \
18 trigger.o update.o util.o vacuum.o vdbe.o vdbeaux.o where.o"
19
20inherit autotools pkgconfig
21
22do_configure() {
23 echo "main.mk is patched, no need to configure"
24 # make pkgconfig.bbclass pick this up
25 cp ${WORKDIR}/sqlite.pc ${S}
26}
27
28do_compile() {
29 oe_runmake -f ${S}/Makefile.linux-gcc \
30 TOP="${S}" \
31 BCC="${BUILD_CC}" \
32 TCC="${CC}" \
33 OPTS="-fPIC -D'INTPTR_TYPE=int'" \
34 TCL_FLAGS= LIBTCL= \
35 READLINE_FLAGS="-DHAVE_READLINE=1 -I${STAGING_INCDIR}" \
36 LIBREADLINE="-L. -L${STAGING_LIBDIR} -lreadline -lncurses"
37}
38
39do_install() {
40 install -d ${D}${libdir} ${D}${bindir}
41 install sqlite ${D}${bindir}
42 install -m 0755 libsqlite.so ${D}${libdir}/libsqlite.so.0.8.6
43 ln -sf libsqlite.so.0.8.6 ${D}${libdir}/libsqlite.so
44 ln -sf libsqlite.so.0.8.6 ${D}${libdir}/libsqlite.so.0
45 ln -sf libsqlite.so.0.8.6 ${D}${libdir}/libsqlite.so.0.8
46 install -d ${D}${includedir}
47 install -m 0644 sqlite.h ${D}${includedir}/sqlite.h
48 install -d ${D}${libdir}/pkgconfig
49 install -m 0644 ${S}/sqlite.pc ${D}${libdir}/pkgconfig/sqlite.pc
50}
51
52PACKAGES += "${PN}-bin"
53FILES_${PN}-bin = "${bindir}/*"
54FILES_${PN} = "${libdir}/*.so.*"
55
56SRC_URI[md5sum] = "838dbac20b56d2c4292e98848505a05b"
57SRC_URI[sha256sum] = "3f35ebfb67867fb5b583a03e480f900206af637efe7179b32294a6a0cf806f37"
58
59BBCLASSEXTEND = "native"