diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-03-17 21:41:22 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-03-17 21:41:22 +0100 |
commit | c58cc7d3796dcee6e93885c835ed04cb566abeb2 (patch) | |
tree | 3eea4d4ef6a4ef79e0f4e025d7012c1a5cc38835 /meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb | |
parent | eec6ab97f712e06eb52c9f7c99e19ffab3ce9d74 (diff) | |
download | meta-openembedded-c58cc7d3796dcee6e93885c835ed04cb566abeb2.tar.gz |
move layer into meta-oe in preparation for future splits
As per TSC decision
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb')
-rw-r--r-- | meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb | 60 |
1 files changed, 60 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb b/meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb new file mode 100644 index 000000000..75678f629 --- /dev/null +++ b/meta-oe/recipes-support/sqlite/sqlite_2.8.17.bb | |||
@@ -0,0 +1,60 @@ | |||
1 | DESCRIPTION = "An Embeddable SQL Database Engine" | ||
2 | HOMEPAGE = "http://www.sqlite.org/" | ||
3 | SECTION = "libs" | ||
4 | PRIORITY = "optional" | ||
5 | DEPENDS = "readline ncurses" | ||
6 | LICENSE = "PD" | ||
7 | LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=10;md5=e98469a8efa024a38ad5b2e4b92f4a96" | ||
8 | |||
9 | PR = "r7" | ||
10 | |||
11 | SRC_URI = "http://www.hwaci.com/sw/sqlite/sqlite-${PV}.tar.gz \ | ||
12 | file://mainmk_build_dynamic.patch \ | ||
13 | file://mainmk_no_tcl.patch \ | ||
14 | file://sqlite.pc" | ||
15 | |||
16 | SOURCES = "attach.o auth.o btree.o btree_rb.o build.o copy.o date.o delete.o \ | ||
17 | expr.o func.o hash.o insert.o main.o opcodes.o os.o pager.o \ | ||
18 | parse.o pragma.o printf.o random.o select.o table.o tokenize.o \ | ||
19 | trigger.o update.o util.o vacuum.o vdbe.o vdbeaux.o where.o" | ||
20 | |||
21 | inherit autotools pkgconfig | ||
22 | |||
23 | do_configure() { | ||
24 | echo "main.mk is patched, no need to configure" | ||
25 | # make pkgconfig.bbclass pick this up | ||
26 | mv ${WORKDIR}/sqlite.pc ${S} | ||
27 | } | ||
28 | |||
29 | do_compile() { | ||
30 | oe_runmake -f Makefile.linux-gcc \ | ||
31 | TOP="${S}" \ | ||
32 | BCC="${BUILD_CC}" \ | ||
33 | TCC="${CC}" \ | ||
34 | OPTS="-fPIC -D'INTPTR_TYPE=int'" \ | ||
35 | TCL_FLAGS= LIBTCL= \ | ||
36 | READLINE_FLAGS="-DHAVE_READLINE=1 -I${STAGING_INCDIR}" \ | ||
37 | LIBREADLINE="-L. -L${STAGING_LIBDIR} -lreadline -lncurses" | ||
38 | } | ||
39 | |||
40 | do_install() { | ||
41 | install -d ${D}${libdir} ${D}${bindir} | ||
42 | install sqlite ${D}${bindir} | ||
43 | install -m 0755 libsqlite.so ${D}${libdir}/libsqlite.so.0.8.6 | ||
44 | ln -sf libsqlite.so.0.8.6 ${D}${libdir}/libsqlite.so | ||
45 | ln -sf libsqlite.so.0.8.6 ${D}${libdir}/libsqlite.so.0 | ||
46 | ln -sf libsqlite.so.0.8.6 ${D}${libdir}/libsqlite.so.0.8 | ||
47 | install -d ${D}${includedir} | ||
48 | install -m 0644 sqlite.h ${D}${includedir}/sqlite.h | ||
49 | install -d ${D}${libdir}/pkgconfig | ||
50 | install -m 0644 ${S}/sqlite.pc ${D}${libdir}/pkgconfig/sqlite.pc | ||
51 | } | ||
52 | |||
53 | PACKAGES += "${PN}-bin" | ||
54 | FILES_${PN}-bin = "${bindir}/*" | ||
55 | FILES_${PN} = "${libdir}/*.so.*" | ||
56 | |||
57 | SRC_URI[md5sum] = "838dbac20b56d2c4292e98848505a05b" | ||
58 | SRC_URI[sha256sum] = "3f35ebfb67867fb5b583a03e480f900206af637efe7179b32294a6a0cf806f37" | ||
59 | |||
60 | BBCLASSEXTEND = "native" | ||